summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/amap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/amap')
-rw-r--r--net-analyzer/amap/Manifest1
-rw-r--r--net-analyzer/amap/amap-5.4.ebuild73
-rw-r--r--net-analyzer/amap/files/4.8-system-pcre.patch45
-rw-r--r--net-analyzer/amap/metadata.xml5
4 files changed, 124 insertions, 0 deletions
diff --git a/net-analyzer/amap/Manifest b/net-analyzer/amap/Manifest
new file mode 100644
index 000000000000..5b4f82e11b63
--- /dev/null
+++ b/net-analyzer/amap/Manifest
@@ -0,0 +1 @@
+DIST amap-5.4.tar.gz 263331 SHA256 a75ea58de75034de6b10b0de0065ec88e32f9e9af11c7d69edbffc4da9a5b059 SHA512 e1a9f03940eded3eedad0028786f4ea6c18077072d52eb2f843ef0b4ff736bf1766c4bdb4eff52d3a8f6038d8f795e39be1c15bcae8283ddae8f40a7fff8647d WHIRLPOOL a7f08440d4e9ccf8ef1909aecebd95bb7a2bb7ddb5917d76b796e146821fe2d962518673faedd9f7665e18b97302e5ac50953f875473dd41328e1b5e77996240
diff --git a/net-analyzer/amap/amap-5.4.ebuild b/net-analyzer/amap/amap-5.4.ebuild
new file mode 100644
index 000000000000..3c628314531e
--- /dev/null
+++ b/net-analyzer/amap/amap-5.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A network scanning tool for pentesters"
+HOMEPAGE="https://www.thc.org/thc-amap/"
+SRC_URI="https://www.thc.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE="ssl"
+
+DEPEND="
+ dev-libs/libpcre
+ ssl? ( >=dev-libs/openssl-0.9.6j )
+"
+RDEPEND="
+ ${DEPEND}
+ !sci-biology/amap
+"
+
+src_prepare() {
+ rm -r pcre-3.9 || die
+ sed -i -e "s:etc/:share/amap/:g" amap-lib.c || die
+ # Above change requires below change. See sources...
+ sed -i '/strlen(AMAP_PREFIX/s: 5 : 12 :' amap-lib.c || die
+ sed -i 's:/usr/local:/usr:' amap.h || die
+ # Files to be updated are at different location, bug 207839.
+ sed -i '/AMAP_RESOURCE/s:www:freeworld:' amap.h || die
+
+ sed -i '/DATADIR/s:/etc:/share/amap:' Makefile.am || die
+
+ epatch "${FILESDIR}"/4.8-system-pcre.patch
+}
+
+src_configure() {
+ # non-autotools configure script
+ ./configure || die
+ sed -i \
+ -e '/^XDEFINES=/s:=.*:=:' \
+ -e '/^XLIBS=/s:=.*:=:' \
+ -e '/^XLIBPATHS/s:=.*:=:' \
+ -e '/^XIPATHS=/s:=.*:=:' \
+ -e "/^CC=/d" \
+ Makefile || die
+ if use ssl ; then
+ sed -i \
+ -e '/^XDEFINES=/s:=:=-DOPENSSL:' \
+ -e '/^XLIBS=/s:=:=-lcrypto -lssl:' \
+ Makefile || die
+ fi
+ sed -i Makefile \
+ -e '/-o amap/{s|(OPT) |(OPT) $(LDFLAGS) |g}' \
+ || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) OPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin amap amapcrap
+ insinto /usr/share/amap
+ doins appdefs.*
+
+ doman ${PN}.1
+ dodoc README TODO CHANGES
+}
diff --git a/net-analyzer/amap/files/4.8-system-pcre.patch b/net-analyzer/amap/files/4.8-system-pcre.patch
new file mode 100644
index 000000000000..097bfbf45eb5
--- /dev/null
+++ b/net-analyzer/amap/files/4.8-system-pcre.patch
@@ -0,0 +1,45 @@
+diff --exclude='*~' -urN amap-4.8.orig/amap-inc.h amap-4.8/amap-inc.h
+--- amap-4.8.orig/amap-inc.h 2005-02-21 21:47:47.251638320 -0500
++++ amap-4.8/amap-inc.h 2005-02-21 21:48:27.774477912 -0500
+@@ -20,7 +20,7 @@
+ #include <errno.h>
+ #include <sys/resource.h>
+ #include <sys/wait.h>
+-#include "pcre-3.9/pcre.h"
++#include <pcre.h>
+ #ifdef OPENSSL
+ #include <openssl/ssl.h>
+ #include <openssl/err.h>
+diff --exclude='*~' -urN amap-4.8.orig/configure amap-4.8/configure
+--- amap-4.8.orig/configure 2005-02-21 21:47:47.240639992 -0500
++++ amap-4.8/configure 2005-02-21 21:48:41.379409648 -0500
+@@ -13,10 +13,6 @@
+ exit 0
+ fi
+
+-cd pcre-3.9 || exit 1
+-./configure || exit 1
+-cd ..
+-
+ echo
+ echo
+ echo "Starting amap auto configuration ..."
+diff --exclude='*~' -urN amap-4.8.orig/Makefile.am amap-4.8/Makefile.am
+--- amap-4.8.orig/Makefile.am 2005-02-21 21:47:47.242639688 -0500
++++ amap-4.8/Makefile.am 2005-02-21 21:49:16.070135856 -0500
+@@ -1,5 +1,5 @@
+ CC=gcc
+-LIB=-lpcre -L./pcre-3.9/ -I./pcre-3.9/
++LIB=-lpcre
+ OPT=-O2
+ OPT_DEBUG=-ggdb -Wall -lefence
+ BINDIR=/bin
+@@ -7,7 +7,7 @@
+ MANDIR=/man/man1
+ SCRIPTS=appdefs.trig appdefs.resp appdefs.rpc
+ MANPAGE=amap.1
+-all: pcre strip
++all: amap amapcrap
+
+ pcre:
+ cd pcre-3.9 && make
diff --git a/net-analyzer/amap/metadata.xml b/net-analyzer/amap/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/amap/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>