summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCristian Othón Martínez Vera <cfuga@cfuga.mx>2022-06-27 13:59:03 -0500
committerSam James <sam@gentoo.org>2022-06-28 00:20:48 +0100
commit840c8861d9d4aa90721853527d0325628d5b3c46 (patch)
tree9cbd7d473564ae73521c6caa3cba5fde26440394 /net-analyzer/tcpreplay
parentnet-libs/libssh: fix musl build with USE="test" (diff)
downloadgentoo-840c8861d9d4aa90721853527d0325628d5b3c46.tar.gz
gentoo-840c8861d9d4aa90721853527d0325628d5b3c46.tar.bz2
gentoo-840c8861d9d4aa90721853527d0325628d5b3c46.zip
net-analyzer/tcpreplay: fix musl build
* Add sys-libs/fts-standalone as dependency * Append the flag "-lfts" for compilation Signed-off-by: Cristian Othón Martínez Vera <cfuga@cfuga.mx> Bug: https://bugs.gentoo.org/836577 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.4.1.ebuild4
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-9999.ebuild29
2 files changed, 23 insertions, 10 deletions
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.4.1.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.4.1.ebuild
index f3f9e2d4d05c..931ea85bf4a9 100644
--- a/net-analyzer/tcpreplay/tcpreplay-4.4.1.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-4.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
@@ -29,6 +29,7 @@ BDEPEND="
DEPEND="
dev-libs/libdnet
>=net-libs/libpcap-0.9
+ elibc_musl? ( sys-libs/fts-standalone )
pcapnav? ( net-libs/libpcapnav )
tcpdump? ( net-analyzer/tcpdump )
"
@@ -57,6 +58,7 @@ src_prepare() {
}
src_configure() {
+ use elibc_musl && append-flags "-lfts"
# By default it uses static linking. Avoid that, bug #252940
econf \
$(use_enable debug) \
diff --git a/net-analyzer/tcpreplay/tcpreplay-9999.ebuild b/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
index ab3477f795b6..01eca400dbe0 100644
--- a/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-9999.ebuild
@@ -1,13 +1,20 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools git-r3
+inherit autotools flag-o-matic
DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
-EGIT_REPO_URI="https://github.com/appneta/tcpreplay"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/appneta/tcpreplay"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~sparc ~x86"
+fi
+
S="${WORKDIR}"/${P/_/-}
LICENSE="BSD GPL-3"
@@ -22,6 +29,7 @@ BDEPEND="
DEPEND="
dev-libs/libdnet
>=net-libs/libpcap-0.9
+ elibc_musl? ( sys-libs/fts-standalone )
pcapnav? ( net-libs/libpcapnav )
tcpdump? ( net-analyzer/tcpdump )
"
@@ -31,6 +39,7 @@ DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
PATCHES=(
"${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+ "${FILESDIR}"/${PN}-4.4.1-fix-bashism-configure.patch
)
src_prepare() {
@@ -49,13 +58,14 @@ src_prepare() {
}
src_configure() {
- # By default it uses static linking. Avoid that, bug 252940
+ use elibc_musl && append-flags "-lfts"
+ # By default it uses static linking. Avoid that, bug #252940
econf \
$(use_enable debug) \
$(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config) \
$(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump) \
- --disable-local-libopts \
--enable-dynamic-link \
+ --enable-local-libopts \
--enable-shared \
--with-libdnet \
--with-testnic2=lo \
@@ -63,14 +73,15 @@ src_configure() {
}
src_test() {
- if [[ ! ${EUID} -eq 0 ]]; then
- ewarn "Some tests will be disabled due to FEATURES=userpriv"
+ if [[ ! ${EUID} -eq 0 ]] ; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
ewarn "To run all tests issue the following command as root:"
ewarn " # make -C ${S}/test"
emake -j1 -C test tcpprep
else
emake -j1 test || {
- ewarn "Note that some tests require eth0 iface to be up." ;
- die "self test failed - see ${S}/test/test.log" ; }
+ ewarn "Note that some tests require eth0 iface to be up."
+ die "self test failed - see ${S}/test/test.log"
+ }
fi
}