summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-02-07 11:49:59 -0600
committerBen Kohler <bkohler@gentoo.org>2019-02-07 11:50:16 -0600
commit4b42f9409144423996b0240fbc49654a15788112 (patch)
tree6956685eb23071fd54041600ffdd93db03c9986b /net-analyzer
parentdev-db/lib_mysqludf_* dev-db/mysql-udf-*: Last rites (diff)
downloadgentoo-4b42f9409144423996b0240fbc49654a15788112.tar.gz
gentoo-4b42f9409144423996b0240fbc49654a15788112.tar.bz2
gentoo-4b42f9409144423996b0240fbc49654a15788112.zip
net-analyzer/iftop: revbump for MAC formatting patch
Closes: https://bugs.gentoo.org/661890 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/iftop/files/iftop-1.0_pre4-fix-MAC-formatting.patch22
-rw-r--r--net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild45
2 files changed, 67 insertions, 0 deletions
diff --git a/net-analyzer/iftop/files/iftop-1.0_pre4-fix-MAC-formatting.patch b/net-analyzer/iftop/files/iftop-1.0_pre4-fix-MAC-formatting.patch
new file mode 100644
index 000000000000..d68a8095dce7
--- /dev/null
+++ b/net-analyzer/iftop/files/iftop-1.0_pre4-fix-MAC-formatting.patch
@@ -0,0 +1,22 @@
+From: Xiaoguang Sun <sun.xiaoguang@yoyosys.com>
+Date: Tue, 11 Mar 2014 13:18:46 +0100
+Subject: MAC address format
+
+Forwarded: http://lists.beasts.org/pipermail/iftop-users/2014-March/000413.html
+---
+ iftop.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/iftop.c b/iftop.c
+index a090dcf..883782e 100644
+--- a/iftop.c
++++ b/iftop.c
+@@ -713,7 +713,7 @@ void packet_init() {
+ if(have_hw_addr) {
+ fprintf(stderr, "MAC address is:");
+ for (i = 0; i < 6; ++i)
+- fprintf(stderr, "%c%02x", i ? ':' : ' ', (unsigned int)if_hw_addr[i]);
++ fprintf(stderr, "%c%02x", i ? ':' : ' ', (unsigned char)if_hw_addr[i]);
+ fprintf(stderr, "\n");
+ }
+
diff --git a/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild b/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
new file mode 100644
index 000000000000..890ba6ff2aeb
--- /dev/null
+++ b/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="display bandwidth usage on an interface"
+SRC_URI="http://www.ex-parrot.com/pdw/iftop/download/${P/_/}.tar.gz"
+HOMEPAGE="http://www.ex-parrot.com/pdw/iftop/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+S="${WORKDIR}"/${P/_/}
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.ac.patch
+ "${FILESDIR}"/${P}-Makefile.am.patch
+ "${FILESDIR}"/${P}-tsent-set-but-not-used.patch
+ "${FILESDIR}"/${P}-ip6.arpa.patch
+ "${FILESDIR}"/${P}-fix-MAC-formatting.patch
+)
+
+src_prepare() {
+ default
+ # bug 490168
+ cat "${FILESDIR}"/ax_pthread.m4 >> "${S}"/acinclude.m4 || die
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin iftop
+ doman iftop.8
+
+ dodoc AUTHORS ChangeLog README "${FILESDIR}"/iftoprc
+}