summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-10-16 06:37:13 +0200
committerJeroen Roovers <jer@gentoo.org>2015-10-16 06:37:39 +0200
commit6312082dd25ab32a275d33330a18bee445486957 (patch)
tree5d4f31436192c1e2da1a54a19bea74bee2c0dc3c /net-analyzer
parentsys-auth/keystone: put caps on liberty (diff)
downloadgentoo-6312082dd25ab32a275d33330a18bee445486957.tar.gz
gentoo-6312082dd25ab32a275d33330a18bee445486957.tar.bz2
gentoo-6312082dd25ab32a275d33330a18bee445486957.zip
net-analyzer/nmap: Work around Makefile fail in ebuild (bug #563038 by Macintosh).
Package-Manager: portage-2.2.23
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index 1e02fc02e780..f72ca712968e 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -64,12 +64,10 @@ src_prepare() {
"${FILESDIR}"/${PN}-4.75-nolua.patch \
"${FILESDIR}"/${PN}-5.10_beta1-string.patch \
"${FILESDIR}"/${PN}-5.21-python.patch \
- "${FILESDIR}"/${PN}-6.01-make.patch \
"${FILESDIR}"/${PN}-6.25-liblua-ar.patch \
"${FILESDIR}"/${PN}-6.46-uninstaller.patch \
"${FILESDIR}"/${PN}-6.47-no-libnl.patch \
- "${FILESDIR}"/${PN}-no-FORTIFY_SOURCE.patch \
- "${FILESDIR}"/${PN}-6.47-ncat-lua.patch
+ "${FILESDIR}"/${PN}-no-FORTIFY_SOURCE.patch
if use nls; then
local lingua=''
@@ -121,6 +119,12 @@ src_configure() {
}
src_compile() {
+ local dep deps="build-dnet build-nbase build-nsock build-netutil"
+
+ for dep in ${deps}; do
+ emake makefile.dep ${dep}
+ done
+
emake \
AR=$(tc-getAR) \
RANLIB=$(tc-getRANLIB )