summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-11 05:57:03 +0100
committerJeroen Roovers <jer@gentoo.org>2017-03-11 05:57:03 +0100
commitf99119030f75bb1cf942c0cbc9eb702c388aaa8a (patch)
tree2bc0095543279b46cdbda1c2af9390085b192e69 /net-analyzer
parentsys-apps/man-db: Stable for HPPA (bug #602588). (diff)
downloadgentoo-f99119030f75bb1cf942c0cbc9eb702c388aaa8a.tar.gz
gentoo-f99119030f75bb1cf942c0cbc9eb702c388aaa8a.tar.bz2
gentoo-f99119030f75bb1cf942c0cbc9eb702c388aaa8a.zip
net-analyzer/nmap: Include nls.m4 in acinclude.m4 (bug #612092 by Aaron Jones).
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/files/nls.m432
-rw-r--r--net-analyzer/nmap/nmap-7.31.ebuild2
-rw-r--r--net-analyzer/nmap/nmap-7.40.ebuild2
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild2
4 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/nmap/files/nls.m4 b/net-analyzer/nmap/files/nls.m4
new file mode 100644
index 000000000000..93df8d3b3f06
--- /dev/null
+++ b/net-analyzer/nmap/files/nls.m4
@@ -0,0 +1,32 @@
+# nls.m4 serial 5 (gettext-0.18)
+dnl Copyright (C) 1995-2003, 2005-2006, 2008-2014 Free Software Foundation,
+dnl Inc.
+dnl This file is free software; the Free Software Foundation
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+dnl This file can be used in projects which are not available under
+dnl the GNU General Public License or the GNU Library General Public
+dnl License but which still want to provide support for the GNU gettext
+dnl functionality.
+dnl Please note that the actual code of the GNU gettext library is covered
+dnl by the GNU Library General Public License, and the rest of the GNU
+dnl gettext package is covered by the GNU General Public License.
+dnl They are *not* in the public domain.
+
+dnl Authors:
+dnl Ulrich Drepper <drepper@cygnus.com>, 1995-2000.
+dnl Bruno Haible <haible@clisp.cons.org>, 2000-2003.
+
+AC_PREREQ([2.50])
+
+AC_DEFUN([AM_NLS],
+[
+ AC_MSG_CHECKING([whether NLS is requested])
+ dnl Default is enabled NLS
+ AC_ARG_ENABLE([nls],
+ [ --disable-nls do not use Native Language Support],
+ USE_NLS=$enableval, USE_NLS=yes)
+ AC_MSG_RESULT([$USE_NLS])
+ AC_SUBST([USE_NLS])
+])
diff --git a/net-analyzer/nmap/nmap-7.31.ebuild b/net-analyzer/nmap/nmap-7.31.ebuild
index feb242cab364..236ceeceafc7 100644
--- a/net-analyzer/nmap/nmap-7.31.ebuild
+++ b/net-analyzer/nmap/nmap-7.31.ebuild
@@ -68,6 +68,8 @@ src_unpack() {
src_prepare() {
rm -r libpcap/ || die
+ cat "${FILESDIR}"/nls.m4 >> "${S}"/acinclude.m4 || die
+
epatch \
"${FILESDIR}"/${PN}-5.10_beta1-string.patch \
"${FILESDIR}"/${PN}-5.21-python.patch \
diff --git a/net-analyzer/nmap/nmap-7.40.ebuild b/net-analyzer/nmap/nmap-7.40.ebuild
index a53f7387fa81..4b2f5e5a57c8 100644
--- a/net-analyzer/nmap/nmap-7.40.ebuild
+++ b/net-analyzer/nmap/nmap-7.40.ebuild
@@ -78,6 +78,8 @@ src_unpack() {
src_prepare() {
rm -r libpcap/ || die
+ cat "${FILESDIR}"/nls.m4 >> "${S}"/acinclude.m4 || die
+
default
if use nls; then
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index d2122aa939eb..431ae56c880a 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -71,6 +71,8 @@ pkg_setup() {
src_prepare() {
rm -r libpcap/ || die
+ cat "${FILESDIR}"/nls.m4 >> "${S}"/acinclude.m4 || die
+
default
if use nls; then