summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-11 22:15:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-11 22:15:40 +0100
commit0c44a81c4dcf50d4c01d24a497ac27698d482cde (patch)
tree5a799388f1bbe32d17dfe88e6e12d7da1722bd25 /net-dialup
parentsec-policy: update live ebuilds to EAPI6 (diff)
downloadgentoo-0c44a81c4dcf50d4c01d24a497ac27698d482cde.tar.gz
gentoo-0c44a81c4dcf50d4c01d24a497ac27698d482cde.tar.bz2
gentoo-0c44a81c4dcf50d4c01d24a497ac27698d482cde.zip
net-dialup/rp-pppoe: Revbump to fix path to ifconfig (bug #602344).
Removed old. Package-Manager: portage-2.3.3
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/rp-pppoe/files/rp-pppoe-3.11-kmode.patch4
-rw-r--r--net-dialup/rp-pppoe/files/rp-pppoe-3.12-ifconfig-path.patch65
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.12-r1.ebuild (renamed from net-dialup/rp-pppoe/rp-pppoe-3.12.ebuild)39
3 files changed, 90 insertions, 18 deletions
diff --git a/net-dialup/rp-pppoe/files/rp-pppoe-3.11-kmode.patch b/net-dialup/rp-pppoe/files/rp-pppoe-3.11-kmode.patch
index 039abd487793..78a6a3b67541 100644
--- a/net-dialup/rp-pppoe/files/rp-pppoe-3.11-kmode.patch
+++ b/net-dialup/rp-pppoe/files/rp-pppoe-3.11-kmode.patch
@@ -1,5 +1,5 @@
---- src/configure.in.old 2015-01-07 13:08:18.929959937 +0100
-+++ src/configure.in 2015-01-07 13:08:38.253406302 +0100
+--- a/src/configure.in
++++ b/src/configure.in
@@ -26,6 +26,7 @@
#include<net/ethernet.h>
#include<linux/if.h>
diff --git a/net-dialup/rp-pppoe/files/rp-pppoe-3.12-ifconfig-path.patch b/net-dialup/rp-pppoe/files/rp-pppoe-3.12-ifconfig-path.patch
new file mode 100644
index 000000000000..2a56d40fabcf
--- /dev/null
+++ b/net-dialup/rp-pppoe/files/rp-pppoe-3.12-ifconfig-path.patch
@@ -0,0 +1,65 @@
+diff --git a/gui/tkpppoe.in b/gui/tkpppoe.in
+index 148c8c8..1d952d4 100755
+--- a/gui/tkpppoe.in
++++ b/gui/tkpppoe.in
+@@ -1573,7 +1573,7 @@ proc SetButtonStates {} {
+ #***********************************************************************
+ proc GetEthernetInterfaces {} {
+ set ifs {}
+- set fp [open "|/sbin/ifconfig" "r"]
++ set fp [open "|/bin/ifconfig" "r"]
+ while {[gets $fp line] >= 0} {
+ if {[regexp {^eth[0-9]+} $line eth]} {
+ lappend ifs $eth
+diff --git a/scripts/pppoe-connect.in b/scripts/pppoe-connect.in
+index 2124422..e7eab32 100755
+--- a/scripts/pppoe-connect.in
++++ b/scripts/pppoe-connect.in
+@@ -28,7 +28,7 @@ exec_prefix=@exec_prefix@
+ localstatedir=/var
+
+ # Paths to programs
+-IFCONFIG=/sbin/ifconfig
++IFCONFIG=/bin/ifconfig
+ PPPD=@PPPD@
+ SETSID=@SETSID@
+ PPPOE=@sbindir@/pppoe
+diff --git a/scripts/pppoe-setup.in b/scripts/pppoe-setup.in
+index b378479..4122084 100755
+--- a/scripts/pppoe-setup.in
++++ b/scripts/pppoe-setup.in
+@@ -17,7 +17,7 @@ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+
+ # Paths to programs
+-IFCONFIG=/sbin/ifconfig
++IFCONFIG=/bin/ifconfig
+ PPPD=@PPPD@
+ PPPOE=@sbindir@/pppoe
+ ECHO=@ECHO@
+diff --git a/scripts/pppoe-start.in b/scripts/pppoe-start.in
+index 7e15804..b9dd7f0 100755
+--- a/scripts/pppoe-start.in
++++ b/scripts/pppoe-start.in
+@@ -29,7 +29,7 @@ exec_prefix=@exec_prefix@
+ # Paths to programs
+ CONNECT=@sbindir@/pppoe-connect
+ ECHO=@ECHO@
+-IFCONFIG=/sbin/ifconfig
++IFCONFIG=/bin/ifconfig
+
+ # Set to "C" locale so we can parse messages from commands
+ LANG=C
+diff --git a/scripts/pppoe-status b/scripts/pppoe-status
+index 9fe89cd..96d6ebd 100755
+--- a/scripts/pppoe-status
++++ b/scripts/pppoe-status
+@@ -73,7 +73,7 @@ for i in /etc/ppp/ppp*.pid /var/run/ppp*.pid ; do
+ exit 1
+ fi
+ echo "pppoe-status: Link is up and running on interface $IF"
+- /sbin/ifconfig $IF
++ /bin/ifconfig $IF
+ exit 0
+ fi
+ fi
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.12.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.12-r1.ebuild
index 4739e1f59e3e..a3e172fb6bd5 100644
--- a/net-dialup/rp-pppoe/rp-pppoe-3.12.ebuild
+++ b/net-dialup/rp-pppoe/rp-pppoe-3.12-r1.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit eutils flag-o-matic autotools readme.gentoo
+inherit eutils flag-o-matic autotools readme.gentoo-r1
PPP_P="ppp-2.4.7"
@@ -35,22 +35,29 @@ pkg_setup() {
PPPD_VER=${PPPD_VER%%-*} #reduce it to ${PV}
}
-src_prepare() {
+PATCHES=(
# Patch to enable integration of pppoe-start and pppoe-stop with
# baselayout-1.11.x so that the pidfile can be found reliably per interface
- epatch "${FILESDIR}/${PN}-3.10-gentoo-netscripts.patch"
-
- epatch "${FILESDIR}/${PN}-3.10-username-charset.patch" # bug 82410
- epatch "${FILESDIR}/${PN}-3.10-plugin-options.patch"
- epatch "${FILESDIR}/${PN}-3.10-autotools.patch"
- has_version '<sys-kernel/linux-headers-2.6.35' && \
- epatch "${FILESDIR}/${PN}-3.10-linux-headers.patch" #334197
- epatch "${FILESDIR}/${PN}-3.10-posix-source-sigaction.patch"
- epatch "${FILESDIR}/${PN}-3.11-gentoo.patch"
- epatch "${FILESDIR}/${PN}-3.11-kmode.patch" #364941
- epatch "${FILESDIR}/${PN}-3.12-linux-headers.patch"
-
- epatch_user
+ "${FILESDIR}/${PN}-3.10-gentoo-netscripts.patch"
+
+ "${FILESDIR}/${PN}-3.10-username-charset.patch" # bug 82410
+ "${FILESDIR}/${PN}-3.10-plugin-options.patch"
+ "${FILESDIR}/${PN}-3.10-autotools.patch"
+ "${FILESDIR}/${PN}-3.10-posix-source-sigaction.patch"
+ "${FILESDIR}/${PN}-3.11-gentoo.patch"
+ "${FILESDIR}/${PN}-3.11-kmode.patch" #364941
+ "${FILESDIR}/${PN}-3.12-linux-headers.patch"
+ "${FILESDIR}/${PN}-3.12-ifconfig-path.patch" #602344
+)
+
+src_prepare() {
+ if has_version '<sys-kernel/linux-headers-2.6.35' ; then
+ PATCHES+=(
+ "${FILESDIR}/${PN}-3.10-linux-headers.patch" #334197
+ )
+ fi
+
+ default
cd "${S}"/src || die
eautoreconf