summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlarig Le Lay <alarig@swordarmor.fr>2020-06-16 12:31:20 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-01 09:38:31 +0300
commit6c35e0080c2fcd69c99bee94e7d96c82d555558a (patch)
tree9dd35448817cda04c1b46803dd665944ec281062 /net-dialup
parentdev-libs/stb: version bump 20200205 (diff)
downloadgentoo-6c35e0080c2fcd69c99bee94e7d96c82d555558a.tar.gz
gentoo-6c35e0080c2fcd69c99bee94e7d96c82d555558a.tar.bz2
gentoo-6c35e0080c2fcd69c99bee94e7d96c82d555558a.zip
net-dialup/freeradius-client: Avoid calling ar directly
Closes: https://bugs.gentoo.org/728332 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr> Closes: https://github.com/gentoo/gentoo/pull/16269 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild b/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
index f9ac8661b098..0b182155d465 100644
--- a/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
+++ b/net-dialup/freeradius-client/freeradius-client-1.1.7-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="FreeRADIUS Client framework"
HOMEPAGE="https://wiki.freeradius.org/project/Radiusclient"
@@ -31,12 +31,19 @@ src_prepare() {
}
src_configure() {
+ tc-export AR
+
local myeconfargs=(
$(use_enable scp)
$(use_enable shadow)
--with-secure-path
)
econf "${myeconfargs[@]}"
+
+ for MAKEFILE in $(find -name Makefile) libtool; do
+ sed -i "s|/usr/bin/ar|${AR}|" "${MAKEFILE}" || \
+ die "Patching ${MAKEFILE} for ${AR} failed"
+ done
}
src_install() {