summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dns/bind-dns-keygen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dns/bind-dns-keygen')
-rw-r--r--net-dns/bind-dns-keygen/Manifest1
-rw-r--r--net-dns/bind-dns-keygen/bind-dns-keygen-9.3.2.39-r1.ebuild31
-rw-r--r--net-dns/bind-dns-keygen/metadata.xml8
3 files changed, 40 insertions, 0 deletions
diff --git a/net-dns/bind-dns-keygen/Manifest b/net-dns/bind-dns-keygen/Manifest
new file mode 100644
index 000000000000..34fea8502271
--- /dev/null
+++ b/net-dns/bind-dns-keygen/Manifest
@@ -0,0 +1 @@
+DIST bind-9.3.2-39.fc6.src.rpm 5480548 SHA256 8e5b98a2cd2f5003b28ba9c7a9229efe135a6439c64cc1a9b6aa91811258ef21 SHA512 8959274880aca83d0882fcd825627cdf1000536d2c6e08fad83fe6b85aecbbeb404e6bf7fc7f1d718aa17d85465198565adffd3628a615744d828a674a775736 WHIRLPOOL 0854c7223d97ea82ac90ec6c7e792778bd7493f919a0b6e6e344e0c70745e28effabf63a45da9e87b65bd7eaa0b3f146ea78aa21e4cfbe6cde3e7f4f0a3b7bcf
diff --git a/net-dns/bind-dns-keygen/bind-dns-keygen-9.3.2.39-r1.ebuild b/net-dns/bind-dns-keygen/bind-dns-keygen-9.3.2.39-r1.ebuild
new file mode 100644
index 000000000000..a8a4de38fad8
--- /dev/null
+++ b/net-dns/bind-dns-keygen/bind-dns-keygen-9.3.2.39-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit rpm toolchain-funcs
+
+# Tag for which Fedora Core version it's from
+FCVER="6"
+
+MY_PV="${PV%.*}-${PV##*.}"
+MY_P="${PN%%-*}-${MY_PV}"
+DESCRIPTION="A simple BIND key generator"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://gentoo/${MY_P}.fc${FCVER}.src.rpm"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN#*-} ${PN##*-}.c || die "compile failed"
+}
+
+src_install() {
+ dosbin ${PN#*-} || die "dosbin failed"
+}
diff --git a/net-dns/bind-dns-keygen/metadata.xml b/net-dns/bind-dns-keygen/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/net-dns/bind-dns-keygen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>