summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2017-08-16 13:32:37 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-22 11:06:59 +0200
commit39c7aed0eb459dc9a3b91dbca053e50acc577fe3 (patch)
tree15504cb3fa6214115a09a1205793e7b907a0a941 /net-dns/knot/knot-2.5.3-r1.ebuild
parentwww-servers/sniproxy: new package (diff)
downloadgentoo-39c7aed0eb459dc9a3b91dbca053e50acc577fe3.tar.gz
gentoo-39c7aed0eb459dc9a3b91dbca053e50acc577fe3.tar.bz2
gentoo-39c7aed0eb459dc9a3b91dbca053e50acc577fe3.zip
net-dns/knot: clean the ebuild and fix QA issues
Diffstat (limited to 'net-dns/knot/knot-2.5.3-r1.ebuild')
-rw-r--r--net-dns/knot/knot-2.5.3-r1.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/net-dns/knot/knot-2.5.3-r1.ebuild b/net-dns/knot/knot-2.5.3-r1.ebuild
new file mode 100644
index 000000000000..5ffb533485ec
--- /dev/null
+++ b/net-dns/knot/knot-2.5.3-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="http://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dnstap doc caps +fastparser idn systemd"
+
+RDEPEND="
+ >=net-libs/gnutls-3.3:=
+ >=dev-db/lmdb-0.9.15
+ >=dev-libs/userspace-rcu-0.5.4
+ caps? ( >=sys-libs/libcap-ng-0.6.4 )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ idn? ( || ( net-dns/libidn >=net-dns/libidn2-2.0.0 ) )
+ dev-libs/libedit
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ econf \
+ --with-storage="${EPREFIX}/var/lib/${PN}" \
+ --with-rundir="${EPREFIX}/var/run/${PN}" \
+ $(use_enable fastparser) \
+ $(use_enable dnstap) \
+ $(use_enable doc documentation) \
+ $(use_with idn libidn) \
+ --enable-systemd=$(usex systemd)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ rmdir "${D}var/run/${PN}" "${D}var/run/" || die
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ systemd_dounit "${FILESDIR}/knot.service"
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}