summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2018-01-02 18:24:53 +0100
committerCraig Andrews <candrews@gentoo.org>2018-01-05 19:01:22 -0500
commitaef308a1598c331da76ed4decf684e047c97ecb3 (patch)
tree032880b9f2b13d37c6a3b17141d71635c32242f9 /net-dns/knot
parentdev-python/python-docs: Clean old up (diff)
downloadgentoo-aef308a1598c331da76ed4decf684e047c97ecb3.tar.gz
gentoo-aef308a1598c331da76ed4decf684e047c97ecb3.tar.bz2
gentoo-aef308a1598c331da76ed4decf684e047c97ecb3.zip
net-dns/knot: version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'net-dns/knot')
-rw-r--r--net-dns/knot/Manifest2
-rw-r--r--net-dns/knot/knot-2.5.7.ebuild102
-rw-r--r--net-dns/knot/knot-2.6.4.ebuild102
3 files changed, 206 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index 9f5052911105..12cb8bb2ef87 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1,3 +1,5 @@
DIST knot-2.5.6.tar.xz 1081756 BLAKE2B a016be4b7080175cc83bacc23cbf08b15e5c8dcdd63da0d6ca61dcbd8aa2d75952a2becf7c9f2f65b43e004bd54641198afc6402a0714046a4f631aaa193ae2d SHA512 dcc58791469c8e4724a47b47105bf0c047bcf62611d6803a07a856bb281d72a397b186210087ff8f145232315bbd9baa194a7cdef10d1ebb36ca3b8c0a0c7379
+DIST knot-2.5.7.tar.xz 1084656 BLAKE2B c2d583625a19f6a61248b3b42cdf14f5bb2bdbafdb20be6b0813744095a4016a4be2eb5e2dfaff0628238c60153480175a86706db0b88569d76156f86ba33968 SHA512 96e375f556309bb89cea982dda169cef70c23d03c48282110e47a44849c1102cd37d98aa7650781b399f5d932b724b8a935f0b9e55e4920465ae7b74a0d1d55a
DIST knot-2.6.1.tar.xz 1112956 BLAKE2B 28c2c2318713c63ce389ab768bedbcf3b2799d9d660d978e77ba68e40aff40de8eb0e31cc7b42d00230beff418ba2d20032e2e01c5dc26a6813e02e10711195a SHA512 f4eaf311adcdfd13628c7174333bcc766b300be573f7df32eaaf162c5857e0ba35ce5a5e022f799c95618203abbe8db93e2364f172a87c4dd4eaf90b30ef8428
DIST knot-2.6.3.tar.xz 1112408 BLAKE2B c2a04e951427fe667b1bef63f4ca4fca8fa099f7c7a0a7e61562a5a5f9f44208118f59debbf67eabba72c5f924412c54f650450e71c592f033d99d061060f103 SHA512 51e1c2abe6149173ded2c48e70ca9a563f76013aae95e53e9c4b5c2325bce44b21b410f7ce773012bc6e6d0b3db21aeffd697669fbeb34137af70af5dcd3f157
+DIST knot-2.6.4.tar.xz 1116928 BLAKE2B 7914addec8ff1826c81c2de098ed4e3b7686c877d40c727286d2d9c8c477fb02c1d0ad38befa77ccc92c5e068d6bc4c86e5df8ad9f5541cc0e3dc6f63192af58 SHA512 7242ef76bd3a379f574ca9af8fec96b0419c2209b6d8114c3b8e675cb5459ec70dab928a5a9ba9850fe1d7201729c9ff7e4c8800674e840e1cf04544c32a6f78
diff --git a/net-dns/knot/knot-2.5.7.ebuild b/net-dns/knot/knot-2.5.7.ebuild
new file mode 100644
index 000000000000..2c5988f91145
--- /dev/null
+++ b/net-dns/knot/knot-2.5.7.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+dnsproxy"
+ "dnstap"
+ "+noudp"
+ "+onlinesign"
+ "rosedb"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ >=dev-db/lmdb-0.9.15
+ dev-libs/libedit
+ >=dev-libs/userspace-rcu-0.5.4
+ dev-python/lmdb
+ >=net-libs/gnutls-3.3:=
+ caps? ( >=sys-libs/libcap-ng-0.6.4 )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ idn? (
+ !libidn2? ( net-dns/libidn )
+ libidn2? ( >=net-dns/libidn2-2.0.0 )
+ )
+ systemd? ( >=sys-apps/systemd-229 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=()
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with $u module-$u)")
+ done
+
+ econf \
+ --with-storage="${EPREFIX}/var/lib/${PN}" \
+ --with-rundir="${EPREFIX}/var/run/${PN}" \
+ $(use_enable fastparser) \
+ $(use_enable dnstap) \
+ $(use_enable doc documentation) \
+ $(use_enable utils utilities) \
+ --enable-systemd=$(usex systemd) \
+ $(use_with idn libidn) \
+ "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ rmdir "${D}var/run/${PN}" "${D}var/run/" || die
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}
diff --git a/net-dns/knot/knot-2.6.4.ebuild b/net-dns/knot/knot-2.6.4.ebuild
new file mode 100644
index 000000000000..63edc2b56df8
--- /dev/null
+++ b/net-dns/knot/knot-2.6.4.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+dnsproxy"
+ "dnstap"
+ "+noudp"
+ "+onlinesign"
+ "rosedb"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ >=dev-db/lmdb-0.9.15
+ dev-libs/libedit
+ >=dev-libs/userspace-rcu-0.5.4
+ dev-python/lmdb
+ >=net-libs/gnutls-3.3:=
+ caps? ( >=sys-libs/libcap-ng-0.6.4 )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ idn? (
+ !libidn2? ( net-dns/libidn )
+ libidn2? ( >=net-dns/libidn2-2.0.0 )
+ )
+ systemd? ( >=sys-apps/systemd-229 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=()
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with $u module-$u)")
+ done
+
+ econf \
+ --with-storage="${EPREFIX}/var/lib/${PN}" \
+ --with-rundir="${EPREFIX}/var/run/${PN}" \
+ $(use_enable fastparser) \
+ $(use_enable dnstap) \
+ $(use_enable doc documentation) \
+ $(use_enable utils utilities) \
+ --enable-systemd=$(usex systemd) \
+ $(use_with idn libidn) \
+ "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ rmdir "${D}var/run/${PN}" "${D}var/run/" || die
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}