summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2017-11-30 18:28:37 +0000
committerSven Wegener <swegener@gentoo.org>2017-11-30 19:05:45 +0000
commitdf76d7bf18d05eac6a000f5c9e8a93b4075b5b3f (patch)
tree7b72411216ef2430a171e20b6d3647058370b868 /net-dns/pdns
parentnet-dns/pdns-recursor: Add snmp USE flag, bug #639018 (diff)
downloadgentoo-df76d7bf18d05eac6a000f5c9e8a93b4075b5b3f.tar.gz
gentoo-df76d7bf18d05eac6a000f5c9e8a93b4075b5b3f.tar.bz2
gentoo-df76d7bf18d05eac6a000f5c9e8a93b4075b5b3f.zip
net-dns/pdns: Add sodium USE flag, bug #639018
Package-Manager: Portage-2.3.14, Repoman-2.3.6 Closes: https://bugs.gentoo.org/639018
Diffstat (limited to 'net-dns/pdns')
-rw-r--r--net-dns/pdns/metadata.xml1
-rw-r--r--net-dns/pdns/pdns-4.1.0_rc3-r1.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/net-dns/pdns/metadata.xml b/net-dns/pdns/metadata.xml
index 264c58531540..03c68c6fd102 100644
--- a/net-dns/pdns/metadata.xml
+++ b/net-dns/pdns/metadata.xml
@@ -18,6 +18,7 @@ standards documents. Furthermore, PowerDNS interfaces with almost any database.
<flag name="opendbx">Use a database supported by <pkg>dev-db/opendbx</pkg> as backend.</flag>
<flag name="protobuf">Enable support for <pkg>dev-libs/protobuf</pkg>.</flag>
<flag name="remote">Use a generic socket or pipe as a backend (via JSON RPC requests).</flag>
+ <flag name="sodium">Use <pkg>dev-libs/libsodium</pkg> for cryptography</flag>
<flag name="tinydns">Use a TinyDNS CDB database as backend.</flag>
<flag name="tools">Build optional tools (dnsscan, dnsscope, etc..).</flag>
</use>
diff --git a/net-dns/pdns/pdns-4.1.0_rc3-r1.ebuild b/net-dns/pdns/pdns-4.1.0_rc3-r1.ebuild
index 06d462d4a735..d97d257344e6 100644
--- a/net-dns/pdns/pdns-4.1.0_rc3-r1.ebuild
+++ b/net-dns/pdns/pdns-4.1.0_rc3-r1.ebuild
@@ -18,7 +18,7 @@ KEYWORDS="~amd64 ~x86"
# oracle: dito (need Oracle Client Libraries)
# xdb: (almost) dead, surely not supported
-IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sqlite systemd tools tinydns test"
+IUSE="botan debug doc geoip ldap libressl lua luajit mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
REQUIRED_USE="mydns? ( mysql ) ?? ( lua luajit )"
@@ -35,6 +35,7 @@ RDEPEND="
sqlite? ( dev-db/sqlite:3 )
opendbx? ( dev-db/opendbx )
geoip? ( >=dev-cpp/yaml-cpp-0.5.1 dev-libs/geoip )
+ sodium? ( dev-libs/libsodium:= )
tinydns? ( >=dev-db/tinycdb-0.77 )
protobuf? ( dev-libs/protobuf )"
DEPEND="${RDEPEND}
@@ -76,6 +77,7 @@ src_configure() {
$(use_enable test unit-tests) \
$(use_enable tools) \
$(use_enable systemd) \
+ $(use_enable sodium libsodium) \
$(use_with lua) \
$(use_with luajit) \
$(use_with protobuf) \