summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-09-13 10:57:03 +0800
committerIan Delaney <idella4@gentoo.org>2015-09-13 10:57:47 +0800
commit1de698ff655f0bb8686a5e078093ab7c47034cd0 (patch)
tree5e36b0ae4481dd6500c90a9812fa07d815603157 /net-firewall/arno-iptables-firewall
parentnet-p2p/ctorrent: workaround broken rTorrent files (diff)
downloadgentoo-1de698ff655f0bb8686a5e078093ab7c47034cd0.tar.gz
gentoo-1de698ff655f0bb8686a5e078093ab7c47034cd0.tar.bz2
gentoo-1de698ff655f0bb8686a5e078093ab7c47034cd0.zip
net-firewall/arno-iptables-firewall: bump, request sourced from bug #559858
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-firewall/arno-iptables-firewall')
-rw-r--r--net-firewall/arno-iptables-firewall/Manifest1
-rw-r--r--net-firewall/arno-iptables-firewall/arno-iptables-firewall-2.0.1f_rc1.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/net-firewall/arno-iptables-firewall/Manifest b/net-firewall/arno-iptables-firewall/Manifest
index 20eb3185cb5f..fe6daf6def7e 100644
--- a/net-firewall/arno-iptables-firewall/Manifest
+++ b/net-firewall/arno-iptables-firewall/Manifest
@@ -1,2 +1,3 @@
DIST arno-iptables-firewall_2.0.1d.tar.gz 125329 SHA256 177343362063125985e8b0008fe69bc6ca8d3ba252cfa35a316e708f52fef9c6 SHA512 a99f4fcf4f84a47cc1bda26b39e4f3dc7e10b74f3aeaea8a2519bf18f43ff08ec0bfbd0f078ac36ce12da31d3ac0eabc51231b4559cadca13cd4d75e0940bf9d WHIRLPOOL 2dd56678015cf49ed9442c63c5455c70e72a6f252d9278a56ae1eaabda34d597c44f7fdb97695656882754776385778a5e67d83e7e35e4554e5765e3a0e68b13
DIST arno-iptables-firewall_2.0.1e.tar.gz 126238 SHA256 fa7b865e5d9b8e077cba73b2f28695a2fd691092a0a7f9e1c16ee369fc27fe43 SHA512 244b3bbf08b2d97128908aece487388bb71ced002cc129885144f4eacf9cf6053c9eb1225a1cd33fdefc502f1e6822a85710d35a7884e99cfde35d34f3fd4f70 WHIRLPOOL f6c1b5ade8b4acdcc4c8e90e19a84335c3932d2a58bbba2221a91b7cbd228c4d6072af6e21836314d86ef005780b47c5ce85198219b345116af529178e2133c1
+DIST arno-iptables-firewall_2.0.1f-rc1.tar.gz 129834 SHA256 84f3e96bb85dbcad2916922d537aa0f188df59ece7ea9d9c0f669468938713e0 SHA512 cf7c2f97e74e01be48a8206be3116156740dfd2022df957651b587de1492157363249c067a778209c1e239f53c30426c32e6b1f901949c37ab2b5d690542d620 WHIRLPOOL 969e09b206cf1e132e93151461297fdb3b40ba849b4b4c9ff9e2ef8095526e4e8340b348e2bc97cfe9838b7de3f42cb1acae7c21d6261dcab5392e26ba81afc4
diff --git a/net-firewall/arno-iptables-firewall/arno-iptables-firewall-2.0.1f_rc1.ebuild b/net-firewall/arno-iptables-firewall/arno-iptables-firewall-2.0.1f_rc1.ebuild
new file mode 100644
index 000000000000..f34f6c931ec9
--- /dev/null
+++ b/net-firewall/arno-iptables-firewall/arno-iptables-firewall-2.0.1f_rc1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit readme.gentoo systemd versionator
+
+DESCRIPTION="Arno's iptables firewall script"
+HOMEPAGE="http://rocky.eld.leidenuniv.nl"
+
+MY_PV=$(replace_version_separator 3 -)
+SRC_URI="http://rocky.eld.leidenuniv.nl/${PN}/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugins"
+
+# sys-apps/coreutils dependency wrt
+# https://bugs.gentoo.org/show_bug.cgi?id=448716
+
+DEPEND=""
+RDEPEND="net-firewall/iptables
+ >sys-apps/coreutils-8.20-r1
+ sys-apps/iproute2
+ plugins? ( net-dns/bind-tools )"
+
+S="${WORKDIR}/${PN}_${MY_PV/rc/RC}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You will need to configure /etc/${PN}/firewall.conf
+before using this package. To start the script, run:
+
+/etc/init.d/${PN} start (for OpenRC)
+systemctl start ${PN} (for systemd)
+
+If you want to start this script at boot, run:
+
+rc-update add ${PN} default (for OpenRC)
+systemctl enable ${PN} (for systemd)"
+
+src_prepare() {
+ sed -i -e 's:/usr/local/share/:/usr/libexec/:' \
+ etc/"${PN}"/firewall.conf || die "Sed failed!"
+ sed -i -e 's:/usr/local/sbin/:/usr/sbin/:' \
+ lib/systemd/system/"${PN}.service" || die "Sed failed!"
+}
+
+src_install() {
+ insinto /etc/"${PN}"
+ doins etc/"${PN}"/firewall.conf
+ doins etc/"${PN}"/custom-rules
+
+ doinitd "${FILESDIR}/${PN}"
+ systemd_dounit lib/systemd/system/"${PN}.service"
+
+ dobin bin/arno-fwfilter
+ dosbin bin/"${PN}"
+
+ insinto /usr/libexec/"${PN}"
+ doins share/"${PN}"/environment
+
+ dodoc CHANGELOG README
+ readme.gentoo_create_doc
+
+ if use plugins
+ then
+ insinto /etc/"${PN}"/plugins
+ doins etc/"${PN}"/plugins/*
+
+ insinto /usr/libexec/"${PN}"/plugins
+ doins share/"${PN}"/plugins/*.plugin
+
+ exeinto /usr/libexec/"${PN}"/plugins
+ doexe share/"${PN}"/plugins/dyndns-host-open-helper
+ doexe share/"${PN}"/plugins/traffic-accounting-helper
+ doexe share/"${PN}"/plugins/traffic-accounting-log-rotate
+ doexe share/"${PN}"/plugins/traffic-accounting-show
+
+ docinto plugins
+ dodoc share/"${PN}"/plugins/*.CHANGELOG
+ fi
+
+ doman share/man/man1/arno-fwfilter.1 \
+ share/man/man8/"${PN}".8
+}
+
+pkg_postinst () {
+ ewarn "When you stop this script, all firewall rules are flushed!"
+ ewarn "Make sure to not use multiple firewall scripts simultaneously"
+ ewarn "unless you know what you are doing!"
+ readme.gentoo_print_elog
+}