summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-20 13:30:35 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-20 13:31:16 -0400
commit35a3bea74f790d3fd69cab4b40f245078dd6bf18 (patch)
tree6f3375be3438d4a45d410e744c4d706fd3a36955 /net-firewall
parentdev-python/backports: add alpha keyword (diff)
downloadgentoo-35a3bea74f790d3fd69cab4b40f245078dd6bf18.tar.gz
gentoo-35a3bea74f790d3fd69cab4b40f245078dd6bf18.tar.bz2
gentoo-35a3bea74f790d3fd69cab4b40f245078dd6bf18.zip
net-firewall/iptables: use -fpack-struct w/x32 ABI #472388
Apply a hack for the x32 ABI to try to get it working. The current version is entirely broken, so this is still better than the status quo.
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/iptables-1.4.21-r2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-firewall/iptables/iptables-1.4.21-r2.ebuild b/net-firewall/iptables/iptables-1.4.21-r2.ebuild
index 268e0f7de373..e87e4ed137c2 100644
--- a/net-firewall/iptables/iptables-1.4.21-r2.ebuild
+++ b/net-firewall/iptables/iptables-1.4.21-r2.ebuild
@@ -7,7 +7,7 @@ EAPI="5"
# Force users doing their own patches to install their own tools
AUTOTOOLS_AUTO_DEPEND=no
-inherit eutils multilib systemd toolchain-funcs autotools
+inherit eutils multilib systemd toolchain-funcs autotools flag-o-matic
DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
HOMEPAGE="http://www.netfilter.org/projects/iptables/"
@@ -44,6 +44,9 @@ src_configure() {
# Some libs use $(AR) rather than libtool to build #444282
tc-export AR
+ # Hack around struct mismatches between userland & kernel for some ABIs. #472388
+ use amd64 && [[ ${ABI} == "x32" ]] && append-flags -fpack-struct
+
sed -i \
-e "/nfnetlink=[01]/s:=[01]:=$(usex netlink 1 0):" \
-e "/nfconntrack=[01]/s:=[01]:=$(usex conntrack 1 0):" \