summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2016-03-18 12:51:57 +0900
committerAaron Bauman <bman@gentoo.org>2016-03-18 12:51:57 +0900
commitc30bec13d8cec7f20c64f21697e0bf713e00e0ad (patch)
tree1677b448d58105fc4c38705f3fd1c77fefabad4c /net-firewall
parentnet-firewall/fwbuilder: update metadata.xml (diff)
downloadgentoo-c30bec13d8cec7f20c64f21697e0bf713e00e0ad.tar.gz
gentoo-c30bec13d8cec7f20c64f21697e0bf713e00e0ad.tar.bz2
gentoo-c30bec13d8cec7f20c64f21697e0bf713e00e0ad.zip
net-firewall/fwbuilder: version bump; add Qt5 support; drop unneeded eclass support and patches
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/fwbuilder/fwbuilder-5.3.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-firewall/fwbuilder/fwbuilder-5.3.6.ebuild b/net-firewall/fwbuilder/fwbuilder-5.3.6.ebuild
new file mode 100644
index 000000000000..9a174dcaba30
--- /dev/null
+++ b/net-firewall/fwbuilder/fwbuilder-5.3.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit qmake-utils autotools
+
+DESCRIPTION="A firewall GUI"
+HOMEPAGE="http://www.fwbuilder.org/"
+SRC_URI="https://github.com/UNINETT/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ dev-libs/elfutils
+ >=dev-qt/qtgui-5.5.1-r1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ sed -i -e '/dnl.*AM_INIT_AUTOMAKE/d' configure.in || die #398743
+ mv configure.in configure.ac || die #426262
+ eautoreconf
+}
+
+src_configure() {
+ eqmake5
+ # portage handles ccache/distcc itself
+ econf --without-{ccache,distcc}
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ validate_desktop_entries
+
+ elog "You need to emerge sys-apps/iproute2"
+ elog "in order to run the firewall script."
+}