summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-10-25 08:32:33 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-10-25 08:32:51 -0500
commite1070a6a8e25357594e2aad2f2415e841c4c09b0 (patch)
treed926ce81ab6b37ef025553f4255a48a4e5e69cd5 /net-firewall
parentapp-crypt/paperkey: Version bump to 1.5 (diff)
downloadgentoo-e1070a6a8e25357594e2aad2f2415e841c4c09b0.tar.gz
gentoo-e1070a6a8e25357594e2aad2f2415e841c4c09b0.tar.bz2
gentoo-e1070a6a8e25357594e2aad2f2415e841c4c09b0.zip
net-firewall/nftables: fixing the rules creating bug 634804
Bug: 634804 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/nftables/nftables-0.8-r3.ebuild (renamed from net-firewall/nftables/nftables-0.8-r2.ebuild)18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-firewall/nftables/nftables-0.8-r2.ebuild b/net-firewall/nftables/nftables-0.8-r3.ebuild
index 4656176d0d39..00a30dec4848 100644
--- a/net-firewall/nftables/nftables-0.8-r2.ebuild
+++ b/net-firewall/nftables/nftables-0.8-r3.ebuild
@@ -72,13 +72,13 @@ pkg_postinst() {
local save_file
save_file="${EROOT%/}/var/lib/nftables/rules-save"
- elog "In order for the nftables-restore systemd service to start, "
- elog "the file, ${save_file}, must exist. To create this "
- elog "file run the following command: "
- elog ""
- elog " touch '${save_file}'"
- elog ""
- elog "Afterwards, the nftables-restore service should be manually started "
- elog "to ensure firewall changes are stored on system shutdown. The "
- elog "systemd service will function normally thereafter."
+ # In order for the nftables-restore systemd service to start
+ # the save_file must exist.
+ if [[ ! -f ${save_file} ]]; then
+ touch ${save_file}
+ fi
+
+ elog "If you are creating firewall rules before the next system restart "
+ elog "the nftables-restore service must be manually started in order to "
+ elog "save those rules on shutdown."
}