summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-14 00:03:07 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-14 00:03:12 -0400
commit6db2e20c272323a10ea3afe3741f8c282bfa2d6a (patch)
treed6a4f27a54df2113c32039ccafb454ce26984b3c /net-fs/nfs-utils
parentapp-emulation/lxd: remove old (diff)
downloadgentoo-6db2e20c272323a10ea3afe3741f8c282bfa2d6a.tar.gz
gentoo-6db2e20c272323a10ea3afe3741f8c282bfa2d6a.tar.bz2
gentoo-6db2e20c272323a10ea3afe3741f8c282bfa2d6a.zip
net-fs/nfs-utils: fix building w/newer glibc #579884
Diffstat (limited to 'net-fs/nfs-utils')
-rw-r--r--net-fs/nfs-utils/files/nfs-utils-1.3.3-sysmacros.patch78
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.3.3.ebuild1
2 files changed, 79 insertions, 0 deletions
diff --git a/net-fs/nfs-utils/files/nfs-utils-1.3.3-sysmacros.patch b/net-fs/nfs-utils/files/nfs-utils-1.3.3-sysmacros.patch
new file mode 100644
index 000000000000..638442563c4c
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-utils-1.3.3-sysmacros.patch
@@ -0,0 +1,78 @@
+From 187f0e8298a3dd405b5aa817df129198d6f66eeb Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 14 Apr 2016 00:01:05 -0400
+Subject: [PATCH nfs-utils] fix building w/newer C libraries
+
+Linux C libraries are moving away from implicitly including the header
+sys/sysmacros.h via sys/types.h. We would like to do this for glibc
+now, but others (musl/etc...) have been doing it already. This means
+any code using major/minor/makedevs functions will fail to build when
+they don't include that header.
+
+Leverage the AC_HEADER_MAJOR macro that configure is already using to
+pull in the right header.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ support/include/xcommon.h | 6 ++++++
+ support/nfs/nfsexport.c | 1 +
+ utils/blkmapd/device-discovery.c | 1 +
+ utils/mountd/cache.c | 1 +
+ 4 files changed, 9 insertions(+)
+
+diff --git a/support/include/xcommon.h b/support/include/xcommon.h
+index d1a4b18..23c9a13 100644
+--- a/support/include/xcommon.h
++++ b/support/include/xcommon.h
+@@ -17,6 +17,12 @@
+ #include <stdlib.h>
+ #include <string.h>
+
++#ifdef MAJOR_IN_MKDEV
++#include <sys/mkdev.h>
++#elif defined(MAJOR_IN_SYSMACROS)
++#include <sys/sysmacros.h>
++#endif
++
+ #define streq(s, t) (strcmp ((s), (t)) == 0)
+
+ /* Functions in sundries.c that are used in mount.c and umount.c */
+diff --git a/support/nfs/nfsexport.c b/support/nfs/nfsexport.c
+index afd7c90..4b13265 100644
+--- a/support/nfs/nfsexport.c
++++ b/support/nfs/nfsexport.c
+@@ -19,6 +19,7 @@
+
+ #include "nfslib.h"
+ #include "misc.h"
++#include "xcommon.h"
+
+ /* if /proc/net/rpc/... exists, then
+ * write to it, as that interface is more stable.
+diff --git a/utils/blkmapd/device-discovery.c b/utils/blkmapd/device-discovery.c
+index b010628..052d582 100644
+--- a/utils/blkmapd/device-discovery.c
++++ b/utils/blkmapd/device-discovery.c
+@@ -51,6 +51,7 @@
+ #include <libdevmapper.h>
+
+ #include "device-discovery.h"
++#include "xcommon.h"
+
+ #define EVENT_SIZE (sizeof(struct inotify_event))
+ #define EVENT_BUFSIZE (1024 * EVENT_SIZE)
+diff --git a/utils/mountd/cache.c b/utils/mountd/cache.c
+index 7847446..ec86a22 100644
+--- a/utils/mountd/cache.c
++++ b/utils/mountd/cache.c
+@@ -31,6 +31,7 @@
+ #include "mountd.h"
+ #include "fsloc.h"
+ #include "pseudoflavors.h"
++#include "xcommon.h"
+
+ #ifdef USE_BLKID
+ #include "blkid/blkid.h"
+--
+2.7.4
+
diff --git a/net-fs/nfs-utils/nfs-utils-1.3.3.ebuild b/net-fs/nfs-utils/nfs-utils-1.3.3.ebuild
index 06740c38ab85..f7f8aa3d7e51 100644
--- a/net-fs/nfs-utils/nfs-utils-1.3.3.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.3.3.ebuild
@@ -58,6 +58,7 @@ DEPEND="${DEPEND_COMMON}
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.4-mtab-sym.patch
epatch "${FILESDIR}"/${PN}-1.2.8-cross-build.patch
+ epatch "${FILESDIR}"/${PN}-1.3.3-sysmacros.patch #579884
sed \
-e "/^sbindir/s:= := \"${EPREFIX}\":g" \