summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2018-11-08 12:50:06 -0500
committerIan Stakenvicius <axs@gentoo.org>2018-11-08 12:51:36 -0500
commitc3c0a86e506899288b9677d732d5394eb006b34e (patch)
tree66a6a654bdbba82af336feedde4087f5cc6e3f99 /net-fs/samba
parentkde-apps/kdesdk-meta: Add USE +webkit (diff)
downloadgentoo-c3c0a86e506899288b9677d732d5394eb006b34e.tar.gz
gentoo-c3c0a86e506899288b9677d732d5394eb006b34e.tar.bz2
gentoo-c3c0a86e506899288b9677d732d5394eb006b34e.zip
net-fs/samba: do not install python DSDB bits when USE=-addc
If ADDC is disabled, samba-4.8.6 was still installing python module smbd_dns.so , which links to libdnsserver-common-samba4.so but the latter is NOT installed. This causes infinite revdep-rebuild errors. This commit patches the build system to prevent said file from being installed. Bumped directly to stable by maintainers. Signed-off-by: Ian Stakenvicius <axs@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'net-fs/samba')
-rw-r--r--net-fs/samba/files/samba-4.8.6-no-pydsdb-when-no-addc.patch36
-rw-r--r--net-fs/samba/samba-4.8.6-r1.ebuild (renamed from net-fs/samba/samba-4.8.6.ebuild)0
2 files changed, 36 insertions, 0 deletions
diff --git a/net-fs/samba/files/samba-4.8.6-no-pydsdb-when-no-addc.patch b/net-fs/samba/files/samba-4.8.6-no-pydsdb-when-no-addc.patch
new file mode 100644
index 000000000000..1093b1de71df
--- /dev/null
+++ b/net-fs/samba/files/samba-4.8.6-no-pydsdb-when-no-addc.patch
@@ -0,0 +1,36 @@
+Do not install the python DSDB modules when ADDC is disabled.
+This is a change integrated upstream in 4.9.1 (or earlier).
+
+Without this, the python dsdb_dns.so module is installed, which
+is linked to libdnsserver-common.so that is NOT installed, and so
+potential breakage ensues.
+
+--- a/source4/dsdb/wscript_build 2018-01-17 03:08:39.000000000 -0500
++++ b/source4/dsdb/wscript_build 2018-11-08 10:43:58.064486832 -0500
+@@ -63,10 +63,11 @@
+ )
+
+ bld.SAMBA_PYTHON('python_dsdb',
+ source='pydsdb.c',
+ # the dependency on dcerpc here is because gensec
+ # depends on dcerpc but the waf circular dependency finder
+ # removes it so we end up with unresolved symbols.
+ deps='samdb pyldb-util dcerpc com_err pyrpc_util pyparam_util dsdb_garbage_collect_tombstones',
+- realname='samba/dsdb.so'
++ realname='samba/dsdb.so',
++ enabled=bld.AD_DC_BUILD_IS_ENABLED()
+ )
+--- a/source4/dns_server/wscript_build 2018-11-08 11:49:03.450296286 -0500
++++ b/source4/dns_server/wscript_build 2018-11-08 11:49:23.327864408 -0500
+@@ -64,9 +64,10 @@
+ private_library=True,
+ deps='samba-hostconfig samdb-common gensec popt dnsserver_common',
+ enabled=bld.AD_DC_BUILD_IS_ENABLED())
+
+
+ bld.SAMBA_PYTHON('python_dsdb_dns',
+ source='pydns.c',
+ deps='samdb pyldb-util pyrpc_util dnsserver_common pytalloc-util',
+- realname='samba/dsdb_dns.so')
++ realname='samba/dsdb_dns.so',
++ enabled=bld.AD_DC_BUILD_IS_ENABLED())
diff --git a/net-fs/samba/samba-4.8.6.ebuild b/net-fs/samba/samba-4.8.6-r1.ebuild
index ea2098018bb3..ea2098018bb3 100644
--- a/net-fs/samba/samba-4.8.6.ebuild
+++ b/net-fs/samba/samba-4.8.6-r1.ebuild