summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-25 17:27:31 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-25 17:33:23 -0400
commit55e4154fda49cc7cd95af9281282c7fc137d7983 (patch)
tree5c6ffa8c72a34cc48905af72ffaf116de40e8187 /net-fs/sshfs
parentnet-fs/s3backer: moved from sys-fs/s3backer (diff)
downloadgentoo-55e4154fda49cc7cd95af9281282c7fc137d7983.tar.gz
gentoo-55e4154fda49cc7cd95af9281282c7fc137d7983.tar.bz2
gentoo-55e4154fda49cc7cd95af9281282c7fc137d7983.zip
net-fs/sshfs: moved from sys-fs/sshfs
Diffstat (limited to 'net-fs/sshfs')
-rw-r--r--net-fs/sshfs/Manifest3
-rw-r--r--net-fs/sshfs/metadata.xml11
-rw-r--r--net-fs/sshfs/sshfs-2.5.ebuild32
-rw-r--r--net-fs/sshfs/sshfs-2.7.ebuild22
-rw-r--r--net-fs/sshfs/sshfs-2.8.ebuild22
5 files changed, 90 insertions, 0 deletions
diff --git a/net-fs/sshfs/Manifest b/net-fs/sshfs/Manifest
new file mode 100644
index 000000000000..4ae6926a13aa
--- /dev/null
+++ b/net-fs/sshfs/Manifest
@@ -0,0 +1,3 @@
+DIST sshfs-2.7.tar.gz 153014 SHA256 ce5f9d390934fc88c287dd937a39d15c2b40cbea6967ba24ad93ed90e0027128 SHA512 e8b00bc3661140d59c6735f1f76d1bd4c63ebc04b578cbcebca88c2f1df8b2cea18c86ff24bef5d40ce286319b55d906632bea53e6b37aff76744072250aec1b WHIRLPOOL 9c57fd7d7d32d51a90f365d9baabf67a3afb70af02664363f4861ed550f791eb7c9ecb132eb3641337bfae8a70b311b42ffc89dbeed3e7df8ff7bd9c2fb28505
+DIST sshfs-2.8.tar.gz 153230 SHA256 7f689174d02e6b7e2631306fda4fb8e6b4483102d1bce82b3cdafba33369ad22 SHA512 a3c6a75137a4410a0c4e049ffdb6e219319add9673de32cf32a74c12ff4bb80f92a6e75088417a180a4dd01957deec39bd780a02140e8b0348f5868c92d67cfd WHIRLPOOL b48b6586e85292079dd51505c3c11b4c8b563a6e858362d8863239672e1446e06bef8c6c3dbfc70756e452672e8416980024b557a3923dbf5ffeef62911b2c65
+DIST sshfs-fuse-2.5.tar.gz 136378 SHA256 e9171452e5d0150b9c6a2158fd2e2dcefb5d5d03ba4d208949e00a3a46c6e63e SHA512 48ae4008d10fe66b843ff1e891627f8262e00d064fec048c8c1189507e757994e81e4fa2deb4d8d56cff0d1818efe4a692494b9c48a01c6c79c626acefa1b53e WHIRLPOOL 00086691d287a770ce04ed068250841fe9fd8ec054a9f86f2ffd388c5c519b4f6bc559990724d25895065d6ab8618eb07129801c32a68eb9bfefb8fa952a412f
diff --git a/net-fs/sshfs/metadata.xml b/net-fs/sshfs/metadata.xml
new file mode 100644
index 000000000000..1dde05c3d522
--- /dev/null
+++ b/net-fs/sshfs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">libfuse/sshfs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-fs/sshfs/sshfs-2.5.ebuild b/net-fs/sshfs/sshfs-2.5.ebuild
new file mode 100644
index 000000000000..6f3f9d6cec98
--- /dev/null
+++ b/net-fs/sshfs/sshfs-2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+MY_PN=sshfs-fuse
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+HOMEPAGE="https://github.com/libfuse/sshfs"
+SRC_URI="https://github.com/libfuse/sshfs/releases/download/sshfs-${PV//./_}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 arm hppa ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+SLOT="0"
+
+CDEPEND=">=sys-fs/fuse-2.6.0_pre3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${CDEPEND}
+ >=net-misc/openssh-4.3"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( README NEWS ChangeLog AUTHORS FAQ.txt )
+
+src_configure() {
+ # hack not needed with >=net-misc/openssh-4.3
+ econf --disable-sshnodelay
+}
diff --git a/net-fs/sshfs/sshfs-2.7.ebuild b/net-fs/sshfs/sshfs-2.7.ebuild
new file mode 100644
index 000000000000..eb362da6a354
--- /dev/null
+++ b/net-fs/sshfs/sshfs-2.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+HOMEPAGE="https://github.com/libfuse/sshfs"
+SRC_URI="https://github.com/libfuse/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+SLOT="0"
+
+CDEPEND=">=sys-fs/fuse-2.6.0_pre3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${CDEPEND}
+ >=net-misc/openssh-4.4"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
diff --git a/net-fs/sshfs/sshfs-2.8.ebuild b/net-fs/sshfs/sshfs-2.8.ebuild
new file mode 100644
index 000000000000..7f314272dd15
--- /dev/null
+++ b/net-fs/sshfs/sshfs-2.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+HOMEPAGE="https://github.com/libfuse/sshfs"
+SRC_URI="https://github.com/libfuse/${PN}/releases/download/${PN}_${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+SLOT="0"
+
+CDEPEND=">=sys-fs/fuse-2.6.0_pre3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${CDEPEND}
+ >=net-misc/openssh-4.4"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )