summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-07 09:47:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-07 09:48:06 +0100
commit29d6c6b48236bf82d0f64cdaf77e379328343a64 (patch)
tree329c3567707185686d2b5d8678bc63660dcba8d2 /net-fs
parentnet-dns/dnscrypt-proxy: Add myself as maintainer. (diff)
downloadgentoo-29d6c6b48236bf82d0f64cdaf77e379328343a64.tar.gz
gentoo-29d6c6b48236bf82d0f64cdaf77e379328343a64.tar.bz2
gentoo-29d6c6b48236bf82d0f64cdaf77e379328343a64.zip
net-fs/nfs-utils: Bump to versions 2.2.1 and 2.2.2_rc1
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/Manifest2
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.2.1.ebuild190
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.2.2_rc1.ebuild190
3 files changed, 382 insertions, 0 deletions
diff --git a/net-fs/nfs-utils/Manifest b/net-fs/nfs-utils/Manifest
index 521804c736d2..a532193d2c78 100644
--- a/net-fs/nfs-utils/Manifest
+++ b/net-fs/nfs-utils/Manifest
@@ -3,3 +3,5 @@ DIST nfs-utils-2.1.1.tar.bz2 820083 SHA256 0a28416948516c26f3bfe90425b0de09b7936
DIST nfs-utils-2.1.2_rc3.tar.gz 475356 SHA256 5b379316a2cc49b07f72042b72eadee0bfe7c88e65d7b5baa4798e6cefca5a82 SHA512 2f948994f275b405678240deecc879900cc0e72476adaf552db059364f08f0929722013d751e0bc7913c30eb3f8183d1fc7693709c063fc92e20b71edd24ccef WHIRLPOOL 6a16a9cc3d22d883b6a8aa2d2f01dce81f9a1df03154a80e4aa43ae9bb878a15f0ca37951702f780341283da94d885b7be3656a950285ef79619e09dc465727f
DIST nfs-utils-2.1.2_rc5.tar.gz 476401 SHA256 52b32896572e0f81dffd5ccd90c367e5d00b5d371b8deef45dc744ee1b7ad2ab SHA512 28670ca993c1bf953632086ab15cec1b6a525fb1b28243e382f246362cfb2629c9d0416f4f65c6a2f2c46202a4c6855d1924a7f8c984395ddb98b6d4f4b0cbcb WHIRLPOOL f2e2f75c0a989402f75740164870e250a12f29f4b3f0eb7102cecf57aea0d647a0a7860798f9333e8bef9efc4af72f516c885c62cd079e89470d108cdaca4b9d
DIST nfs-utils-2.1.2_rc6.tar.gz 476695 SHA256 a88b499210eec4fb41414f9ba653570d1845981e414f5de6ae90ecaf14205977 SHA512 d7c054074e2ea4370a5e47922785fa2a0cf595623d0222cb16f910c4946ed7f3d6f093b471557ce139c85ad0dd321bed0222f5c5aa5b7bca04b31d422eb35f75 WHIRLPOOL 6dfec79baa7b37f57a162296b7e5acb07da9144d677cf1f7ec515fc220a844d9a0d7e935ac0f4b9a1db9eaa2816d5d1ea089141f11f6ae9e6ec8bd77d24be0b5
+DIST nfs-utils-2.2.1.tar.bz2 853812 SHA256 0d819d8da358bea6e005e1a6cf0f6fa0c5507a78747d36bc87a0182e6af14291 SHA512 05e2aa4f413a4a4927995847211680baf87f956a435d0d903dd7b6239f72e66a15a089758d41874c05c2137e0626d72c1714010c2a9ce854943fef7798db9a24 WHIRLPOOL 8cd39c83e0a761c3cc846f81184ec6cbe68289b2648c5605ba68a31379f86afafe67f6808f348b30875730a1ee1656d65738b74dd0863a70b48250a3d325f1fc
+DIST nfs-utils-2.2.2_rc1.tar.gz 509381 SHA256 5ed5c50ef20c49a9b96c99bd288d25dc94ecbdb4b314f5d885576692e89345bc SHA512 5cc9a19e1ebf1831f1914419c0e7f12ff12037caa35e5866dfba8bf30c5355dcf2e039928b9b336c6755df856549ccac6ea646d61b57c68f96fd586d21a27f1a WHIRLPOOL 407b721b43308b96ae48553169dfeafb2844dedbce3060860549d85322aea074539bac82bb5579a17d74b2fcc212156d1450feb8a5340570f3d33c763b8fed29
diff --git a/net-fs/nfs-utils/nfs-utils-2.2.1.ebuild b/net-fs/nfs-utils/nfs-utils-2.2.1.ebuild
new file mode 100644
index 000000000000..133e06869f03
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-2.2.1.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic multilib systemd
+
+DESCRIPTION="NFS client and server daemons"
+HOMEPAGE="http://linux-nfs.org/"
+
+if [[ "${PV}" = *_rc* ]] ; then
+ inherit versionator
+ MY_PV="$(replace_all_version_separators -)"
+ SRC_URI="http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=snapshot;h=refs/tags/${PN}-${MY_PV};sf=tgz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
+else
+ SRC_URI="mirror://sourceforge/nfs/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps ipv6 kerberos +libmount nfsdcld +nfsidmap +nfsv4 nfsv41 selinux tcpd +uuid"
+REQUIRED_USE="kerberos? ( nfsv4 )"
+RESTRICT="test" #315573
+
+# kth-krb doesn't provide the right include
+# files, and nfs-utils doesn't build against heimdal either,
+# so don't depend on virtual/krb.
+# (04 Feb 2005 agriffis)
+DEPEND_COMMON="tcpd? ( sys-apps/tcp-wrappers )
+ caps? ( sys-libs/libcap )
+ sys-libs/e2fsprogs-libs
+ >=net-nds/rpcbind-0.2.4
+ net-libs/libtirpc:=
+ libmount? ( sys-apps/util-linux )
+ nfsdcld? ( >=dev-db/sqlite-3.3 )
+ nfsv4? (
+ dev-libs/libevent:=
+ >=net-libs/libnfsidmap-0.21-r1
+ kerberos? (
+ >=net-libs/libtirpc-0.2.4-r1[kerberos]
+ app-crypt/mit-krb5
+ )
+ nfsidmap? (
+ >=net-libs/libnfsidmap-0.24
+ >=sys-apps/keyutils-1.5.9
+ )
+ )
+ nfsv41? (
+ sys-fs/lvm2
+ )
+ uuid? ( sys-apps/util-linux )"
+RDEPEND="${DEPEND_COMMON}
+ !net-nds/portmap
+ !<sys-apps/openrc-0.13.9
+ selinux? (
+ sec-policy/selinux-rpc
+ sec-policy/selinux-rpcbind
+ )
+"
+DEPEND="${DEPEND_COMMON}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.4-mtab-sym.patch
+ "${FILESDIR}"/${PN}-1.2.8-cross-build.patch
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e "/^sbindir/s:= := \"${EPREFIX}\":g" \
+ -i utils/*/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ export libsqlite3_cv_is_recent=yes # Our DEPEND forces this.
+ export ac_cv_header_keyutils_h=$(usex nfsidmap)
+ local myeconfargs=(
+ --with-statedir="${EPREFIX}"/var/lib/nfs
+ --enable-tirpc
+ --with-tirpcinclude="${EPREFIX}"/usr/include/tirpc/
+ $(use_enable libmount libmount-mount)
+ $(use_with tcpd tcp-wrappers)
+ $(use_enable nfsdcld nfsdcltrack)
+ $(use_enable nfsv4)
+ $(use_enable nfsv41)
+ $(use_enable ipv6)
+ $(use_enable caps)
+ $(use_enable uuid)
+ $(use_enable kerberos gss)
+ $(use_enable kerberos svcgss)
+ --without-gssglue
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile(){
+ # remove compiled files bundled in the tarball
+ emake clean
+ default
+}
+
+src_install() {
+ default
+ rm linux-nfs/Makefile* || die
+ dodoc -r linux-nfs README
+
+ # Don't overwrite existing xtab/etab, install the original
+ # versions somewhere safe... more info in pkg_postinst
+ keepdir /var/lib/nfs/{,sm,sm.bak}
+ mv "${ED%/}"/var/lib "${ED%/}"/usr/$(get_libdir) || die
+
+ # Install some client-side binaries in /sbin
+ dodir /sbin
+ mv "${ED%/}"/usr/sbin/rpc.statd "${ED%/}"/sbin/ || die
+
+ if use nfsv4 && use nfsidmap ; then
+ # Install a config file for idmappers in newer kernels. #415625
+ insinto /etc/request-key.d
+ echo 'create id_resolver * * /usr/sbin/nfsidmap -t 600 %k %d' > id_resolver.conf
+ doins id_resolver.conf
+ fi
+
+ insinto /etc
+ doins "${FILESDIR}"/exports
+ keepdir /etc/exports.d
+
+ local f list=() opt_need=""
+ if use nfsv4 ; then
+ opt_need="rpc.idmapd"
+ list+=( rpc.idmapd rpc.pipefs )
+ use kerberos && list+=( rpc.gssd rpc.svcgssd )
+ fi
+ for f in nfs nfsclient rpc.statd "${list[@]}" ; do
+ newinitd "${FILESDIR}"/${f}.initd ${f}
+ done
+ newinitd "${FILESDIR}"/nfsmount.initd-1.3.1 nfsmount # Nuke after 2015/08/01
+ for f in nfs nfsclient ; do
+ newconfd "${FILESDIR}"/${f}.confd ${f}
+ done
+ sed -i \
+ -e "/^NFS_NEEDED_SERVICES=/s:=.*:=\"${opt_need}\":" \
+ "${ED%/}"/etc/conf.d/nfs || die #234132
+
+ local systemd_systemunitdir="$(systemd_get_systemunitdir)"
+ systemd_dounit systemd/*.{mount,service,target}
+ if ! use nfsv4 || ! use kerberos ; then
+ rm "${ED%/}${systemd_systemunitdir}"/rpc-{gssd,svcgssd}.service || die
+ fi
+ if ! use nfsv41 ; then
+ rm "${ED%/}${systemd_systemunitdir}"/nfs-blkmap.* || die
+ fi
+ sed -i \
+ -e 's:/usr/sbin/rpc.statd:/sbin/rpc.statd:' \
+ "${ED%/}${systemd_systemunitdir}"/* || die
+
+ keepdir /var/lib/nfs #368505
+ keepdir /var/lib/nfs/v4recovery #603628
+
+}
+
+pkg_postinst() {
+ # Install default xtab and friends if there's none existing. In
+ # src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. #30486
+ local f
+ for f in "${EROOT%/}"/usr/$(get_libdir)/nfs/*; do
+ [[ -e ${EROOT%/}/var/lib/nfs/${f##*/} ]] && continue
+ einfo "Copying default ${f##*/} from ${EPREFIX}/usr/$(get_libdir)/nfs to ${EPREFIX}/var/lib/nfs"
+ cp -pPR "${f}" "${EROOT%/}"/var/lib/nfs/
+ done
+
+ if systemd_is_booted; then
+ if [[ ${REPLACING_VERSIONS} < 1.3.0 ]]; then
+ ewarn "We have switched to upstream systemd unit files. Since"
+ ewarn "they got renamed, you should probably enable the new ones."
+ ewarn "You can run 'equery files nfs-utils | grep systemd'"
+ ewarn "to know what services you need to enable now."
+ fi
+ else
+ ewarn "If you use OpenRC, the nfsmount service has been replaced with nfsclient."
+ ewarn "If you were using nfsmount, please add nfsclient and netmount to the"
+ ewarn "same runlevel as nfsmount."
+ fi
+}
diff --git a/net-fs/nfs-utils/nfs-utils-2.2.2_rc1.ebuild b/net-fs/nfs-utils/nfs-utils-2.2.2_rc1.ebuild
new file mode 100644
index 000000000000..133e06869f03
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-2.2.2_rc1.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic multilib systemd
+
+DESCRIPTION="NFS client and server daemons"
+HOMEPAGE="http://linux-nfs.org/"
+
+if [[ "${PV}" = *_rc* ]] ; then
+ inherit versionator
+ MY_PV="$(replace_all_version_separators -)"
+ SRC_URI="http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=snapshot;h=refs/tags/${PN}-${MY_PV};sf=tgz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
+else
+ SRC_URI="mirror://sourceforge/nfs/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps ipv6 kerberos +libmount nfsdcld +nfsidmap +nfsv4 nfsv41 selinux tcpd +uuid"
+REQUIRED_USE="kerberos? ( nfsv4 )"
+RESTRICT="test" #315573
+
+# kth-krb doesn't provide the right include
+# files, and nfs-utils doesn't build against heimdal either,
+# so don't depend on virtual/krb.
+# (04 Feb 2005 agriffis)
+DEPEND_COMMON="tcpd? ( sys-apps/tcp-wrappers )
+ caps? ( sys-libs/libcap )
+ sys-libs/e2fsprogs-libs
+ >=net-nds/rpcbind-0.2.4
+ net-libs/libtirpc:=
+ libmount? ( sys-apps/util-linux )
+ nfsdcld? ( >=dev-db/sqlite-3.3 )
+ nfsv4? (
+ dev-libs/libevent:=
+ >=net-libs/libnfsidmap-0.21-r1
+ kerberos? (
+ >=net-libs/libtirpc-0.2.4-r1[kerberos]
+ app-crypt/mit-krb5
+ )
+ nfsidmap? (
+ >=net-libs/libnfsidmap-0.24
+ >=sys-apps/keyutils-1.5.9
+ )
+ )
+ nfsv41? (
+ sys-fs/lvm2
+ )
+ uuid? ( sys-apps/util-linux )"
+RDEPEND="${DEPEND_COMMON}
+ !net-nds/portmap
+ !<sys-apps/openrc-0.13.9
+ selinux? (
+ sec-policy/selinux-rpc
+ sec-policy/selinux-rpcbind
+ )
+"
+DEPEND="${DEPEND_COMMON}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.4-mtab-sym.patch
+ "${FILESDIR}"/${PN}-1.2.8-cross-build.patch
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e "/^sbindir/s:= := \"${EPREFIX}\":g" \
+ -i utils/*/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ export libsqlite3_cv_is_recent=yes # Our DEPEND forces this.
+ export ac_cv_header_keyutils_h=$(usex nfsidmap)
+ local myeconfargs=(
+ --with-statedir="${EPREFIX}"/var/lib/nfs
+ --enable-tirpc
+ --with-tirpcinclude="${EPREFIX}"/usr/include/tirpc/
+ $(use_enable libmount libmount-mount)
+ $(use_with tcpd tcp-wrappers)
+ $(use_enable nfsdcld nfsdcltrack)
+ $(use_enable nfsv4)
+ $(use_enable nfsv41)
+ $(use_enable ipv6)
+ $(use_enable caps)
+ $(use_enable uuid)
+ $(use_enable kerberos gss)
+ $(use_enable kerberos svcgss)
+ --without-gssglue
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile(){
+ # remove compiled files bundled in the tarball
+ emake clean
+ default
+}
+
+src_install() {
+ default
+ rm linux-nfs/Makefile* || die
+ dodoc -r linux-nfs README
+
+ # Don't overwrite existing xtab/etab, install the original
+ # versions somewhere safe... more info in pkg_postinst
+ keepdir /var/lib/nfs/{,sm,sm.bak}
+ mv "${ED%/}"/var/lib "${ED%/}"/usr/$(get_libdir) || die
+
+ # Install some client-side binaries in /sbin
+ dodir /sbin
+ mv "${ED%/}"/usr/sbin/rpc.statd "${ED%/}"/sbin/ || die
+
+ if use nfsv4 && use nfsidmap ; then
+ # Install a config file for idmappers in newer kernels. #415625
+ insinto /etc/request-key.d
+ echo 'create id_resolver * * /usr/sbin/nfsidmap -t 600 %k %d' > id_resolver.conf
+ doins id_resolver.conf
+ fi
+
+ insinto /etc
+ doins "${FILESDIR}"/exports
+ keepdir /etc/exports.d
+
+ local f list=() opt_need=""
+ if use nfsv4 ; then
+ opt_need="rpc.idmapd"
+ list+=( rpc.idmapd rpc.pipefs )
+ use kerberos && list+=( rpc.gssd rpc.svcgssd )
+ fi
+ for f in nfs nfsclient rpc.statd "${list[@]}" ; do
+ newinitd "${FILESDIR}"/${f}.initd ${f}
+ done
+ newinitd "${FILESDIR}"/nfsmount.initd-1.3.1 nfsmount # Nuke after 2015/08/01
+ for f in nfs nfsclient ; do
+ newconfd "${FILESDIR}"/${f}.confd ${f}
+ done
+ sed -i \
+ -e "/^NFS_NEEDED_SERVICES=/s:=.*:=\"${opt_need}\":" \
+ "${ED%/}"/etc/conf.d/nfs || die #234132
+
+ local systemd_systemunitdir="$(systemd_get_systemunitdir)"
+ systemd_dounit systemd/*.{mount,service,target}
+ if ! use nfsv4 || ! use kerberos ; then
+ rm "${ED%/}${systemd_systemunitdir}"/rpc-{gssd,svcgssd}.service || die
+ fi
+ if ! use nfsv41 ; then
+ rm "${ED%/}${systemd_systemunitdir}"/nfs-blkmap.* || die
+ fi
+ sed -i \
+ -e 's:/usr/sbin/rpc.statd:/sbin/rpc.statd:' \
+ "${ED%/}${systemd_systemunitdir}"/* || die
+
+ keepdir /var/lib/nfs #368505
+ keepdir /var/lib/nfs/v4recovery #603628
+
+}
+
+pkg_postinst() {
+ # Install default xtab and friends if there's none existing. In
+ # src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. #30486
+ local f
+ for f in "${EROOT%/}"/usr/$(get_libdir)/nfs/*; do
+ [[ -e ${EROOT%/}/var/lib/nfs/${f##*/} ]] && continue
+ einfo "Copying default ${f##*/} from ${EPREFIX}/usr/$(get_libdir)/nfs to ${EPREFIX}/var/lib/nfs"
+ cp -pPR "${f}" "${EROOT%/}"/var/lib/nfs/
+ done
+
+ if systemd_is_booted; then
+ if [[ ${REPLACING_VERSIONS} < 1.3.0 ]]; then
+ ewarn "We have switched to upstream systemd unit files. Since"
+ ewarn "they got renamed, you should probably enable the new ones."
+ ewarn "You can run 'equery files nfs-utils | grep systemd'"
+ ewarn "to know what services you need to enable now."
+ fi
+ else
+ ewarn "If you use OpenRC, the nfsmount service has been replaced with nfsclient."
+ ewarn "If you were using nfsmount, please add nfsclient and netmount to the"
+ ewarn "same runlevel as nfsmount."
+ fi
+}