summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-09-03 10:55:30 +0200
committerHanno Böck <hanno@gentoo.org>2020-09-03 10:55:50 +0200
commitd675113d42a284eec27e443d78222a7c40ef65f7 (patch)
tree063e5c3b2eb26cdd1d7877311713304024fd7448 /net-im/gajim
parentmedia-plugins/cmt-plugins: fixed clang compilation + linking in 1.17-r1 (diff)
downloadgentoo-d675113d42a284eec27e443d78222a7c40ef65f7.tar.gz
gentoo-d675113d42a284eec27e443d78222a7c40ef65f7.tar.bz2
gentoo-d675113d42a284eec27e443d78222a7c40ef65f7.zip
net-im/gajim: Bump and Python 3.9.
Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.5, Repoman-3.0.1
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/Manifest1
-rw-r--r--net-im/gajim/gajim-1.2.2.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-im/gajim/Manifest b/net-im/gajim/Manifest
index f1ad66f3d824..eecdf685b3eb 100644
--- a/net-im/gajim/Manifest
+++ b/net-im/gajim/Manifest
@@ -1 +1,2 @@
DIST gajim-1.2.1.tar.gz 9421625 BLAKE2B 890c4ac30506a771a3158f46c687723aacfed5fe7b7da3984e8de7354d8a448508cf98e5b224060078571bb27eecb2bb74927d610dae23709a522d77bb018961 SHA512 1a1ebc3a0605a12b5f459c576037359543814686a170199148e44e409d4f054cefdb66505e68ed4c28bd8c64a7910a70301c2d90d1d4b31b9587d9126329e8c4
+DIST gajim-1.2.2.tar.gz 9416794 BLAKE2B ab1dd2997422175bb7591bc11b230c47f9b72326fbf5b652ae15710bb46798ac8a1514dc2e1361e89bef4a80f43d5f64cf09879f3faffa927aa4407fe696b564 SHA512 297afa2b0ac44aad59b203907b1479fb8f004e2dc2a00681fa8034d76e4fb89ee3dcb4fb96011028382659bcb978cf214c396073d29b3dd0a7a711454915057b
diff --git a/net-im/gajim/gajim-1.2.2.ebuild b/net-im/gajim/gajim-1.2.2.ebuild
new file mode 100644
index 000000000000..60719dd066e4
--- /dev/null
+++ b/net-im/gajim/gajim-1.2.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE="sqlite,xml"
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="https://gajim.org/"
+SRC_URI="https://gajim.org/downloads/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt geolocation jingle remote rst +spell upnp +webp"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection[cairo(+)]
+ >=x11-libs/gtk+-3.22:3[introspection]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ >=dev-python/python-nbxmpp-1.0.2[${PYTHON_USEDEP}]
+ x11-libs/libXScrnSaver
+ app-crypt/libsecret[crypt,introspection]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ >=dev-python/secretstorage-3.1.1[${PYTHON_USEDEP}]
+ dev-python/css-parser[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ net-libs/libsoup[introspection]
+ media-libs/gsound[introspection]
+ crypt? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
+ geolocation? ( app-misc/geoclue[introspection] )
+ jingle? (
+ net-libs/farstream:0.2[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gst-plugins-ugly:1.0
+ )
+ remote? (
+ >=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ )
+ rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ spell? (
+ app-text/gspell[introspection]
+ app-text/hunspell
+ )
+ upnp? ( net-libs/gupnp-igd[introspection] )
+ webp? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ')"
+
+src_install() {
+ distutils-r1_src_install
+
+ # avoid precompressed man pages
+ rm -r "${D}/usr/share/man"
+ doman data/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}