summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-30 10:23:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-30 10:58:23 +0100
commit9beed400f557ea287c84d2d21b2d0e948b3cf21c (patch)
treed7d9a8b7fbcf74b6a0ec8bae7b4ca4f31909805c /net-im/psi
parentnet-im/psi: Switch to xdg.eclass (diff)
downloadgentoo-9beed400f557ea287c84d2d21b2d0e948b3cf21c.tar.gz
gentoo-9beed400f557ea287c84d2d21b2d0e948b3cf21c.tar.bz2
gentoo-9beed400f557ea287c84d2d21b2d0e948b3cf21c.zip
net-im/psi: EAPI-7 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im/psi')
-rw-r--r--net-im/psi/psi-9999.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/net-im/psi/psi-9999.ebuild b/net-im/psi/psi-9999.ebuild
index 4c1e85949f64..24d8d574291e 100644
--- a/net-im/psi/psi-9999.ebuild
+++ b/net-im/psi/psi-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PLOCALES="be bg ca cs de en eo es et fa fi fr he hu it ja kk mk nl pl pt pt_BR ru sk sl sr@latin sv sw uk ur_PK vi zh_CN zh_TW"
PLOCALE_BACKUP="en"
@@ -29,7 +29,13 @@ REQUIRED_USE="
webengine? ( !webkit )
"
-RDEPEND="
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ extras? ( >=sys-devel/qconf-2.4 )
+"
+DEPEND="
app-crypt/qca:2[ssl]
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
@@ -57,13 +63,7 @@ RDEPEND="
whiteboarding? ( dev-qt/qtsvg:5 )
xscreensaver? ( x11-libs/libXScrnSaver )
"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- extras? ( >=sys-devel/qconf-2.4 )
-"
-PDEPEND="
+RDEPEND="${DEPEND}
dev-qt/qtimageformats
"
@@ -73,14 +73,12 @@ pkg_setup() {
MY_PN=psi
if use extras; then
MY_PN=psi-plus
- echo
ewarn "You're about to build patched version of Psi called Psi+."
ewarn "It has new nice features not yet included to Psi."
ewarn "Take a look at homepage for more info: http://psi-plus.com/"
- echo
if use iconsets; then
- echo
+ ewarn
ewarn "Some artwork is from open source projects, but some is provided 'as-is'"
ewarn "and has not clear licensing."
ewarn "Possibly this build is not redistributable in some countries."
@@ -168,7 +166,7 @@ src_install() {
emake INSTALL_ROOT="${D}" install
# this way the docs will be installed in the standard gentoo dir
- rm "${ED}"/usr/share/${MY_PN}/{COPYING,README.html} || die "Installed file set seems to be changed by upstream"
+ rm "${ED}"/usr/share/${MY_PN}/{COPYING,README.html} || die "doc files set seems to have changed"
newdoc iconsets/roster/README README.roster
newdoc iconsets/system/README README.system
newdoc certs/README README.certs