summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Ilinykh <rion4ik@gmail.com>2018-11-02 23:47:23 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-04 21:33:39 +0100
commit9fe9ff4461f87d1fb042ac7d0b3c330453958e6f (patch)
tree7132222a352d87018fe7028801e4fe036f81013d /net-im/psi
parentapp-office/skrooge: 2.16.2 version bump (diff)
downloadgentoo-9fe9ff4461f87d1fb042ac7d0b3c330453958e6f.tar.gz
gentoo-9fe9ff4461f87d1fb042ac7d0b3c330453958e6f.tar.bz2
gentoo-9fe9ff4461f87d1fb042ac7d0b3c330453958e6f.zip
net-im/psi: 1.4 version bump
Signed-off-by: Sergey Ilinykh <rion4ik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10323 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im/psi')
-rw-r--r--net-im/psi/Manifest4
-rw-r--r--net-im/psi/psi-1.4.ebuild124
2 files changed, 126 insertions, 2 deletions
diff --git a/net-im/psi/Manifest b/net-im/psi/Manifest
index 4b829442f0f2..b34f42685fd8 100644
--- a/net-im/psi/Manifest
+++ b/net-im/psi/Manifest
@@ -1,2 +1,2 @@
-DIST psi-1.3.tar.xz 2143076 BLAKE2B 88b930d06c3a42519d9500148bd8a4300917d3db8b11cd45eb36e3a340f46c0776f3d8d5d5ddbf15f7ff78e3da89f011b19e2b7e8ccf973bb20fa6407cdfcd24 SHA512 b1b0f8d0c8326d486cb908d7b7de8f48579a2775f4cad0721ebeb646abd35e890712df176dd8676bf6c6089db88e73cf1b0423bd7a0ea0054661bdcea89349fe
-DIST psi-l10n-1.3.tar.gz 2991441 BLAKE2B 78fac27c069c097189b01594320aa139af5e66baf57de7e9fe58bd216281ba201d14737fcf5b3fe669ad706ae32dfb1d3d2d15801d212bcc02b4aefe41116d52 SHA512 22885352b5f443ff0719ae4e861ce5626e779ec231ac13b5cd48a7c57065289c6c5504ae6d1f5782ad05b3d27a477fd52e729cfcd1c774786872d8a79cf55090
+DIST psi-1.4.tar.xz 2119840 BLAKE2B 28298f526f23a4bcbb5452ca593163efd50c990a6bc9a2ed54d2136e0b34cf34ad2f1d4a81bd529a013b8aa351e8531f4bf9ea7faf3958085869dd75817828f8 SHA512 9bb8da58809270e5387e024f5ea031e28441e66cde53cde219beebe7b46bfa5c41d0a86110d1936d0ac2e15483ffb947f8998cbeeb415f72553cb78b67c57ed1
+DIST psi-l10n-1.4.tar.gz 2991451 BLAKE2B 628aaa1b8e3a31f958ed355edce4a6495085b6d978cd611bcb3b00af0d6e6b0d893cafde3d9a8253279645e6fb6a056fe5e701ac36c68bf9fed642b026a2642c SHA512 53dcec52493319e28c473e2e7765341b10451e390c317bb13b8c8d165e9cef4eb1099a87910dacfc9444a8f9df029a98e380ab8f4529c6d2830734328b834915
diff --git a/net-im/psi/psi-1.4.ebuild b/net-im/psi/psi-1.4.ebuild
new file mode 100644
index 000000000000..c32424e600c8
--- /dev/null
+++ b/net-im/psi/psi-1.4.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="be bg ca cs de en eo es et fa fi fr he hu it ja kk mk nl pl pt pt_BR ru sk sl sr@latin sv sw uk ur_PK vi zh_CN zh_TW"
+PLOCALE_BACKUP="en"
+
+inherit l10n qmake-utils gnome2-utils xdg-utils
+
+DESCRIPTION="Qt XMPP client"
+HOMEPAGE="https://psi-im.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz
+ https://github.com/psi-im/psi-l10n/archive/${PV}.tar.gz -> psi-l10n-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aspell crypt dbus debug doc enchant +hunspell webengine webkit whiteboarding xscreensaver"
+
+REQUIRED_USE="
+ ?? ( aspell enchant hunspell )
+ webengine? ( !webkit )
+"
+
+RDEPEND="
+ app-crypt/qca:2[ssl]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ net-dns/libidn:0
+ sys-libs/zlib[minizip]
+ x11-libs/libX11
+ x11-libs/libxcb
+ aspell? ( app-text/aspell )
+ dbus? ( dev-qt/qtdbus:5 )
+ enchant? ( >=app-text/enchant-1.3.0 )
+ hunspell? ( app-text/hunspell:= )
+ webengine? (
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5[widgets]
+ )
+ webkit? ( dev-qt/qtwebkit:5 )
+ whiteboarding? ( dev-qt/qtsvg:5 )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+RESTRICT="test"
+
+src_configure() {
+ CONF=(
+ --prefix="${EPREFIX}"/usr
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --no-separate-debug-info
+ --qtdir="$(qt5_get_bindir)/.."
+ $(use_enable aspell)
+ $(use_enable dbus qdbus)
+ $(use_enable enchant)
+ $(use_enable hunspell)
+ $(use_enable xscreensaver xss)
+ $(use_enable whiteboarding)
+ )
+
+ use debug && CONF+=("--debug")
+ use webengine && CONF+=("--enable-webkit" "--with-webkit=qtwebengine")
+ use webkit && CONF+=("--enable-webkit" "--with-webkit=qtwebkit")
+
+ # This may generate warnings if passed option already matches with default.
+ # Just ignore them. It's how qconf-based configure works and will be fixed in
+ # future qconf versions.
+ ./configure "${CONF[@]}" || die "configure failed"
+
+ eqmake5 psi.pro
+}
+
+src_compile() {
+ emake
+ use doc && emake -C doc api_public
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ # this way the docs will be installed in the standard gentoo dir
+ rm "${ED}"/usr/share/psi/{COPYING,README} || die "Installed file set seems to be changed by upstream"
+ newdoc iconsets/roster/README README.roster
+ newdoc iconsets/system/README README.system
+ newdoc certs/README README.certs
+ dodoc README
+
+ use doc && HTML_DOCS=( doc/api/. )
+ einstalldocs
+
+ # install translations
+ local mylrelease="$(qt5_get_bindir)"/lrelease
+ cd "${WORKDIR}/psi-l10n-${PV}" || die
+ insinto /usr/share/psi
+ install_locale() {
+ "${mylrelease}" "translations/${PN}_${1}.ts" || die "lrelease ${1} failed"
+ doins "translations/${PN}_${1}.qm"
+ }
+ l10n_for_each_locale_do install_locale
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ einfo "For GPG support make sure app-crypt/qca is compiled with gpg USE flag."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}