summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZetok Zalbavar <zetok@openmailbox.org>2016-11-13 22:43:18 +0000
committerGöktürk Yüksek <gokturk@gentoo.org>2016-11-17 00:26:42 -0500
commit840ede2f4ed05dba6bbb53bdbf6d6f038c82e542 (patch)
tree8cc489a8c9d739b93bbc3f43b4921e34e654b87e /net-im/qtox/qtox-1.6.0.ebuild
parentgames-board/stockfish: take over maintainership (diff)
downloadgentoo-840ede2f4ed05dba6bbb53bdbf6d6f038c82e542.tar.gz
gentoo-840ede2f4ed05dba6bbb53bdbf6d6f038c82e542.tar.bz2
gentoo-840ede2f4ed05dba6bbb53bdbf6d6f038c82e542.zip
net-im/qtox: bump version to v1.6.0 and remove outdated versions
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-im/qtox/qtox-1.6.0.ebuild')
-rw-r--r--net-im/qtox/qtox-1.6.0.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-im/qtox/qtox-1.6.0.ebuild b/net-im/qtox/qtox-1.6.0.ebuild
new file mode 100644
index 000000000000..fb6373082fc7
--- /dev/null
+++ b/net-im/qtox/qtox-1.6.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
+HOMEPAGE="https://github.com/qTox/qTox"
+SRC_URI="https://github.com/qTox/qTox/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk X"
+
+# needed, since tarball provided by github extracts to `qTox`
+S="${WORKDIR}/qTox-${PV}"
+
+RDEPEND="
+ dev-db/sqlcipher
+ dev-libs/libsodium
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[gif,jpeg,png,xcb]
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-gfx/qrencode
+ media-libs/openal
+ >=media-video/ffmpeg-2.6.3[webp,v4l]
+ gtk? ( dev-libs/atk
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf[X]
+ x11-libs/gtk+:2
+ x11-libs/cairo[X]
+ x11-libs/pango[X] )
+ net-libs/tox[av]
+ X? ( x11-libs/libX11
+ x11-libs/libXScrnSaver )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if tc-is-gcc ; then
+ if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 8 || $(gcc-major-version) -lt 4 ]] ; then
+ eerror "You need at least sys-devel/gcc-4.8.3"
+ die "You need at least sys-devel/gcc-4.8.3"
+ fi
+ fi
+ fi
+}
+
+src_configure() {
+ use gtk || local NO_GTK_SUPPORT="ENABLE_SYSTRAY_STATUSNOTIFIER_BACKEND=NO ENABLE_SYSTRAY_GTK_BACKEND=NO"
+ use X || local NO_X_SUPPORT="DISABLE_PLATFORM_EXT=YES"
+
+ eqmake5 \
+ PREFIX="${D}/usr" \
+ GIT_DESCRIBE="${PV}" \
+ ${NO_GTK_SUPPORT} \
+ ${NO_X_SUPPORT}
+}