summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-15 22:22:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-17 01:12:20 +0100
commit664209dc8505d9aa1fd12ed289969ee181b9e551 (patch)
treea3f765cb879114b08e14ed387282c11c375a3406 /net-im/qtox/qtox-9999.ebuild
parentdev-qt/qtgui: Restore QHighDPIScaling::isActive() 5.13 behavior (diff)
downloadgentoo-664209dc8505d9aa1fd12ed289969ee181b9e551.tar.gz
gentoo-664209dc8505d9aa1fd12ed289969ee181b9e551.tar.bz2
gentoo-664209dc8505d9aa1fd12ed289969ee181b9e551.zip
net-im/qtox: EAPI-7 bump, use cmake.eclass, fix build with Qt-5.13
Closes: https://bugs.gentoo.org/699152 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im/qtox/qtox-9999.ebuild')
-rw-r--r--net-im/qtox/qtox-9999.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index 955d7a8edce1..c2f80f279d6f 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -1,21 +1,25 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils eutils git-r3 gnome2-utils xdg-utils
+inherit cmake git-r3 xdg
DESCRIPTION="Most feature-rich GUI for net-libs/tox using Qt5"
HOMEPAGE="https://github.com/qTox/qTox"
-SRC_URI=""
EGIT_REPO_URI="https://github.com/qTox/qTox.git"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
IUSE="notification test X"
+
RESTRICT="!test? ( test )"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
RDEPEND="
dev-db/sqlcipher
dev-libs/libsodium:=
@@ -38,13 +42,11 @@ RDEPEND="
x11-libs/libXScrnSaver )
"
DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- virtual/pkgconfig
test? ( dev-qt/qttest:5 )
"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# bug 628574
if ! use test; then
@@ -61,15 +63,5 @@ src_configure() {
-DUSE_FILTERAUDIO=OFF
)
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
+ cmake_src_configure
}