summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Vesely <jano.vesely@gmail.com>2018-10-18 21:36:38 -0400
committerMikle Kolyada <zlogene@gentoo.org>2018-10-21 14:32:09 +0300
commit94b029f357ec31fcae69fc809b73355300c25173 (patch)
tree0459c8276a3c054478a4de936a423f8834d5b1a0 /net-im/telegram-desktop-bin
parentmedia-libs/harfbuzz: Bump to version 2.0.2 (diff)
downloadgentoo-94b029f357ec31fcae69fc809b73355300c25173.tar.gz
gentoo-94b029f357ec31fcae69fc809b73355300c25173.tar.bz2
gentoo-94b029f357ec31fcae69fc809b73355300c25173.zip
net-im/telegram-desktop-bin: Bump version to 1.4.3
Signed-off-by: Jan Vesely <jano.vesely@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10175 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-im/telegram-desktop-bin')
-rw-r--r--net-im/telegram-desktop-bin/Manifest3
-rw-r--r--net-im/telegram-desktop-bin/telegram-desktop-bin-1.4.3.ebuild75
2 files changed, 78 insertions, 0 deletions
diff --git a/net-im/telegram-desktop-bin/Manifest b/net-im/telegram-desktop-bin/Manifest
index ef55ab03952c..3eb75cc7d1e7 100644
--- a/net-im/telegram-desktop-bin/Manifest
+++ b/net-im/telegram-desktop-bin/Manifest
@@ -1,3 +1,6 @@
DIST tdesktop-1.4.0.tar.gz 17318129 BLAKE2B bd77ac1c20aeb3e760294f32d8649d49740ef97aae37fabc90aee8207e87109812ce824e25b028785f4ab6fc932ed2e727022cf40a61a189e9f90eb056b0e19a SHA512 4eb123dc34edd3a47848abac66ca7c07a6bf9cf0658a9e904797ae52324f3cdcef3de9a63983f4003652c36087d4ab2e0a9fbf6c6c95b424fd68a65bd77ecadf
DIST tsetup.1.4.0.tar.xz 34811788 BLAKE2B a46e38b8d27ce764b7e9e735809a5098456368ed747e83bc16d125d80e6b772e1fb0eeee0d6b8eab937c04148b2516d5130c365dbda7e7a05571b14137b5a9c5 SHA512 c646763d66a807ade2c5d475444ce651dfd8ff488cafc4148a9e6850485fcfa8bc41d821dea1a9a6d6d5ac8f97593f5cedefa20a533d057c40e72a497afe264c
DIST tsetup32.1.4.0.tar.xz 37403084 BLAKE2B dd134c49da40fb25266e0bbaf5722675eea84bf760029646f0d727f6df587a789d42d40c1de1d3f8eb6a2623e5f5e569524b618df18ea48d26e0a05a1a597310 SHA512 8700221f791fa366bedbe666f8d73ec68a216db0dd0ceef43332fd4ce075897c003b069f51946e29dc1b1574dd50fdd6abb1ed491d1c09f5952d044628656a3a
+DIST tdesktop-1.4.3.tar.gz 17341652 BLAKE2B 26bacb695bb6e5adfd9fcdb394652695b6d8300fb856caf12cb7e22dd571b370cf74d38363c7eecdd8d7bde9fc3d43a91fd08ab175c2d3406db4f8cfed8619aa SHA512 c72deb10be79221c86b84cb36cf647e69bd51f57c05ae0ab0a43a23b04829aed068536124acfafd308e2b850de64bf448eec770e1d6a5423bb4a6b4c445edb6f
+DIST tsetup.1.4.3.tar.xz 34895128 BLAKE2B efea0915fee03ff7eecd4739b4c656b7282858611c96d7a59faf8e59f94a6a6bb5e29060f280af2dee5e7f6516564268e977f1e801cce0f1bd7c6bbdf491128d SHA512 fb344584fa2ce2adb53c6377cee34d917464495aaa0aa20d80ef80071f480ea2477f5fed4d5af336e95c9999dc2f2c73d30ff72146662d076d254b23bfc57969
+DIST tsetup32.1.4.3.tar.xz 37493196 BLAKE2B 1643016dd13e4f214fbac9892c7784f6998ce5fefd50d001d38db1fbd92c2f102eadf4b7d15a46e2151eeff971b5ed70f5ac8b9476ff4d7d489ad8c0ebf95f17 SHA512 e5b321da75b15c97438d30d480ce73305d97fe3373146650f132931f0620ea75aeac369a031ed070e0695af0b85335bb605d9b8b3a8047de3d739ab08bfa8578
diff --git a/net-im/telegram-desktop-bin/telegram-desktop-bin-1.4.3.ebuild b/net-im/telegram-desktop-bin/telegram-desktop-bin-1.4.3.ebuild
new file mode 100644
index 000000000000..c709f83a6719
--- /dev/null
+++ b/net-im/telegram-desktop-bin/telegram-desktop-bin-1.4.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils xdg
+
+DESCRIPTION="Official desktop client for Telegram (binary package)"
+HOMEPAGE="https://desktop.telegram.org"
+SRC_URI="
+ https://github.com/telegramdesktop/tdesktop/archive/v${PV}.tar.gz -> tdesktop-${PV}.tar.gz
+ amd64? ( https://updates.tdesktop.com/tlinux/tsetup.${PV}.tar.xz )
+ x86? ( https://updates.tdesktop.com/tlinux32/tsetup32.${PV}.tar.xz )
+"
+
+LICENSE="telegram"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+QA_PREBUILT="usr/lib/${PN}/Telegram"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ >=sys-apps/dbus-1.4.20
+ x11-libs/libX11
+ >=x11-libs/libxcb-1.10[xkb]
+ >=media-libs/fontconfig-2.13
+"
+
+S="${WORKDIR}/Telegram"
+
+src_install() {
+ exeinto /usr/lib/${PN}
+ doexe "Telegram"
+ newbin "${FILESDIR}"/${PN}-r2 "telegram-desktop"
+
+ local icon_size
+ for icon_size in 16 32 48 64 128 256 512; do
+ newicon -s "${icon_size}" \
+ "${WORKDIR}/tdesktop-${PV}/Telegram/Resources/art/icon${icon_size}.png" \
+ telegram-desktop.png
+ done
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}/
+ doins ${FILESDIR}/fonts.conf
+
+ domenu "${WORKDIR}/tdesktop-${PV}"/lib/xdg/telegramdesktop.desktop
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ einfo
+ einfo "Previous versions of ${PN} have created "
+ einfo "\"~/.local/share/applications/telegram.desktop\". These files"
+ einfo "conflict with the one shipped by portage and should be removed"
+ einfo "from all homedirs. (https://bugs.gentoo.org/618662)"
+ einfo
+ einfo "This versions fixes fontconfig issues that have been reported"
+ einfo "by several users. However, the fix might have side-effects on"
+ einfo "non-latin fonts. If you have font issues with this version just"
+ einfo "delete \"/etc/${PN}/fonts.conf\" and leave a comment here"
+ einfo "https://bugs.gentoo.org/664872"
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}