summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-31 23:41:05 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-31 23:41:05 +0200
commit17f2a4b1ccf9d11226c2d96bacb14a4a611b2fac (patch)
tree20cd64b8a7d53dc6243f59ff05ba70fffd3cc914 /net-im
parentgames-emulation/pcsx2: Update live ebuild (diff)
downloadgentoo-17f2a4b1ccf9d11226c2d96bacb14a4a611b2fac.tar.gz
gentoo-17f2a4b1ccf9d11226c2d96bacb14a4a611b2fac.tar.bz2
gentoo-17f2a4b1ccf9d11226c2d96bacb14a4a611b2fac.zip
net-im/skypeforlinux: add 8.86.0.407
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.86.0.407.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 9743d4a4c379..127a2dbf443b 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -3,3 +3,4 @@ DIST skypeforlinux_8.82.0.403-1.x86_64.rpm 140817695 BLAKE2B 94a1038a534dce77e01
DIST skypeforlinux_8.83.0.408-1.x86_64.rpm 140847167 BLAKE2B 79d00a80bdb9cfa131094de2d702b1c8031307c6614ed962567cfeb3868bd542f5483b4ef87ab7146f9aa94e4548d9339ce7f4f28e65c2bfb5add25a3d3e5d26 SHA512 66865836f6e44ec54f14b26bdb0bcf2b9aec11379d4b16386814a44137e6eb1dd83cfbe2f4248cf6b2b4ba2513ebdcc64fec5f1819ee3a67e2ae04bcf4f7e028
DIST skypeforlinux_8.83.0.411-1.x86_64.rpm 140568859 BLAKE2B 3e429e5c60fe812092a2da1cd6ed4012d81e65a4f69c18772a7e34721c1549e18c401ea2fc6d0263bdbace85265c48467835e97f7fa50eca1ae8dbbbf4cf0b3c SHA512 ebab053e75e81e294e434aa7f573843017a97d749cdf9fdf1768ba35a8172e17b1c98f5cb68e7445ab19bd44c4b1d6b8defdcff6bcd24128b5fa176466f10752
DIST skypeforlinux_8.85.0.409-1.x86_64.rpm 125943432 BLAKE2B 7300c53c85387df71a7b1ccdd56a12a659a0e8ddbf8b274c32ac956e0bd67269815bc56e4d3a91cbc3f8214a3259026147ae3e8467efec934d06424495bf502d SHA512 2ee36ea93259390bb1061aae5ea86ac5617ac411f058b62607324fc36debbd7c914e872b9a2741ff72b37bc5e1b4683d862d3c01b84f9a3fe98de2e20959c911
+DIST skypeforlinux_8.86.0.407-1.x86_64.rpm 126036696 BLAKE2B e9fb9fb5c3612c1818d801c1ce43848ca2e313a7d09009678b6aeb1a649cd29c58a6e798fc22e48a6d23ceedd3a99b087110abc7b3d4cb8ba97cbe31d1f77c2e SHA512 8546a0bfc367e801b0f94d926dedf87dd2212888ea4d9206b1ed650c334ceebc1d72029a81c826dbf1630ec6625a6e08c7ae942e6dd79403027671996385435b
diff --git a/net-im/skypeforlinux/skypeforlinux-8.86.0.407.ebuild b/net-im/skypeforlinux/skypeforlinux-8.86.0.407.ebuild
new file mode 100644
index 000000000000..911974eaca88
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.86.0.407.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+S="${WORKDIR}"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ sys-libs/glibc
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}