summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.bugzilla.2012@r123.de>2019-02-11 11:11:02 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-02-11 23:54:50 +0100
commit53737e7f735e6a2a393f687141965a2d65851b8b (patch)
tree6c31fcf816064ca56c2d3321ac88a17e7c223f88 /net-im
parentmedia-libs/libffado: keyworded 2.4.1 for ppc, bug #677640 (diff)
downloadgentoo-53737e7f735e6a2a393f687141965a2d65851b8b.tar.gz
gentoo-53737e7f735e6a2a393f687141965a2d65851b8b.tar.bz2
gentoo-53737e7f735e6a2a393f687141965a2d65851b8b.zip
net-im/signal-desktop-bin: new version 1.21.1.
Signed-off-by: Robert Siebeck <gentoo.bugzilla.2012@r123.de> Closes: https://github.com/gentoo/gentoo/pull/11026 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/signal-desktop-bin/Manifest1
-rw-r--r--net-im/signal-desktop-bin/signal-desktop-bin-1.21.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-im/signal-desktop-bin/Manifest b/net-im/signal-desktop-bin/Manifest
index 1f653da63290..7d4c6aa6ed26 100644
--- a/net-im/signal-desktop-bin/Manifest
+++ b/net-im/signal-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST signal-desktop_1.21.0_amd64.deb 74766112 BLAKE2B 16f46a291a6e3ae43f75cc4f85cd47a8faea5c343b77ea7d8b12f7ef40c11abcefddffcbd5c27e6ae9ace6eb44055886150a6c668d3d89cd449c084f697251fa SHA512 7e20e8e511ee3d90ac809dd28c17b08898a7fd0a707bb2a2381ba558af4d8f9f52deb6127cf2dd2ad001714b339ac8e3b2fd1d40f179192f0c0b0aef8d4d2996
+DIST signal-desktop_1.21.1_amd64.deb 74759386 BLAKE2B 16f203ee54757822db8952fcfd4ccaffcbc421efea1bb81dbf05dabef6d91f9652ee3cfb02e6e501a214596c55fdcbbaad33ec21e0df7175777e9ab0b4e43065 SHA512 058d02aa5ce89edc3f5ae7c8b2bf10f2bda8449d4be2a69f802014cd80c847bd387e64259ccf3f50877a84a291e52765e788f11a20a5953d07aad3db365fd19b
diff --git a/net-im/signal-desktop-bin/signal-desktop-bin-1.21.1.ebuild b/net-im/signal-desktop-bin/signal-desktop-bin-1.21.1.ebuild
new file mode 100644
index 000000000000..e4a362f0ca50
--- /dev/null
+++ b/net-im/signal-desktop-bin/signal-desktop-bin-1.21.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+
+inherit gnome2-utils pax-utils unpacker xdg-utils
+
+DESCRIPTION="Allows you to send and receive messages of Signal Messenger on your computer"
+HOMEPAGE="https://signal.org/
+ https://github.com/WhisperSystems/Signal-Desktop"
+SRC_URI="https://updates.signal.org/desktop/apt/pool/main/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RDEPEND="
+ gnome-base/gconf:2
+ dev-libs/nss
+ x11-libs/gtk+:3[X]
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ net-print/cups
+ "
+
+QA_PREBUILT="opt/Signal/signal-desktop
+ opt/Signal/libnode.so
+ opt/Signal/libffmpeg.so"
+
+S="${WORKDIR}"
+
+src_prepare(){
+ default
+ sed -e 's|\("/opt/Signal/signal-desktop"\)|\1 --start-in-tray|g' \
+ -i usr/share/applications/signal-desktop.desktop || die
+ unpack usr/share/doc/signal-desktop/changelog.gz
+}
+
+src_install() {
+ insinto /
+ dodoc changelog
+ doins -r opt
+ insinto /usr/share
+ doins -r usr/share/applications
+ doins -r usr/share/icons
+ fperms +x /opt/Signal/signal-desktop
+ pax-mark m opt/Signal/signal-desktop
+
+ dosym ../../opt/Signal/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}