summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-06-17 17:50:45 +0300
committerMichał Górny <mgorny@gentoo.org>2018-06-17 23:30:36 +0200
commitaea1842e4bbb253c2fa0a689b2a6ed3e072b0225 (patch)
treedbbc95f1a90c761d4d54496ba56759645f57c5ca /net-im
parentdev-libs/libsavitar: use system pugixml (diff)
downloadgentoo-aea1842e4bbb253c2fa0a689b2a6ed3e072b0225.tar.gz
gentoo-aea1842e4bbb253c2fa0a689b2a6ed3e072b0225.tar.bz2
gentoo-aea1842e4bbb253c2fa0a689b2a6ed3e072b0225.zip
net-im/slack-bin: version bump to 3.2.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8875
Diffstat (limited to 'net-im')
-rw-r--r--net-im/slack-bin/Manifest1
-rw-r--r--net-im/slack-bin/slack-bin-3.2.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-im/slack-bin/Manifest b/net-im/slack-bin/Manifest
index c748794a470d..adec58ba7ce7 100644
--- a/net-im/slack-bin/Manifest
+++ b/net-im/slack-bin/Manifest
@@ -3,3 +3,4 @@ DIST slack-desktop-2.1.2-i386.deb 42997902 BLAKE2B e5b3375efbe00d31e34c900aedde4
DIST slack-desktop-3.1.0-amd64.deb 60324688 BLAKE2B bf9184ed49d31baa8b03d430091a965434ebdb13d0e85c4872fc5ee4101782b548c817388ef3f52b2c769dd23ed931c997d2b9efe56929dae8640918b4afca38 SHA512 8b7c93e54a24bdd3b83dcaef7dbef5fe2da62719a8c84d9c0c78236a077de30bf7ebc5c29e25228fd2306594abcf3733364f6075aa08ecce1de86cb0223986b0
DIST slack-desktop-3.1.1-amd64.deb 60320286 BLAKE2B 3054e8283b41d5b8b45323131b2a85800ba8b8e24e0b80aa0eff0c0152c7cad0a2914bf64a6b83621cf6c9ad52b9bf26c0d113cf5867d4c3f2e7d6129d4d27ae SHA512 06f209b07d1bbbadede592f4e63da7c53436ecc821585448269d4eda16ad0bdf8355ac46e508741150fae6dc883c90563509361f47dd02fda2f15b2829dda309
DIST slack-desktop-3.2.0-beta25a7a50e-amd64.deb 57959130 BLAKE2B b7c2b68a793022b069fc0b51621003e48c06c7f4b90d18fb3e2e8133d651ff058bed83e395dc4fc251da03c3fa17d52919c1f98c5317f7166b5b72a920e441be SHA512 d55b9a6f7383c7afc30df0e020863c42a03f8736c8a668064d8bcf016f6160e6c010a14042b76860a76edb7b793e565f88d15ae75e9d8f12cd532fece1aeac4a
+DIST slack-desktop-3.2.1-amd64.deb 57873452 BLAKE2B 6445aabf6512c218779e769a05069ff29292ef31dd9f4e109f1d0044f3db117db86b2dfb86d6ce00c36933c763c2e4d4874f27f4c7cdd8a10837cd1ffd1228f1 SHA512 ba08afefc8383cfc46198a64de1278a924a6e3552057484cdb8823fbbb38861f4b6b457be44ffb7913c968e5d5d6e88893636ebecdd0a0a979a2f3639220333e
diff --git a/net-im/slack-bin/slack-bin-3.2.1.ebuild b/net-im/slack-bin/slack-bin-3.2.1.ebuild
new file mode 100644
index 000000000000..9bc03e7bfad1
--- /dev/null
+++ b/net-im/slack-bin/slack-bin-3.2.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop gnome2-utils multilib-build pax-utils unpacker xdg-utils
+
+DESCRIPTION="Team collaboration tool"
+HOMEPAGE="http://www.slack.com/"
+SRC_URI="https://downloads.slack-edge.com/linux_releases/${MY_PN}-desktop-${PV}-amd64.deb"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 -*"
+IUSE="ayatana pax_kernel"
+RESTRICT="bindist mirror"
+
+RDEPEND="app-crypt/libsecret:0[${MULTILIB_USEDEP}]
+ dev-libs/atk:0[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ gnome-base/gconf:2[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ net-misc/curl:0[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libXi:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrender:0[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver:0[${MULTILIB_USEDEP}]
+ x11-libs/libXtst:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]
+ ayatana? ( dev-libs/libappindicator:3[${MULTILIB_USEDEP}] )"
+
+QA_PREBUILT="opt/slack/slack
+ opt/slack/resources/app.asar.unpacked/node_modules/*
+ opt/slack/libnode.so
+ opt/slack/libffmpeg.so
+ opt/slack/libCallsCore.so"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ if use ayatana ; then
+ sed -i '/Exec/s|=|=env XDG_CURRENT_DESKTOP=Unity |' \
+ usr/share/applications/slack.desktop \
+ || die "sed failed for slack.desktop"
+ fi
+}
+
+src_install() {
+ doicon usr/share/pixmaps/slack.png
+ doicon -s 512 usr/share/pixmaps/slack.png
+ domenu usr/share/applications/slack.desktop
+
+ insinto /opt/slack
+ doins -r usr/lib/slack/.
+ fperms +x /opt/slack/slack
+ dosym ../../opt/slack/slack usr/bin/slack
+
+ use pax_kernel && pax-mark -m "${ED%/}"/opt/slack/slack
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}