summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorNikos Chantziaras <realnc@gmail.com>2018-06-04 21:44:31 +0300
committerPatrice Clement <monsieurp@gentoo.org>2018-06-07 23:33:28 +0200
commitaf334d131185fd597c5509340dacfcf9d833a491 (patch)
treec908916e1cdc3174884453fcae4670efe9d8cee5 /net-im
parentdev-db/mysql-connector-c++: use HTTPs. (diff)
downloadgentoo-af334d131185fd597c5509340dacfcf9d833a491.tar.gz
gentoo-af334d131185fd597c5509340dacfcf9d833a491.tar.bz2
gentoo-af334d131185fd597c5509340dacfcf9d833a491.zip
net-im/skypeforlinux: version bump to 8.22.0.2.
Inherit desktop instead of eutils. Closes: https://bugs.gentoo.org/656334 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8723
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.22.0.2.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index f81580a21293..ee39fed4d037 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -3,3 +3,4 @@ DIST skypeforlinux_8.16.0.4-1.x86_64.rpm 105226365 BLAKE2B 377c4d646740c29efb10e
DIST skypeforlinux_8.17.0.2-1.x86_64.rpm 101588489 BLAKE2B 0a92756c403ae8a8b7f9aa4769cecc518988904d3b9cdc5e3cfc11518e2c369816df1c9e9c71e973cbef8200de3ca5be0ea18daa5e75432a0267f2dd09f9ce6c SHA512 121907e15b6b52d3ba35be7162ff0ba66b183d76fc929ca238a698d5035b625fcdf4efb93f2dbfd92fb18dc2aaf0b5bfbebac9fc96bd408478e4549d7e47454a
DIST skypeforlinux_8.18.0.6-1.x86_64.rpm 101968899 BLAKE2B 2aa2ed9d290f2f9307cb8db124b407b509a7b8f869805f25293df343978cc4911476a1734563325063bd1e3ef0e9044bc12d864edff838855af1f1b731dd4b39 SHA512 0917875b21b9d77f2299260ea2152b3c14c0b332343cb9832be2a613c875025b77ca782f60987f638d430d005d1bf78f1763fe82b7d91c3146c39e7fafbf1c11
DIST skypeforlinux_8.20.0.9-1.x86_64.rpm 115781688 BLAKE2B 24f197afeb034e0de6930af40508ada51dd3dc7a24d0a20bc05e65591bbdd8630d767bafcaf739cf70da5531f60ba52f8f51d53fb6f28e6974c4ca1be304585a SHA512 c39c672f03ac340ddd31641e80a780e2e5d624ba60aab3991f96611daedc93b1893fb44155b3895a84b21c04fa9498ba6dc158a40041b17ffc14f3b272eb72e3
+DIST skypeforlinux_8.22.0.2-1.x86_64.rpm 96073264 BLAKE2B d5d85ac5ba852ef50286894a4a3ff830e3763eb962f8e40cf4d2b9a9511394113991bd0de6cfe54fb8286c5bbe25ce516a640097f9240a947c7e70c97c7bcec9 SHA512 c628bcde1a467bf69e66bd8fc134bba18a2489d857659d386addb0659492bdc7884c29087411d5728074ae7f108f98be876b6330b1178e8ffe9792662bc9105f
diff --git a/net-im/skypeforlinux/skypeforlinux-8.22.0.2.ebuild b/net-im/skypeforlinux/skypeforlinux-8.22.0.2.ebuild
new file mode 100644
index 000000000000..b29bf79dd34f
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.22.0.2.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop gnome2-utils pax-utils rpm multilib-build xdg-utils
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 -*"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+# See bug 642054 about app-crypt/libsecret and MULTILIB_USEDEP.
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ gnome-base/gconf:2[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Exec=/usr/!Exec=${EPREFIX}/opt/!" \
+ -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+ into /opt
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${P} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ # compat symlink for the autostart desktop file
+ dosym ../../opt/bin/skypeforlinux usr/bin/skypeforlinux
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ if use pax_kernel; then
+ pax-mark -m "${ED%/}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED%/}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+ ewarn "You have set USE=pax_kernel meaning that you intend to run"
+ ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ ewarn "you suspect that ${PN} is being broken by this modification,"
+ ewarn "please open a bug."
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}