summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/hexchat/hexchat-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/hexchat/hexchat-9999.ebuild')
-rw-r--r--net-irc/hexchat/hexchat-9999.ebuild184
1 files changed, 184 insertions, 0 deletions
diff --git a/net-irc/hexchat/hexchat-9999.ebuild b/net-irc/hexchat/hexchat-9999.ebuild
new file mode 100644
index 000000000000..064761a60865
--- /dev/null
+++ b/net-irc/hexchat/hexchat-9999.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+inherit autotools eutils fdo-mime gnome2-utils mono-env multilib python-single-r1 git-2
+
+DESCRIPTION="Graphical IRC client based on XChat"
+HOMEPAGE="http://hexchat.github.io/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/hexchat/hexchat.git"
+
+LICENSE="GPL-2 plugin-fishlim? ( MIT )"
+SLOT="0"
+KEYWORDS=""
+IUSE="dbus +gtk ipv6 libcanberra libnotify libproxy nls ntlm perl +plugins plugin-checksum plugin-doat plugin-fishlim plugin-sysinfo python spell ssl theme-manager"
+REQUIRED_USE="plugins? ( python? ( ${PYTHON_REQUIRED_USE} ) )"
+
+DEPEND="dev-libs/glib:2
+ dbus? ( >=dev-libs/dbus-glib-0.98 )
+ gtk? ( x11-libs/gtk+:2 )
+ libcanberra? ( media-libs/libcanberra )
+ libproxy? ( net-libs/libproxy )
+ libnotify? ( x11-libs/libnotify )
+ nls? ( virtual/libintl )
+ ntlm? ( net-libs/libntlm )
+ plugins? (
+ perl? ( >=dev-lang/perl-5.8.0 )
+ plugin-sysinfo? ( sys-apps/pciutils )
+ python? ( ${PYTHON_DEPS} )
+ )
+ spell? ( app-text/iso-codes )
+ ssl? ( dev-libs/openssl:0 )
+ theme-manager? ( dev-lang/mono )"
+RDEPEND="${DEPEND}
+ spell? ( app-text/enchant )"
+DEPEND="${DEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )
+ theme-manager? ( dev-util/monodevelop )"
+
+pkg_setup() {
+ use plugins && use python && python-single-r1_pkg_setup
+ if use theme-manager ; then
+ mono-env_pkg_setup
+ export XDG_CACHE_HOME="${T}/.cache"
+ fi
+
+ if use !plugins ; then
+ local myplugins
+
+ use perl && myplugins+="perl\n"
+ use python && myplugins+="python\n"
+ use plugin-checksum && myplugins+="plugin-checksum\n"
+ use plugin-doat && myplugins+="plugin-doat\n"
+ use plugin-fishlim && myplugins+="plugin-fishlim\n"
+ use plugin-sysinfo && myplugins+="plugin-sysinfo\n"
+
+ if [[ ${myplugins} ]] ; then
+ ewarn "The following plugins/interfaces have been disabled, because"
+ ewarn "\"plugins\" USE flag is disabled. Check metadata.xml"
+ ewarn "to get more information or run \"equery u hexchat\"."
+ ewarn "\n${myplugins}"
+ fi
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "/intl\/Makefile/d" \
+ -e "/po\/Makefile.in/d" \
+ configure.ac || die
+ sed -i -e "/SUBDIRS/s/intl//" Makefile.am || die
+ epatch -p1 \
+ "${FILESDIR}"/${PN}-2.9.5-autoconf-missing-macros.patch
+ epatch_user
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ einfo "Running gettextize -f --no-changelog..."
+ "${T}"/gettextize -f --no-changelog > /dev/null || die "gettexize failed"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable libproxy socks) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ $(use_enable gtk gtkfe) \
+ $(use_enable !gtk textfe) \
+ $(usex plugins \
+ "$(usex python "--enable-python=${EPYTHON}" "--disable-python")" \
+ "--disable-python" \
+ ) \
+ $(usex plugins \
+ "$(use_enable perl)" \
+ "--disable-perl" \
+ ) \
+ $(use_enable plugins plugin) \
+ $(usex plugins \
+ "$(use_enable plugin-checksum checksum)" \
+ "--disable-checksum" \
+ ) \
+ $(usex plugins \
+ "$(use_enable plugin-doat doat)" \
+ "--disable-doat" \
+ ) \
+ $(usex plugins \
+ "$(use_enable plugin-fishlim fishlim)" \
+ "--disable-fishlim" \
+ ) \
+ $(usex plugins \
+ "$(use_enable plugin-sysinfo sysinfo)" \
+ "--disable-sysinfo" \
+ ) \
+ $(use_enable dbus) \
+ $(use_enable libnotify) \
+ $(use_enable libcanberra) \
+ $(use_enable ntlm) \
+ $(use_enable libproxy) \
+ $(use_enable spell isocodes) \
+ --enable-minimal-flags \
+ $(use_with theme-manager)
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ UPDATE_ICON_CACHE=true \
+ UPDATE_MIME_DATABASE=true \
+ UPDATE_DESKTOP_DATABASE=true \
+ install
+ dodoc readme.md
+ prune_libtool_files --all
+}
+
+pkg_preinst() {
+ if use gtk ; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ gnome2_icon_cache_update
+ einfo
+ else
+ einfo
+ elog "You have disabled the gtk USE flag. This means you don't have"
+ elog "the GTK-GUI for HexChat but only a text interface called \"hexchat-text\"."
+ elog
+ fi
+
+ if use theme-manager ; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ elog "Themes are available at:"
+ elog " http://hexchat.org/themes.html"
+ elog
+ fi
+
+ einfo
+ elog "optional dependencies:"
+ elog " media-sound/sox (sound playback if you don't have libcanberra"
+ elog " enabled)"
+ elog " x11-plugins/hexchat-javascript (javascript support)"
+ elog " x11-themes/sound-theme-freedesktop (default BEEP sound,"
+ elog " needs libcanberra enabled)"
+ einfo
+}
+
+pkg_postrm() {
+ if use gtk ; then
+ gnome2_icon_cache_update
+ fi
+
+ if use theme-manager ; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ fi
+}