summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/iip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/iip')
-rw-r--r--net-irc/iip/Manifest1
-rw-r--r--net-irc/iip/files/iip_open_mode.patch11
-rw-r--r--net-irc/iip/iip-1.2.ebuild41
-rw-r--r--net-irc/iip/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/net-irc/iip/Manifest b/net-irc/iip/Manifest
new file mode 100644
index 000000000000..0522a21f7bdb
--- /dev/null
+++ b/net-irc/iip/Manifest
@@ -0,0 +1 @@
+DIST iip-1.2-dev1.tar.bz2 299053 SHA256 8f4bfce32e43a75e71c78d49eecaee9efe3f6b8782878276d590e736566a9fbf SHA512 384026ba6b0d797574fad9295ac7d042a20556fb428663f8043768e9daf2adc831cd89b81c48abc4473e68f3f0d84d7d854be1816f8a82628f397839e19a8992 WHIRLPOOL f4fb55c175ed9ff8a61bccbb31fc4f1996128e95c1156797f49e2d0e846cb08cb3517bb33dabed4b2870de92754f4af3fe39b0b173bfe98a7d6290d8043907a0
diff --git a/net-irc/iip/files/iip_open_mode.patch b/net-irc/iip/files/iip_open_mode.patch
new file mode 100644
index 000000000000..6d3aec1af5ab
--- /dev/null
+++ b/net-irc/iip/files/iip_open_mode.patch
@@ -0,0 +1,11 @@
+--- src/misc/unix.c 2002-10-29 07:56:29.000000000 +0000
++++ src/misc/unix.c 2009-03-05 13:12:54.000000000 +0000
+@@ -100,7 +100,7 @@
+ s = stringCopyMany(lockfilepath, lockfileprefix, NULL);
+ s = stringJoinMany(s, intToString((int) getpid()), NULL);
+
+- fd = open(s, O_CREAT | O_EXCL | S_IWUSR);
++ fd = open(s, O_CREAT | O_EXCL ,S_IWUSR | S_IRUSR);
+ if(fd == -1) {
+ LOGERROR(stringCopyMany("unixAddLockFile: open lock file failed (", s, ")",
+ _("Error opening lockfile."), NULL))
diff --git a/net-irc/iip/iip-1.2.ebuild b/net-irc/iip/iip-1.2.ebuild
new file mode 100644
index 000000000000..9045af9099ef
--- /dev/null
+++ b/net-irc/iip/iip-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+MY_P="${P}-dev1"
+
+DESCRIPTION="Proxy server for encrypted anonymous IRC-like network"
+HOMEPAGE="http://www.invisiblenet.net/iip/"
+SRC_URI="mirror://sourceforge/invisibleip/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/iip_open_mode.patch"
+}
+
+src_compile() {
+ sed -i \
+ -e "s:-Werror::" "${S}"/src/Makefile || \
+ die "sed Makefile failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README
+}
diff --git a/net-irc/iip/metadata.xml b/net-irc/iip/metadata.xml
new file mode 100644
index 000000000000..7e25b929ec9c
--- /dev/null
+++ b/net-irc/iip/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <upstream>
+ <remote-id type="sourceforge">invisibleip</remote-id>
+ </upstream>
+</pkgmetadata>