summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-08-16 00:02:48 +1200
committerKent Fredric <kentnl@gentoo.org>2019-08-16 00:04:25 +1200
commit27eac7b8fc3da678ed259599e7bdd4ad2d3180a9 (patch)
tree0a8107ba07aa1801b340ca2168eb4384e9a49385 /net-irc/ircmap
parentx11-libs/pango: fix CVE-2019-1010238 (diff)
downloadgentoo-27eac7b8fc3da678ed259599e7bdd4ad2d3180a9.tar.gz
gentoo-27eac7b8fc3da678ed259599e7bdd4ad2d3180a9.tar.bz2
gentoo-27eac7b8fc3da678ed259599e7bdd4ad2d3180a9.zip
net-irc/ircmap: Fix swathe of QA issues
- Using the perl privlib trick was both wrong, and unneeded, as the modules in question are inherently 'private to this package' and are not intended for general use by other tools on CPAN. - Subsequently, this changes to stashing them in /usr/share/ircmap - Upstreams homepage has moved - Upstreams existing SRC_URI's were unresolvable - Added conversion of upstreams tarball from "ircmap.tar.gz" to "ircmap-0.99.tar.gz". Upstream don't actually version their releases properly it seems, but its been so long since a release its hard to imagine there will be more. - Convert to EAPI7, though its probably incomplete and this probably needs some EPREFIX/DEPEND/BDEPEND/BROOT love, but eh. - Keyworded ~amd64 as it mostly appears to work for me, but no way to test functionality. - --straight-to-stable'd simply because these are all QA fixups, and no point waiting a month to silence the warnings. Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'net-irc/ircmap')
-rw-r--r--net-irc/ircmap/Manifest2
-rw-r--r--net-irc/ircmap/ircmap-0.99-r1.ebuild (renamed from net-irc/ircmap/ircmap-0.99.ebuild)31
2 files changed, 16 insertions, 17 deletions
diff --git a/net-irc/ircmap/Manifest b/net-irc/ircmap/Manifest
index 8828fb2f5f05..5e01b1327f8b 100644
--- a/net-irc/ircmap/Manifest
+++ b/net-irc/ircmap/Manifest
@@ -1 +1 @@
-DIST ircmap.tar.gz 27944 BLAKE2B 8f8d04c64e250383d36c88e3c0d1f76ef961081a526b60e624da74f9cbac2fe04e9bc680e750703240c75a794ecfbd4f5e9b387b04db3752c172d3c704156421 SHA512 52ce62d7846e5e50525800af86b4296d427da21d129f68b83cd30daa75fdd9fe78c6615771e729c4ad5f8afe75f20b1cab0b6d4b01be4a7c2889524676b60ac9
+DIST ircmap-0.99.tar.gz 27944 BLAKE2B 8f8d04c64e250383d36c88e3c0d1f76ef961081a526b60e624da74f9cbac2fe04e9bc680e750703240c75a794ecfbd4f5e9b387b04db3752c172d3c704156421 SHA512 52ce62d7846e5e50525800af86b4296d427da21d129f68b83cd30daa75fdd9fe78c6615771e729c4ad5f8afe75f20b1cab0b6d4b01be4a7c2889524676b60ac9
diff --git a/net-irc/ircmap/ircmap-0.99.ebuild b/net-irc/ircmap/ircmap-0.99-r1.ebuild
index 61a38d5469ed..05d3f133fb3d 100644
--- a/net-irc/ircmap/ircmap-0.99.ebuild
+++ b/net-irc/ircmap/ircmap-0.99-r1.ebuild
@@ -1,29 +1,30 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
DESCRIPTION="Scripts to treate diagrams of IRC networks using the LINKS command"
-HOMEPAGE="http://pasky.or.cz/~pasky/irc/"
-SRC_URI="http://pasky.ji.cz/~pasky/irc/${PN}.tar.gz"
+HOMEPAGE="http://pasky.or.cz/irc/"
+SRC_URI="http://pasky.or.cz/irc/${PN}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
IUSE=""
-DEPEND="dev-lang/perl"
-RDEPEND="${RDEPEND}
- media-gfx/graphviz"
-DEPEND="${DEPEND}
- >=sys-apps/sed-4"
+RDEPEND="
+ media-gfx/graphviz
+ dev-lang/perl
+"
+BDEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+"
+DEPEND=""
S="${WORKDIR}"/${PN}
src_compile() {
- eval $(perl -V:installprivlib)
-
sed -i \
- -e "s:/home/pasky/ircmap:${installprivlib}/ircmap:" \
+ -e "s:/home/pasky/ircmap:/usr/share/ircmap:" \
{ircmapC,ircmapR-aa,ircmapR-gvdot,ircmapR-ircnet,ircmapS}.pl
}
@@ -31,9 +32,7 @@ src_install () {
dodoc README
dobin ircmapS.pl ircmapC.pl ircmapR-aa.pl ircmapR-gvdot.pl ircmapR-ircnet.pl
- eval $(perl -V:installprivlib)
-
- insinto /"${installprivlib}"/ircmap
+ insinto /usr/share/ircmap
doins IHash.pm
}