summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/irker/irker-2.12.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/irker/irker-2.12.ebuild')
-rw-r--r--net-irc/irker/irker-2.12.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-irc/irker/irker-2.12.ebuild b/net-irc/irker/irker-2.12.ebuild
new file mode 100644
index 000000000000..6dd3a2b12f2f
--- /dev/null
+++ b/net-irc/irker/irker-2.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ssl"
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="Submission tools for IRC notifications"
+HOMEPAGE="http://www.catb.org/esr/irker/"
+SRC_URI="http://www.catb.org/esr/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto"
+
+src_prepare() {
+ # https://gitorious.org/irker/irker/merge_requests/25
+ epatch "${FILESDIR}/2.7-Register-author_name-as-author-instead-of-email-user.patch"
+
+ epatch "${FILESDIR}/2.7-irkerhook-Remove-file-listing.patch"
+
+ # Prefix support
+ sed -i -e "/^ExecStart=/ s:=/:=${EROOT}:" irkerd.service
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ python_doscript "${ED}/usr/bin/irkerd"
+ # Not installed with the default Makefile
+ python_doscript irk irkerhook.py
+
+ newinitd "${FILESDIR}/irkerd.initd" irkerd
+ newconfd "${FILESDIR}/irkerd.confd" irkerd
+
+ dodoc NEWS README hacking.txt security.txt
+ dohtml irkerd.html irkerhook.html
+
+ docinto examples
+ dodoc filter-example.py filter-test.py
+}