summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-08-15 19:15:07 +0000
committerMike Gilbert <floppym@gentoo.org>2019-08-16 13:02:29 -0400
commit33d72cab6898eaeb782fe60eb1e1b8f794a655a5 (patch)
treed6ecdc0371af6b1d1ef4b90fdc84a7f4be100d74 /net-irc/kvirc
parentnet-irc/kvirc: Add dev-lang/perl to BDEPEND. Cleanup. (diff)
downloadgentoo-33d72cab6898eaeb782fe60eb1e1b8f794a655a5.tar.gz
gentoo-33d72cab6898eaeb782fe60eb1e1b8f794a655a5.tar.bz2
gentoo-33d72cab6898eaeb782fe60eb1e1b8f794a655a5.zip
net-irc/kvirc: Install API documentation with USE="doc".
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'net-irc/kvirc')
-rw-r--r--net-irc/kvirc/kvirc-5.2_pre20190628041642.ebuild20
-rw-r--r--net-irc/kvirc/kvirc-9999.ebuild20
2 files changed, 40 insertions, 0 deletions
diff --git a/net-irc/kvirc/kvirc-5.2_pre20190628041642.ebuild b/net-irc/kvirc/kvirc-5.2_pre20190628041642.ebuild
index 2fb31df8c0fc..9b9efe89389c 100644
--- a/net-irc/kvirc/kvirc-5.2_pre20190628041642.ebuild
+++ b/net-irc/kvirc/kvirc-5.2_pre20190628041642.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+CMAKE_MAKEFILE_GENERATOR="emake"
PYTHON_COMPAT=(python2_7)
inherit cmake-utils flag-o-matic python-single-r1 xdg-utils
@@ -139,6 +140,25 @@ src_configure() {
cmake-utils_src_configure
}
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ cmake-utils_src_compile devdocs
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ (
+ docinto html
+ dodoc -r "${BUILD_DIR}/doc/api/html/"*
+ )
+ fi
+}
+
pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update
diff --git a/net-irc/kvirc/kvirc-9999.ebuild b/net-irc/kvirc/kvirc-9999.ebuild
index 5c2798753705..3e4e206a18d6 100644
--- a/net-irc/kvirc/kvirc-9999.ebuild
+++ b/net-irc/kvirc/kvirc-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+CMAKE_MAKEFILE_GENERATOR="emake"
PYTHON_COMPAT=(python2_7)
inherit cmake-utils flag-o-matic python-single-r1 xdg-utils
@@ -139,6 +140,25 @@ src_configure() {
cmake-utils_src_configure
}
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ cmake-utils_src_compile devdocs
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ (
+ docinto html
+ dodoc -r "${BUILD_DIR}/doc/api/html/"*
+ )
+ fi
+}
+
pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update