summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-23 11:14:59 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-23 11:14:59 +0200
commit6c5b68d969384203ada3950d83766a9b85480514 (patch)
tree0f5a58f90ac49e98546a1054514a3feb1264e799 /net-irc/muh
parentnet-libs/libident: EAPI 6 bump (diff)
downloadgentoo-6c5b68d969384203ada3950d83766a9b85480514.tar.gz
gentoo-6c5b68d969384203ada3950d83766a9b85480514.tar.bz2
gentoo-6c5b68d969384203ada3950d83766a9b85480514.zip
net-irc/muh: EAPI 6 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'net-irc/muh')
-rw-r--r--net-irc/muh/muh-2.2a-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/muh/muh-2.2a-r1.ebuild b/net-irc/muh/muh-2.2a-r1.ebuild
new file mode 100644
index 000000000000..c5c9dc85ad91
--- /dev/null
+++ b/net-irc/muh/muh-2.2a-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Persistent IRC bouncer"
+HOMEPAGE="http://mind.riot.org/muh/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="ipv6"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --datadir=/usr/share/muh $(use_enable ipv6)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "You'll need to configure muh before running it."
+ elog "Put your config in ~/.muh/muhrc"
+ elog "A sample config is /usr/share/muh/muhrc"
+ elog "For more information, see the documentation."
+ elog
+}