summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/ninja
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/ninja')
-rw-r--r--net-irc/ninja/Manifest1
-rw-r--r--net-irc/ninja/metadata.xml5
-rw-r--r--net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild32
-rw-r--r--net-irc/ninja/ninja-1.5.9_pre14.ebuild31
4 files changed, 69 insertions, 0 deletions
diff --git a/net-irc/ninja/Manifest b/net-irc/ninja/Manifest
new file mode 100644
index 000000000000..00bd3f526c60
--- /dev/null
+++ b/net-irc/ninja/Manifest
@@ -0,0 +1 @@
+DIST ninja-1.5.9pre14.tar.gz 920668 SHA256 151422413acf67a6d695346fa21d8b9ce8901ee31d0e6ac07d997d5793ff3c38 SHA512 5a379ed355c06d28f26ed7b97e657b463deec0832ebf822424ed92379e85066e8aca971943ad751e695c003a6ef1ab7fa46ff29e5febe30c439cdfdf6b4d6cfb WHIRLPOOL a735179313f785b8ffeb3b89f67e8af28f069feecb95dd45785234642372d7c16f89c5455d9a82196fe22e7e344c5f64f0d0058e404c117d0d746674e94eb006
diff --git a/net-irc/ninja/metadata.xml b/net-irc/ninja/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/ninja/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>
diff --git a/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild b/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild
new file mode 100644
index 000000000000..be9de0a91db5
--- /dev/null
+++ b/net-irc/ninja/ninja-1.5.9_pre14-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+S=${WORKDIR}/${P/_*/}
+
+DESCRIPTION="Ninja IRC Client"
+HOMEPAGE="http://ninja.qoop.org/"
+SRC_URI="ftp://qoop.org/ninja/stable/${P/_/}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ncurses ipv6 ssl"
+
+RESTRICT="test"
+
+DEPEND="ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_configure() {
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/bin/ninja{,_irc} || die #436804
+}
diff --git a/net-irc/ninja/ninja-1.5.9_pre14.ebuild b/net-irc/ninja/ninja-1.5.9_pre14.ebuild
new file mode 100644
index 000000000000..343fd9983d05
--- /dev/null
+++ b/net-irc/ninja/ninja-1.5.9_pre14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+S=${WORKDIR}/${P/_*/}
+
+DESCRIPTION="Ninja IRC Client"
+HOMEPAGE="http://ninja.qoop.org/"
+SRC_URI="ftp://qoop.org/ninja/stable/${P/_/}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ~ppc64 ~sparc x86"
+IUSE="ncurses ipv6 ssl"
+
+RESTRICT="test"
+
+DEPEND="ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )
+ !dev-util/ninja" #436804
+RDEPEND="${DEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_compile() {
+ econf $(use_enable ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}