summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-06-06 21:03:47 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-06-06 21:04:48 -0700
commit4760387a1d2ac78c7e77aed300b8c439f2bd8365 (patch)
treefccd758e87cdbd8528d216058fb47c9a7a29a12c /net-irc/weechat
parentnet-irc/weechat: bump to 2.5 (diff)
downloadgentoo-4760387a1d2ac78c7e77aed300b8c439f2bd8365.tar.gz
gentoo-4760387a1d2ac78c7e77aed300b8c439f2bd8365.tar.bz2
gentoo-4760387a1d2ac78c7e77aed300b8c439f2bd8365.zip
net-irc/weechat: sync live ebuild
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-irc/weechat')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index 87138663a67a..bebadfe887e0 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -22,10 +22,10 @@ LICENSE="GPL-3"
SLOT="0"
NETWORKS="+irc"
-PLUGINS="+alias +buflist +charset +exec +fset +fifo +logger +relay +scripts +spell +trigger +xfer"
+PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spell +trigger +xfer"
# dev-lang/v8 was dropped from Gentoo so we can't enable javascript support
SCRIPT_LANGS="guile lua +perl php +python ruby tcl"
-LANGS=" cs de es fr hu it ja pl pt pt_BR ru tr"
+LANGS=" cs de es fr it ja pl ru"
IUSE="doc man nls +ssl test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -41,16 +41,19 @@ RDEPEND="
perl? ( dev-lang/perl:= )
php? ( >=dev-lang/php-7.0:* )
python? ( ${PYTHON_DEPS} )
- ruby? ( || ( dev-lang/ruby:2.6 dev-lang/ruby:2.5 dev-lang/ruby:2.4 dev-lang/ruby:2.3 ) )
+ ruby? ( || ( dev-lang/ruby:2.6 dev-lang/ruby:2.5 dev-lang/ruby:2.4 ) )
ssl? ( net-libs/gnutls )
spell? ( app-text/aspell )
tcl? ( >=dev-lang/tcl-8.4.15:0= )
"
DEPEND="${RDEPEND}
+ test? ( dev-util/cpputest )
+"
+
+BDEPEND="
doc? ( >=dev-ruby/asciidoctor-1.5.4 )
man? ( >=dev-ruby/asciidoctor-1.5.4 )
nls? ( >=sys-devel/gettext-0.15 )
- test? ( dev-util/cpputest )
"
DOCS="AUTHORS.adoc ChangeLog.adoc Contributing.adoc ReleaseNotes.adoc README.adoc"
@@ -65,12 +68,6 @@ pkg_setup() {
src_prepare() {
cmake-utils_src_prepare
- # fix libdir placement
- sed -i \
- -e "s:lib/:$(get_libdir)/:g" \
- -e "s:lib\":$(get_libdir)\":g" \
- CMakeLists.txt || die "sed failed"
-
# install only required translations
local i
for i in ${LANGS} ; do
@@ -106,11 +103,11 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
+ -DLIBDIR=$(get_libdir)
-DENABLE_JAVASCRIPT=OFF
-DENABLE_LARGEFILE=ON
-DENABLE_NCURSES=ON
-DENABLE_ALIAS=$(usex alias)
- -DENABLE_ASPELL=$(usex spell)
-DENABLE_BUFLIST=$(usex buflist)
-DENABLE_CHARSET=$(usex charset)
-DENABLE_DOC=$(usex doc)
@@ -131,6 +128,7 @@ src_configure() {
-DENABLE_RUBY=$(usex ruby)
-DENABLE_SCRIPT=$(usex scripts)
-DENABLE_SCRIPTS=$(usex scripts)
+ -DENABLE_SPELL=$(usex spell)
-DENABLE_TCL=$(usex tcl)
-DENABLE_TESTS=$(usex test)
-DENABLE_TRIGGER=$(usex trigger)