summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/xaric
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/xaric')
-rw-r--r--net-irc/xaric/Manifest1
-rw-r--r--net-irc/xaric/files/xaric-0.13.6-tinfo.patch16
-rw-r--r--net-irc/xaric/metadata.xml5
-rw-r--r--net-irc/xaric/xaric-0.13.6.ebuild30
4 files changed, 52 insertions, 0 deletions
diff --git a/net-irc/xaric/Manifest b/net-irc/xaric/Manifest
new file mode 100644
index 000000000000..a0822343a62d
--- /dev/null
+++ b/net-irc/xaric/Manifest
@@ -0,0 +1 @@
+DIST xaric-0.13.6.tar.gz 479754 SHA256 dbed41ed43efcea05baac0af0fe87cca36eebd96e5b7d4838b38cca3da4518bb SHA512 1c52e30cfab49d82306cd0b4402175f68cfc411b7ef04156b2361fadeea01648476742015306a0c242c13f4ab29916e8ac48a59f481ecdb5475584ef6cdf028f WHIRLPOOL b76afdbaa6e0352af8bc6a9fc76fced02f9a8c6210b1e6092a3b31a160ca3bd3095bcc959837c1a0c7142d73a5c03d32a743626f638f7f4110b53028968efba9
diff --git a/net-irc/xaric/files/xaric-0.13.6-tinfo.patch b/net-irc/xaric/files/xaric-0.13.6-tinfo.patch
new file mode 100644
index 000000000000..0fcfe3aa1846
--- /dev/null
+++ b/net-irc/xaric/files/xaric-0.13.6-tinfo.patch
@@ -0,0 +1,16 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -279,9 +279,10 @@
+ olibs="$LIBS"
+ AC_CHECK_LIB(termcap, tgetent, LIBS="-ltermcap $olibs",
+ AC_CHECK_LIB(termlib, tgetent, LIBS="-ltermlib $olibs",
+- AC_CHECK_LIB(curses, tgetent, LIBS="-lcurses $olibs",
+- AC_CHECK_LIB(xtermcap, tgetent, LIBS="-lxtermcap $olibs",
+- AC_MSG_ERROR([i can not find tgetent. you need to help me])))))
++ AC_CHECK_LIB(tinfo, tgetent, LIBS="-ltinfo $olibs",
++ AC_CHECK_LIB(curses, tgetent, LIBS="-lcurses $olibs",
++ AC_CHECK_LIB(xtermcap, tgetent, LIBS="-lxtermcap $olibs",
++ AC_MSG_ERROR([i can not find tgetent. you need to help me]))))))
+ fi
+
+ dnl ----------------------------------------------------------
diff --git a/net-irc/xaric/metadata.xml b/net-irc/xaric/metadata.xml
new file mode 100644
index 000000000000..c519652bdf0d
--- /dev/null
+++ b/net-irc/xaric/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+</pkgmetadata>
diff --git a/net-irc/xaric/xaric-0.13.6.ebuild b/net-irc/xaric/xaric-0.13.6.ebuild
new file mode 100644
index 000000000000..b96111e2ec22
--- /dev/null
+++ b/net-irc/xaric/xaric-0.13.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="An IRC client similar to ircII, BitchX, or ircII EPIC"
+HOMEPAGE="http://xaric.org/"
+SRC_URI="http://xaric.org/software/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon xaric.xpm
+}