summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-30 05:00:20 +0000
committerSam James <sam@gentoo.org>2020-08-30 05:00:20 +0000
commit061e99afd0b86219d38a9464e4c786408076b657 (patch)
tree38f3be187551b7ef2cdc447b30fec0eced6c7913 /net-irc
parentnet-irc/ircstats: respect CFLAGS, CC (diff)
downloadgentoo-061e99afd0b86219d38a9464e4c786408076b657.tar.gz
gentoo-061e99afd0b86219d38a9464e4c786408076b657.tar.bz2
gentoo-061e99afd0b86219d38a9464e4c786408076b657.zip
net-irc/dccserver: respect AR
Closes: https://bugs.gentoo.org/724956 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/dccserver/dccserver-0.5-r1.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/net-irc/dccserver/dccserver-0.5-r1.ebuild b/net-irc/dccserver/dccserver-0.5-r1.ebuild
index 2576bf19e353..995df89457bf 100644
--- a/net-irc/dccserver/dccserver-0.5-r1.ebuild
+++ b/net-irc/dccserver/dccserver-0.5-r1.ebuild
@@ -1,15 +1,25 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="linux implementation of the mirc dccserver command"
HOMEPAGE="https://www.nih.at/dccserver/"
SRC_URI="https://www.nih.at/dccserver/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND=""
-RDEPEND=""
+src_prepare() {
+ default
+
+ # Respect AR
+ sed -i -e "s/AR = /AR ?= /" lib/Makefile.in || die
+}
+
+src_compile() {
+ AR="$(tc-getAR)" default
+}