summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2023-01-08 20:08:53 -0800
committerViorel Munteanu <ceamac@gentoo.org>2023-01-16 12:24:59 +0200
commit8c2c86e8670deb9fc51ce769e624d921cab35fe7 (patch)
tree3f1388c4fb0c44657bfffa192dd67a1cbe6ad6c2 /net-irc
parentwww-servers/apache: drop 2.4.54-r2 (diff)
downloadgentoo-8c2c86e8670deb9fc51ce769e624d921cab35fe7.tar.gz
gentoo-8c2c86e8670deb9fc51ce769e624d921cab35fe7.tar.bz2
gentoo-8c2c86e8670deb9fc51ce769e624d921cab35fe7.zip
net-irc/inspircd: add 3.15.0
Signed-off-by: Wade Cline <wadecline@hotmail.com> Closes: https://github.com/gentoo/gentoo/pull/29028 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/inspircd/Manifest2
-rw-r--r--net-irc/inspircd/inspircd-3.15.0.ebuild113
-rw-r--r--net-irc/inspircd/metadata.xml2
3 files changed, 117 insertions, 0 deletions
diff --git a/net-irc/inspircd/Manifest b/net-irc/inspircd/Manifest
index 59eb8ce6d90f..d4c6efe23b9e 100644
--- a/net-irc/inspircd/Manifest
+++ b/net-irc/inspircd/Manifest
@@ -4,3 +4,5 @@ DIST inspircd-3.13.0-fix-template-files.patch.bz2 785 BLAKE2B ee559a1e92c7ff1b98
DIST inspircd-3.13.0.tar.gz 868027 BLAKE2B 9d31917d076329d255f3b29a394a1329f286d3178573063e5af48148c14ba8a4c6b78e90251ec9d8df9dc10726435dd4aff381c65d81c902034ea527aabac51f SHA512 1466e6b4259ea0f1e62342133a6720839e01eea24f67398ab47f9d5d63703cb934b867c705f07c8e0d3a0fa25c20f9b20ce3f5dbc7bbe7c4f2d5d02b7a170cca
DIST inspircd-3.14.0-fix-build-paths.patch.bz2 4731 BLAKE2B 5d8bdfc2af5ff4e9f0e592cb23dd747f9bcfcaad63a725d03fc78b2b032bc4df59a21dfca2067b3e50c1dcf18257706fb30862a1db919e109b8954aa06712efe SHA512 bfd5bdf58fa0ce8e91da1d74aada01f7cafd33b911f5445fd379728f5e67c8b10cf68cdc74dc0cf3d6bdab87ee9cb2251a52e3ed165970381b19a487ee11b554
DIST inspircd-3.14.0.tar.gz 869137 BLAKE2B d02d98c6922093e2e04a8f68092a8591ca4b7e5b079676ddc9b33c315725ac4c6739528c3285820683f0daba9926c4be8577e643b4a6cc28d9d3f39151d7da82 SHA512 c19afc20b779a029b9e7a88470806d4a8e45d1fa3e9fd8597c02811d5669e6812c33dc3086557f1cb28335a778c50b78efd863357f500780dbadc61c02c2253c
+DIST inspircd-3.15.0-fix-build-paths.patch.bz2 4733 BLAKE2B 72bc94f8feb5620ce8bd735dd84a5805b086855af39ca204b2159c41f951fd8285e01aca69f9ef1c1b546060eb46a5b6a42c66e8831ab9289663429a8b0371fc SHA512 8d021f04b861d5b3a7bfd19f8b49e34498f1bdda02fda967d78b35af8329819a37a446db42c8c1f7c8543b3fa533dcff214b92b5393cd380a1d47fd32cdf0679
+DIST inspircd-3.15.0.tar.gz 874629 BLAKE2B 50dd2cdba497e85da6d72c22f612cae5944f2a654783d6edc673e956a33132c539ab71bc7ab9647468bd96cc3e2c73031a300e39df0753886af8ac532d07b696 SHA512 32d10cd7f6a06c79720c138fc4aff3c8db667754c7a2fe3ad7c07a1e56604bedcf17e3dd5d5f54a6fd49b37414acd57b97afc1d4accbf3e5fbd92b483fe6c394
diff --git a/net-irc/inspircd/inspircd-3.15.0.ebuild b/net-irc/inspircd/inspircd-3.15.0.ebuild
new file mode 100644
index 000000000000..7df864d182dd
--- /dev/null
+++ b/net-irc/inspircd/inspircd-3.15.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Inspire IRCd - The Stable, High-Performance Modular IRCd"
+HOMEPAGE="https://www.inspircd.org/"
+SRC_URI="
+ https://github.com/inspircd/inspircd/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/clinew/gentoo-distfiles/raw/master/inspircd-${PV}-fix-build-paths.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="argon2 debug gnutls ldap maxminddb mbedtls mysql pcre pcre2 postgres re2 regex-posix regex-stdlib sqlite ssl sslrehashsignal tre"
+
+RDEPEND="
+ acct-group/inspircd
+ acct-user/inspircd
+ dev-lang/perl
+ argon2? ( app-crypt/argon2 )
+ gnutls? ( net-libs/gnutls:= dev-libs/libgcrypt:0 )
+ ldap? ( net-nds/openldap:= )
+ maxminddb? ( dev-libs/libmaxminddb:= )
+ mbedtls? ( net-libs/mbedtls:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ pcre? ( dev-libs/libpcre )
+ pcre2? ( dev-libs/libpcre2 )
+ postgres? ( dev-db/postgresql:= )
+ re2? ( dev-libs/re2:= )
+ sqlite? ( >=dev-db/sqlite-3.0 )
+ ssl? ( dev-libs/openssl:= )
+ tre? ( dev-libs/tre )"
+DEPEND="${RDEPEND}"
+
+DOCS=( docs/. .configure/apparmor )
+PATCHES=( "${WORKDIR}"/${P}-fix-build-paths.patch )
+
+src_configure() {
+ local extras=""
+
+ use argon2 && extras+="argon2,"
+ use gnutls && extras+="ssl_gnutls,"
+ use ldap && extras+="ldap,"
+ use maxminddb && extras+="geo_maxmind,"
+ use mbedtls && extras+="ssl_mbedtls,"
+ use mysql && extras+="mysql,"
+ use pcre && extras+="regex_pcre,"
+ use pcre2 && extras+="regex_pcre2,"
+ use postgres && extras+="pgsql,"
+ use re2 && extras+="regex_re2,"
+ use regex-posix && extras+="regex_posix,"
+ use regex-stdlib && extras+="regex_stdlib,"
+ use sqlite && extras+="sqlite3,"
+ use ssl && extras+="ssl_openssl,"
+ use sslrehashsignal && extras+="sslrehashsignal,"
+ use tre && extras+="regex_tre,"
+
+ # The first configuration run enables certain "extra" InspIRCd
+ # modules, the second run generates the actual makefile.
+ if [[ -n "${extras}" ]]; then
+ ./configure --enable-extras=${extras%,}
+ fi
+
+ local myconf=(
+ --disable-auto-extras
+ --disable-ownership
+ --system
+ --uid ${PN}
+ --gid ${PN}
+ --binary-dir="/usr/bin"
+ --data-dir="/var/lib/${PN}/data"
+ --example-dir="/usr/share/doc/${PV}"
+ --manual-dir="/usr/share/man"
+ --module-dir="/usr/$(get_libdir)/${PN}/modules")
+ CXX="$(tc-getCXX)" ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}" $(usev debug INSPIRCD_DEBUG=2) INSPIRCD_VERBOSE=1
+}
+
+src_install() {
+ default
+
+ insinto "/usr/include/${PN}"
+ doins -r include/.
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit .configure/inspircd.service
+
+ keepdir "/var/log/${PN}"
+ insinto "/etc/logrotate.d"
+ newins .configure/logrotate "${PN}"
+
+ diropts -o"${PN}" -g"${PN}" -m0700
+ keepdir "/var/lib/${PN}/data"
+
+ rmdir "${ED}"/run{/inspircd,} || die
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You will find example configuration files under "
+ elog "/usr/share/doc/${PN}"
+ elog "Read the ${PN}.conf.example file carefully before "
+ elog "starting the service."
+ fi
+}
diff --git a/net-irc/inspircd/metadata.xml b/net-irc/inspircd/metadata.xml
index 08f34e02163c..41305043803e 100644
--- a/net-irc/inspircd/metadata.xml
+++ b/net-irc/inspircd/metadata.xml
@@ -12,11 +12,13 @@
para ser estable, moderno y ligero.
</longdescription>
<use>
+ <flag name="argon2">Enable Argon2 hashes in modules</flag>
<flag name="gnutls">Enable TLS support</flag>
<flag name="ldap">Enable LDAP support</flag>
<flag name="maxminddb">Add support for geolocation using libMaxMindDB</flag>
<flag name="mbedtls">Add support for TLS using the mbedTLS library</flag>
<flag name="mysql">Enable MySQL database backend</flag>
+ <flag name="pcre2">Add support for Perl Compatible Regular Expressions 2</flag>
<flag name="postgres">Enable PostgreSQL database backend</flag>
<flag name="re2">Add support for Google RE2 regular expressions library</flag>
<flag name="regex-posix">Add support for POSIX Regular Expressions</flag>