summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-06-21 01:36:01 +0300
committerMichał Górny <mgorny@gentoo.org>2019-07-06 09:02:54 +0200
commit8ffb9961657028bdacc37362aeb7aa1ac877cc15 (patch)
tree5df303aae3d917097641e34f4a83bab7c6921113 /net-libs/libvncserver/files
parentnet-libs/libvncserver: drop redundant USE-flags (diff)
downloadgentoo-8ffb9961657028bdacc37362aeb7aa1ac877cc15.tar.gz
gentoo-8ffb9961657028bdacc37362aeb7aa1ac877cc15.tar.bz2
gentoo-8ffb9961657028bdacc37362aeb7aa1ac877cc15.zip
net-libs/libvncserver: reorganize ssl/crypto deps
* no longer depend on libgcrypt when gnutls USE-flag is enabled * put gnutls dependency behind ssl USE-flag openssl/libressl also provides crypto (if gcrypt is not enabled), but lets leave them behind ssl USE-flag anyway. Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/libvncserver/files')
-rw-r--r--net-libs/libvncserver/files/libvncserver-0.9.12-libgcrypt.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libvncserver/files/libvncserver-0.9.12-libgcrypt.patch b/net-libs/libvncserver/files/libvncserver-0.9.12-libgcrypt.patch
new file mode 100644
index 000000000000..a0313562ff1b
--- /dev/null
+++ b/net-libs/libvncserver/files/libvncserver-0.9.12-libgcrypt.patch
@@ -0,0 +1,40 @@
+From 57be637006a95091119f7a49b4232e461116520f Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Sat, 25 May 2019 02:02:47 +0300
+Subject: [PATCH] crypto: rfbcrypto_gnutls is actually libgcrypt-based
+
+Long time ago gnutls used libgcrypt as a cryptographic backend. Perhaps
+that was what caused the confusion.
+---
+ CMakeLists.txt | 9 ++++-----
+ common/{rfbcrypto_gnutls.c => rfbcrypto_libgcrypt.c} | 0
+ 2 files changed, 4 insertions(+), 5 deletions(-)
+ rename common/{rfbcrypto_gnutls.c => rfbcrypto_libgcrypt.c} (100%)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b9ca4ba..0d3b4dc 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -226,11 +226,10 @@ if(SYSTEMD_FOUND)
+ endif(SYSTEMD_FOUND)
+
+ if(LIBVNCSERVER_HAVE_SYS_UIO_H)
+- if(GNUTLS_FOUND)
+- message(STATUS "Building crypto with GnuTLS")
+- set(CRYPTO_LIBRARIES ${GNUTLS_LIBRARIES})
+- set(CRYPTO_SOURCES ${COMMON_DIR}/rfbcrypto_gnutls)
+- include_directories(${GNUTLS_INCLUDE_DIR})
++ if(WITH_GCRYPT AND LIBGCRYPT_LIBRARIES)
++ message(STATUS "Building crypto with Libgcrypt")
++ set(CRYPTO_LIBRARIES ${LIBGCRYPT_LIBRARIES})
++ set(CRYPTO_SOURCES ${COMMON_DIR}/rfbcrypto_libgcrypt)
+ elseif(OPENSSL_FOUND)
+ message(STATUS "Building crypto with OpenSSL")
+ set(CRYPTO_LIBRARIES ${OPENSSL_LIBRARIES})
+diff --git a/common/rfbcrypto_gnutls.c b/common/rfbcrypto_libgcrypt.c
+similarity index 100%
+rename from common/rfbcrypto_gnutls.c
+rename to common/rfbcrypto_libgcrypt.c
+--
+2.21.0
+