summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-12-30 20:30:18 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-12-30 20:30:18 +0100
commita62dc01ebebe7a20eb595d0ff1e54508e9bd91ac (patch)
tree0cc9f9be0228725f7f0c99c7c91370a19ffe368f /net-libs
parentnet-libs/rpcsvc-proto: Bump to v1.3 (diff)
downloadgentoo-a62dc01ebebe7a20eb595d0ff1e54508e9bd91ac.tar.gz
gentoo-a62dc01ebebe7a20eb595d0ff1e54508e9bd91ac.tar.bz2
gentoo-a62dc01ebebe7a20eb595d0ff1e54508e9bd91ac.zip
net-libs/zeromq: Bump to v4.2.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/zeromq/Manifest1
-rw-r--r--net-libs/zeromq/zeromq-4.2.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/zeromq/Manifest b/net-libs/zeromq/Manifest
index 8e54f7f657bf..77a2488446f6 100644
--- a/net-libs/zeromq/Manifest
+++ b/net-libs/zeromq/Manifest
@@ -6,3 +6,4 @@ DIST zeromq-4.1.6.tar.gz 799771 BLAKE2B 91ecc39122199846bfe0d9ea49c2acc076d0f827
DIST zeromq-4.2.0.tar.gz 1046254 BLAKE2B d14bad19861cef7bfd58f571118e5dce89afecf1b80c05c6089f7669b702c38a93825e736e73988cae3f2ce90ab4a3fc28dc34b5ca2e6ff0a12707eb238bc05e SHA512 3b6f0a1869fb1663ea40b3c3aa088b81399a35c051e4ade2b30bbac60bfceefe6b4403248a4635fb31d33767c1e478342f61c47b0ffdb4501419c13590ebeb96
DIST zeromq-4.2.1.tar.gz 1243428 BLAKE2B 2112f127d5e9624861adad455e77c21b17db09123adbe6473e86575a63ca1c21634078cce9af13e9ea1cc24e68658ae56172d98f24478161c14c5be56a922739 SHA512 6ef52edff930be34451e81bd21a7e23f08e135c8e10e006d0a6146e7fa4171e9dcf9065f77c33cb0c0db4c16cff4a50cab2a9d612e306490a02bc6a4a913ba6a
DIST zeromq-4.2.2.tar.gz 1236437 BLAKE2B 7104f8ad28cc00f1ba6d6cb5dbb9aa466971c73a513e206eee77db293f4e4845106910d539363dc0c21de7e83885056453a530c941c38e19c5ec1fa836e1bca0 SHA512 d78813a61ce3311a1f8c230f7da0f5aedc97ef4b792afb6d398c5710da239348c0c7a67bdfeb38a7ab0282af498f1ed173649aff4add1bc35f0ef1b66f965443
+DIST zeromq-4.2.3.tar.gz 1326780 BLAKE2B f76ff6461e5a180221b1fff471e795a457fe4f26ec1ca725438aff4e240be7da80e42b2aea49845b5712e1d63590f64bc681f9a793bcf4d32fe0ee08bcab482c SHA512 8ac588a7a4db9d65586dd7b501999edac151e1d03056c1014d7ded6cd4bcf5bb4f81252b47d89d60c3ad7d527685218992bf5853b4656c0702e0f64c2d77712b
diff --git a/net-libs/zeromq/zeromq-4.2.3.ebuild b/net-libs/zeromq/zeromq-4.2.3.ebuild
new file mode 100644
index 000000000000..cdef847f86e4
--- /dev/null
+++ b/net-libs/zeromq/zeromq-4.2.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="A brokerless kernel"
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc pgm +sodium static-libs test unwind elibc_Darwin"
+
+RDEPEND="
+ !elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
+ sodium? ( dev-libs/libsodium:= )
+ pgm? ( =net-libs/openpgm-5.2.122 )"
+DEPEND="${RDEPEND}
+ !elibc_Darwin? ( sys-apps/util-linux )
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ pgm? ( virtual/pkgconfig )"
+
+PATCHES=()
+
+src_prepare() {
+ sed \
+ -e '/libzmq_werror=/s:yes:no:g' \
+ -i configure.ac || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable unwind libunwind)
+ $(use_with sodium libsodium)
+ $(use_with pgm)
+ $(use_with doc docs)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Restricting to one job because multiple tests are using the same port.
+ # Upstream knows the problem and says it doesn't support parallel test
+ # execution, see ${S}/INSTALL.
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}