summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-17 00:25:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-17 00:25:57 +0200
commitf53335b1893f7d1d7e07189b649464ce7999ac27 (patch)
tree33089b4a9a490df0e3da23aa970e6fe883638052 /net-libs
parentdev-libs/libwbxml: EAPI-6 bump (diff)
downloadgentoo-f53335b1893f7d1d7e07189b649464ce7999ac27.tar.gz
gentoo-f53335b1893f7d1d7e07189b649464ce7999ac27.tar.bz2
gentoo-f53335b1893f7d1d7e07189b649464ce7999ac27.zip
net-libs/zmqpp: EAPI-6 bump
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/zmqpp/zmqpp-4.2.0.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/net-libs/zmqpp/zmqpp-4.2.0.ebuild b/net-libs/zmqpp/zmqpp-4.2.0.ebuild
index 4eb86e192ea6..b78adb04f7a4 100644
--- a/net-libs/zmqpp/zmqpp-4.2.0.ebuild
+++ b/net-libs/zmqpp/zmqpp-4.2.0.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit cmake-utils
-
-DESCRIPTION="ZeroMQ 'highlevel' C++ bindings"
-HOMEPAGE="https://github.com/zeromq/zmqpp"
if [[ $PV == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/zeromq/zmqpp.git"
else
SRC_URI="https://github.com/zeromq/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
fi
+inherit cmake-utils
-KEYWORDS="~amd64 ~x86"
+DESCRIPTION="ZeroMQ 'highlevel' C++ bindings"
+HOMEPAGE="https://github.com/zeromq/zmqpp"
LICENSE="MPL-2.0"
SLOT="0"
@@ -23,15 +22,13 @@ IUSE="static-libs"
DEPEND="net-libs/zeromq[static-libs?]"
RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}/${P}-multilib-strict.patch"
-)
+PATCHES=( "${FILESDIR}/${P}-multilib-strict.patch" )
src_configure() {
local mycmakeargs=(
-DIS_TRAVIS_CI_BUILD=OFF
-DZMQPP_BUILD_SHARED=ON
- $(cmake-utils_use static-libs ZMQPP_BUILD_STATIC)
+ -DZMQPP_BUILD_STATIC=$(usex static-libs)
)
cmake-utils_src_configure