summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2016-10-10 22:32:45 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2016-10-10 22:33:10 +0100
commitaec8fc565b34c9dadbfd5c8eb54dc0f9a83f480e (patch)
tree8621776cf4b6235315b5ef9a2674892cab4d0f6b /net-mail
parentprofiles/package.mask: mask dev-python/pylons* for removal. (diff)
downloadgentoo-aec8fc565b34c9dadbfd5c8eb54dc0f9a83f480e.tar.gz
gentoo-aec8fc565b34c9dadbfd5c8eb54dc0f9a83f480e.tar.bz2
gentoo-aec8fc565b34c9dadbfd5c8eb54dc0f9a83f480e.zip
net-mail/notmuch: Bump version to 0.23
Package-Manager: portage-2.3.1
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/Manifest1
-rw-r--r--net-mail/notmuch/metadata.xml2
-rw-r--r--net-mail/notmuch/notmuch-0.23.ebuild200
3 files changed, 202 insertions, 1 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
index 5334138be324..e1a3eb196946 100644
--- a/net-mail/notmuch/Manifest
+++ b/net-mail/notmuch/Manifest
@@ -4,3 +4,4 @@ DIST notmuch-0.19.tar.gz 659038 SHA256 396fc6548423785ebbbe9a6cce321d957d3b2e856
DIST notmuch-0.20.2.tar.gz 652945 SHA256 f741a26345bff389fd8a4a119c4174c6585730f71844809583a54ef2a865adec SHA512 08ab75df324f232edd7c36f73d01d7453c058ffb55c4f548afdf9abe843317c1d7066f21e7600c66c53577f7d31787914bf69743aa5d221e239e182452681c75 WHIRLPOOL 1698cb1b09046f50a57ebf23625a2dd68f86cac7cb1142be81e77b5625e49960cb2311c8acff44de0894238bced48853cdd72b7edf34109ecee0bc53d5b086fc
DIST notmuch-0.21.tar.gz 663600 SHA256 d06f8ffed168c7d53ffc449dd611038b5fa90f7ee22d58f3bec3b379571e25b3 SHA512 2485c422433be21f6bf89aaf997e1468c31a52029ddc8336e78a632b292c659569448c29813ea550ed27fb6815558522a451a7fa10e8fb3f87d9538b4dd7b01a WHIRLPOOL 303c6427822272834e3d95ac94760f0fbaf3f2947a984a6770a9b2918fe0fbad289ef95fb9a8300cb6db08ab3ef0ff56810b3a60879c6a2a3eac524689f0a2f0
DIST notmuch-0.22.2.tar.gz 683796 SHA256 6cd19c61634079981b2d8f4b7cb4eb953cba2a36272520603682d813d2bd7ed1 SHA512 cc11feb8d1c2c7959a42e032c1e36e828290a8e8477af8936a27654117fbc2e080c71fe69ec92bd80763d9d3b163d45b7c0fa9fe9c4ec649600fa928110da4ee WHIRLPOOL 6aa41fa26a92a11393193b6f7e147b69de00f57fe712486805b2b7019d9bf9887d6d10962ef4144ca9ef07d6f63bbb1ddb2f7104c6eb89841285620d439743be
+DIST notmuch-0.23.tar.gz 689540 SHA256 c5e75b658ee2b58c5ac7a79e34d2449d37ddfa5c9e67a736454ec296c9a0a1b8 SHA512 87e3bb97035cc2d48b5b1cfdebf49576de96498d54192f7a58976e495b8b77672037a9702af194d882e9eb1e0252daeb01f49df90709434ff04d2b3db236a039 WHIRLPOOL 256d43ccf43d7c83a83ceb1fb55b223e47b1b339a938dfeeb77feae2a3bff60e0449b7bfdf155a2afbd9d10c3416e7fe6e1ed7b7f22d305aef727473d63b77fb
diff --git a/net-mail/notmuch/metadata.xml b/net-mail/notmuch/metadata.xml
index 332a3c073f59..c91b250fcc97 100644
--- a/net-mail/notmuch/metadata.xml
+++ b/net-mail/notmuch/metadata.xml
@@ -6,7 +6,7 @@
<name>Amadeusz Żołnowski</name>
</maintainer>
<use>
- <flag name="doc">Install API documentation for enabled bindings</flag>
+ <flag name="doc">Install API documentation</flag>
<flag name="crypt">Support decryption and verification of PGP/MIME
messages and in Emacs UI - encryption; support also S/MIME
signature verification since version 0.22</flag>
diff --git a/net-mail/notmuch/notmuch-0.23.ebuild b/net-mail/notmuch/notmuch-0.23.ebuild
new file mode 100644
index 000000000000..66c7df98bc42
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.23.ebuild
@@ -0,0 +1,200 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
+ distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz
+ test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~x86"
+REQUIRED_USE="
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python valgrind )
+ "
+IUSE="crypt doc emacs mutt nmbug python test valgrind"
+
+CDEPEND="
+ >=app-shells/bash-completion-1.9
+ >=dev-libs/glib-2.22:2
+ >=dev-libs/gmime-2.6.20-r2:2.6
+ >=dev-libs/xapian-1.2.7-r2:=
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=sys-libs/zlib-1.2.5.2
+ sys-libs/talloc
+ crypt? ( >=dev-libs/gmime-2.6.20-r2:2.6[smime] )
+ emacs? ( >=virtual/emacs-23 )
+ python? ( ${PYTHON_DEPS} )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
+ >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb
+ crypt? ( app-crypt/gnupg dev-libs/openssl ) )
+ valgrind? ( dev-util/valgrind )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git )
+ mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
+ dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+
+bindings() {
+ local ret=0
+
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ "$@"
+ ret=$?
+ popd || die
+ fi
+
+ return $ret
+}
+
+pkg_pretend() {
+ if has_version '<net-mail/notmuch-0.18'; then
+ ewarn
+ ewarn "There are few not backward compatible changes between"
+ ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
+ ewarn "(0.18 section) for details before first use!"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+}
+
+src_unpack() {
+ unpack "${P}".tar.gz
+ if use test; then
+ mkdir -p "${S}"/test/test-databases || die
+ cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ bindings python distutils-r1_src_prepare
+ bindings python mv README README-python || die
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ rm -f Makefile.config # assure that new Makefile.config will be generated
+
+ if use test; then
+ append-cflags -g
+ append-cxxflags -g
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with emacs)
+ $(use_with doc api-docs)
+ )
+ tc-export CC CXX
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ V=1 default
+ bindings python distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ rm -r html/_sources || die
+ rm html/{objects.inv,.buildinfo} || die
+ mkdir -p ../html && mv html ../html/python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin devel/nmbug/nmbug
+ dobin devel/nmbug/notmuch-report
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ DOCS="" bindings python distutils-r1_src_install
+ use doc && bindings python dodoc -r html
+}
+
+pkg_preinst() {
+ if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}