summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-02-16 11:24:24 -0500
committerMichael Orlitzky <mjo@gentoo.org>2019-02-16 11:31:58 -0500
commitdec77c2cdea324c5a0c50cf7a29afbd81b2aad73 (patch)
tree42d7866e5b4a84293c102cfa48efb403f8ff53a4 /net-mail
parentdev-util/jenkins-bin: fix Manifest (diff)
downloadgentoo-dec77c2cdea324c5a0c50cf7a29afbd81b2aad73.tar.gz
gentoo-dec77c2cdea324c5a0c50cf7a29afbd81b2aad73.tar.bz2
gentoo-dec77c2cdea324c5a0c50cf7a29afbd81b2aad73.zip
net-mail/amavis-logwatch: new revision with another custom patch.
This -r5 adds handle-clamd-select-failed.patch, which allows the program to match those types of lines. Signed-off-by: Michael Orlitzky <mjo@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/amavis-logwatch/amavis-logwatch-1.51.03-r5.ebuild (renamed from net-mail/amavis-logwatch/amavis-logwatch-1.51.03-r4.ebuild)3
-rw-r--r--net-mail/amavis-logwatch/files/handle-clamd-select-failed.patch38
2 files changed, 40 insertions, 1 deletions
diff --git a/net-mail/amavis-logwatch/amavis-logwatch-1.51.03-r4.ebuild b/net-mail/amavis-logwatch/amavis-logwatch-1.51.03-r5.ebuild
index db425aabba89..c7c607e6427a 100644
--- a/net-mail/amavis-logwatch/amavis-logwatch-1.51.03-r4.ebuild
+++ b/net-mail/amavis-logwatch/amavis-logwatch-1.51.03-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}/no-pid_file-configured.patch"
"${FILESDIR}/will-bind-to-lines.patch"
"${FILESDIR}/SANITIZED-NULL-bytes-messages.patch"
+ "${FILESDIR}/handle-clamd-select-failed.patch"
)
src_prepare() {
diff --git a/net-mail/amavis-logwatch/files/handle-clamd-select-failed.patch b/net-mail/amavis-logwatch/files/handle-clamd-select-failed.patch
new file mode 100644
index 000000000000..83dad161e18a
--- /dev/null
+++ b/net-mail/amavis-logwatch/files/handle-clamd-select-failed.patch
@@ -0,0 +1,38 @@
+From 869fa9d8b2113f50c3a97ef9f4a1f95171702be4 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 13 Feb 2019 11:25:33 -0500
+Subject: [PATCH 1/1] Catch "Select failed: Interrupted system call" entries
+ from clamd.
+
+When a select() call in clamd is interrupted, amavis logs the
+following warning:
+
+ ClamAV-clamd: Select failed: Interrupted system call at /usr/sbin/amavisd
+ line 8472, <GEN16> line 296., retrying (1)
+
+These are harmless in and of themselves, but we would like to classify
+them as warnings. Currently they are unmatched. This commit adds a
+pattern for them, moving them from the "Unmatched Entries" heading to
+"Miscellaneous warnings" instead. Afterwards, the report looks like,
+
+ 24 Miscellaneous warnings --------------------------------
+ 2 ClamAV-clamd: Select failed: Interrupted system call
+---
+ amavis-logwatch | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/amavis-logwatch b/amavis-logwatch
+index 044c94d..4c9b59f 100644
+--- a/amavis-logwatch
++++ b/amavis-logwatch
+@@ -2817,6 +2817,7 @@ while (<>) {
+ ($p1 =~ /^TROUBLE/) or
+ ($p1 =~ /Can't (?:connect to UNIX|send to) socket/) or
+ ($p1 =~ /: Empty result from /) or
++ ($p1 =~ /: Select failed: Interrupted system call/) or
+ ($p1 =~ /: Error reading from socket: Connection reset by peer/) or
+ ($p1 =~ /open\(.*\): Permission denied/) or
+ ($p1 =~ /^_?WARN: /) or
+--
+2.19.2
+