summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-13 13:44:45 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-13 13:45:19 +0200
commit64e2b7590889d33ecf888c528bfaefdbc341c932 (patch)
treea513ae530b6b77a2350eef1c31a96eb12f1af95b /net-misc/cni-plugins
parentnet-analyzer/ntopng: blocking net-libs/nDPI as it causes errors in this version (diff)
downloadgentoo-64e2b7590889d33ecf888c528bfaefdbc341c932.tar.gz
gentoo-64e2b7590889d33ecf888c528bfaefdbc341c932.tar.bz2
gentoo-64e2b7590889d33ecf888c528bfaefdbc341c932.zip
net-misc/cni-plugins: Initial version
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-misc/cni-plugins')
-rw-r--r--net-misc/cni-plugins/Manifest1
-rw-r--r--net-misc/cni-plugins/cni-plugins-0.6.0.ebuild36
-rw-r--r--net-misc/cni-plugins/metadata.xml11
3 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/cni-plugins/Manifest b/net-misc/cni-plugins/Manifest
new file mode 100644
index 000000000000..b6133f4cd9d7
--- /dev/null
+++ b/net-misc/cni-plugins/Manifest
@@ -0,0 +1 @@
+DIST cni-plugins-0.6.0.tar.gz 787756 SHA256 8589670f7f9b211a351dfcd211d4fe0b961d77283a7415443dc188f3dbf05668 SHA512 4b3c1901154eb1af86dc35888fda7b7666ee88d2cf728fb09182df5385d32b747de34c5c01598e1f37ae1e3497dbf5af2bc6ad6f737e683ccfccf9c1860cf6dc WHIRLPOOL 4e06c4b54144139509148cb851182dfa642fa4614fc392304bdc541611dc8bb34c978e9ff6507bb55a46a4d0f016feaf615abd09cdfb303e1f9e995162a19351
diff --git a/net-misc/cni-plugins/cni-plugins-0.6.0.ebuild b/net-misc/cni-plugins/cni-plugins-0.6.0.ebuild
new file mode 100644
index 000000000000..7a785167042e
--- /dev/null
+++ b/net-misc/cni-plugins/cni-plugins-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+DESCRIPTION="Standard networking plugins for container networking"
+EGO_PN="github.com/containernetworking/plugins"
+HOMEPAGE="https://github.com/containernetworking/plugins"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+src_compile() {
+ pushd src || die
+ local i
+ for i in plugins/{meta/{flannel,portmap,tuning},main/{bridge,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local},sample}; do
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${WORKDIR}/${P}" go install -v "${EGO_PN}/${i}"
+ done
+ popd || die
+}
+
+src_install() {
+ exeinto /opt/cni/bin
+ doexe bin/*
+ pushd src/${EGO_PN} || die
+ dodoc README.md
+ local i
+ for i in plugins/{meta/{flannel,portmap,tuning},main/{bridge,ipvlan,loopback,macvlan,ptp,vlan},ipam/{dhcp,host-local},sample}; do
+ newdoc README.md ${i##*/}.README.md
+ done
+ popd || die
+}
diff --git a/net-misc/cni-plugins/metadata.xml b/net-misc/cni-plugins/metadata.xml
new file mode 100644
index 000000000000..deec70d1fa6f
--- /dev/null
+++ b/net-misc/cni-plugins/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Manuel Rüger</name>
+ <email>mrueg@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containernetworking/plugins</remote-id>
+ </upstream>
+</pkgmetadata>