summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/gupnp-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/gupnp-tools')
-rw-r--r--net-misc/gupnp-tools/Manifest2
-rw-r--r--net-misc/gupnp-tools/gupnp-tools-0.8.10.ebuild33
-rw-r--r--net-misc/gupnp-tools/gupnp-tools-0.8.9.ebuild34
-rw-r--r--net-misc/gupnp-tools/metadata.xml5
4 files changed, 74 insertions, 0 deletions
diff --git a/net-misc/gupnp-tools/Manifest b/net-misc/gupnp-tools/Manifest
new file mode 100644
index 000000000000..af0381ab7c57
--- /dev/null
+++ b/net-misc/gupnp-tools/Manifest
@@ -0,0 +1,2 @@
+DIST gupnp-tools-0.8.10.tar.xz 487716 SHA256 592c53289ff1cd70e676405c56ca87b28d2da37a385d34a3bb9b944ba9108d17 SHA512 d6de9ef5700e1e783a4300317874a362f0d3ca475778a118acf00af4f9204a5d80b461a10407b47031025ddd8e6070ee372efc7e989ad2bf563d896abf10a362 WHIRLPOOL 197edcb39f918c0c13d3a9cda9024bbbe30572b226a25d80fc95c732eca6fe423615aa1169096ea23043bb4e6d17ac50e04a523f34ddad75d5759effb69c55b7
+DIST gupnp-tools-0.8.9.tar.xz 479616 SHA256 c0c3c7a6eacfeb83aa6c5acd5e2f48e1c12da6fb45cac14a972961d7918e8072 SHA512 2ca7a75f2019fc8ae84e477c3bed727913bdd4d00c27a8eb5d64afd47521b5f73d2c24564e757319cdb7c188bc6e27b7e22c9b08b5dbe74a7416dae0b029c073 WHIRLPOOL 355604537216ba791a91be9c2179e51b14cd56e97f2238479793ba86d7fd001ed4b370f79bda3485bc6216d0d23c77b902416604cf7005c01ff0b73f47876e46
diff --git a/net-misc/gupnp-tools/gupnp-tools-0.8.10.ebuild b/net-misc/gupnp-tools/gupnp-tools-0.8.10.ebuild
new file mode 100644
index 000000000000..f685f66d564e
--- /dev/null
+++ b/net-misc/gupnp-tools/gupnp-tools-0.8.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Free replacements of Intel UPnP tools that use GUPnP"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.24:2
+ >=dev-libs/libxml2-2.4:2
+ >=net-libs/gssdp-0.13.3
+ >=net-libs/gupnp-0.20.8
+ >=net-libs/gupnp-av-0.5.5
+ net-libs/libsoup:2.4
+ sys-apps/util-linux
+ >=x11-libs/gtk+-3.10:3
+ >=x11-libs/gtksourceview-3.2:3.0
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.6
+ sys-devel/gettext
+ virtual/pkgconfig
+"
diff --git a/net-misc/gupnp-tools/gupnp-tools-0.8.9.ebuild b/net-misc/gupnp-tools/gupnp-tools-0.8.9.ebuild
new file mode 100644
index 000000000000..9254a8ae65ae
--- /dev/null
+++ b/net-misc/gupnp-tools/gupnp-tools-0.8.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Free replacements of Intel UPnP tools that use GUPnP"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.24:2
+ >=dev-libs/libxml2-2.4:2
+ >=net-libs/gssdp-0.13.3
+ >=net-libs/gupnp-0.20.8
+ >=net-libs/gupnp-av-0.5.5
+ net-libs/libsoup:2.4
+ sys-apps/util-linux
+ >=x11-libs/gtk+-3:3
+ >=x11-libs/gtksourceview-3.2:3.0
+ >=x11-themes/gnome-icon-theme-2.20
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.6
+ sys-devel/gettext
+ virtual/pkgconfig
+"
diff --git a/net-misc/gupnp-tools/metadata.xml b/net-misc/gupnp-tools/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-misc/gupnp-tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>