summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/gwhois
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/gwhois')
-rw-r--r--net-misc/gwhois/Manifest1
-rw-r--r--net-misc/gwhois/files/gwhois.xinetd18
-rw-r--r--net-misc/gwhois/gwhois-20120626.ebuild47
-rw-r--r--net-misc/gwhois/metadata.xml17
4 files changed, 83 insertions, 0 deletions
diff --git a/net-misc/gwhois/Manifest b/net-misc/gwhois/Manifest
new file mode 100644
index 000000000000..4b7caee10f86
--- /dev/null
+++ b/net-misc/gwhois/Manifest
@@ -0,0 +1 @@
+DIST gwhois_20120626.tar.gz 41698 SHA256 8d72f3228ff3f4334d8d9455434fdf38284c3f6db70de815a387f19b28bcefd6 SHA512 8ffaa611389929435f70d3f020e28249e6e3109c4e822e9318b050f52cf09d6934adbb14ab67a6361574ce8645656d5eaf24808dea453f2187352fc2b2513e0e WHIRLPOOL 1aede56813b9eec3e37c425b267b8894fdf14cc3a24af281c325efbe93a9688de72821a15d7e5517d1f1134b02625251ed273298c5d71f862084f6ab3c425c2e
diff --git a/net-misc/gwhois/files/gwhois.xinetd b/net-misc/gwhois/files/gwhois.xinetd
new file mode 100644
index 000000000000..b518371dd9df
--- /dev/null
+++ b/net-misc/gwhois/files/gwhois.xinetd
@@ -0,0 +1,18 @@
+## whois service
+service whois
+{
+ disable = no
+ socket_type = stream
+ protocol = tcp
+ port = 43
+ wait = no
+ user = gwhois
+# group =
+ server = /usr/bin/gwhois
+# server_args =
+ only_from = 0.0.0.0
+ instances = 20
+ log_on_success += PID HOST DURATION USERID EXIT
+ log_on_failure += HOST USERID
+ nice = 5
+}
diff --git a/net-misc/gwhois/gwhois-20120626.ebuild b/net-misc/gwhois/gwhois-20120626.ebuild
new file mode 100644
index 000000000000..d5674a8bb60d
--- /dev/null
+++ b/net-misc/gwhois/gwhois-20120626.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P=${P/_p/.}
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="generic whois"
+HOMEPAGE="http://gwhois.de/"
+SRC_URI="http://gwhois.de/gwhois/${MY_P/-/_}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="www-client/lynx
+ net-misc/curl
+ dev-lang/perl
+ dev-perl/libwww-perl
+ dev-perl/Net-LibIDN"
+
+src_install() {
+ dodir /etc/gwhois
+ insinto /etc/gwhois
+ doins pattern
+ dobin gwhois
+ doman gwhois.1
+ dodoc TODO "${FILESDIR}/gwhois.xinetd" README.RIPE
+ einfo ""
+ einfo "See included gwhois.xinetd for an example on how to"
+ einfo "use gwhois as a whois proxy using xinetd."
+ einfo "Just copy gwhois.xinetd to /etc/xinetd.d/gwhois"
+ einfo "and reload xinetd."
+ einfo ""
+}
+
+pkg_postinst() {
+ if [ -f /etc/gwhois/pattern.ripe ]; then
+ ewarn ""
+ ewarn "Will move old /etc/gwhois/pattern.ripe to removethis-pattern.ripe"
+ ewarn "as it causes malfunction with this version."
+ ewarn "If you did not modify the file, just remove it."
+ ewarn ""
+ mv /etc/gwhois/pattern.ripe /etc/gwhois/removethis-pattern.ripe
+ fi
+}
diff --git a/net-misc/gwhois/metadata.xml b/net-misc/gwhois/metadata.xml
new file mode 100644
index 000000000000..12152959d0ab
--- /dev/null
+++ b/net-misc/gwhois/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+gwhois is a generic whois client which can be used as a commandline
+whois client or as a whois proxy service using (x)inetd
+</longdescription>
+<longdescription lang="ja">
+gwhois は (x)inetd 経由のプロクシ・サービスとして利用できるコマンド
+ライン操作の一般的 whois クライアントです。
+</longdescription>
+</pkgmetadata>