summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/netpipe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/netpipe')
-rw-r--r--net-misc/netpipe/Manifest1
-rw-r--r--net-misc/netpipe/metadata.xml7
-rw-r--r--net-misc/netpipe/netpipe-1.0.0_beta2-r1.ebuild30
-rw-r--r--net-misc/netpipe/netpipe-1.0.0_beta2.ebuild33
4 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/netpipe/Manifest b/net-misc/netpipe/Manifest
new file mode 100644
index 000000000000..5019cca38aa4
--- /dev/null
+++ b/net-misc/netpipe/Manifest
@@ -0,0 +1 @@
+DIST netpipe.tar.gz 30593 RMD160 7146d29bdb00ca36a3c3d0fa5a9cb5b026d50982 SHA1 3d5199e92fe5b954b18a42ae4cfd9aaf76e94f75 SHA256 89cfcd5ca5898d77fd5cd64634610667f3b9e087db20536d7636739295d7cdf3
diff --git a/net-misc/netpipe/metadata.xml b/net-misc/netpipe/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/net-misc/netpipe/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-misc/netpipe/netpipe-1.0.0_beta2-r1.ebuild b/net-misc/netpipe/netpipe-1.0.0_beta2-r1.ebuild
new file mode 100644
index 000000000000..2386dd5d4de4
--- /dev/null
+++ b/net-misc/netpipe/netpipe-1.0.0_beta2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="tool to reliably distribute binary data using UDP broadcasting techniques"
+HOMEPAGE="http://www.wudika.de/~jan/netpipe/"
+SRC_URI="http://www.wudika.de/~jan/${PN}/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:^OPT=.*:OPT = ${CFLAGS} ${LDFLAGS}:" \
+ -e "s:^CC=.*:CC = $(tc-getCC):" \
+ Makefile || die "sed failed"
+}
+
+src_install() {
+ dobin netpipe || die "dobin failed"
+ dodoc DOCUMENTATION INSTALL TECH-NOTES || die
+}
diff --git a/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
new file mode 100644
index 000000000000..01ab500684d1
--- /dev/null
+++ b/net-misc/netpipe/netpipe-1.0.0_beta2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="tool to reliably distribute binary data using UDP broadcasting techniques"
+HOMEPAGE="http://www.wudika.de/~jan/netpipe/"
+SRC_URI="http://www.wudika.de/~jan/netpipe/${PN}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:^OPT=.*:OPT = ${CFLAGS}:" \
+ -e "s:^CC=.*:CC = $(tc-getCC):" \
+ Makefile
+}
+
+src_install() {
+ dobin netpipe || die "dobin failed"
+ dodoc DOCUMENTATION INSTALL TECH-NOTES
+}