summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-06-20 18:03:17 -0400
committerMike Frysinger <vapier@gentoo.org>2018-06-26 04:18:50 -0400
commit4db7e4be4eb444afc5c074bed7b68dcfc8954c3f (patch)
tree38fb0ccbb60c77d89e6804b0188f369f5794e44e /net-misc/openssh
parentnet-misc/openssh: update set of locale vars #367017 (diff)
downloadgentoo-4db7e4be4eb444afc5c074bed7b68dcfc8954c3f.tar.gz
gentoo-4db7e4be4eb444afc5c074bed7b68dcfc8954c3f.tar.bz2
gentoo-4db7e4be4eb444afc5c074bed7b68dcfc8954c3f.zip
net-misc/openssh: send & accept COLORTERM env var #658540
For terminal emulators that set this variable, pass it along. Url: https://gist.github.com/XVilka/8346728 Bug: https://bugs.gentoo.org/658540
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/openssh-7.7_p1-r102.ebuild6
-rw-r--r--net-misc/openssh/openssh-7.7_p1-r6.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/net-misc/openssh/openssh-7.7_p1-r102.ebuild b/net-misc/openssh/openssh-7.7_p1-r102.ebuild
index 5bea8702b077..c4747a2597ee 100644
--- a/net-misc/openssh/openssh-7.7_p1-r102.ebuild
+++ b/net-misc/openssh/openssh-7.7_p1-r102.ebuild
@@ -345,6 +345,9 @@ tweak_ssh_configs() {
# Allow client to pass locale environment variables. #367017
AcceptEnv ${locale_vars[*]}
+
+ # Allow client to pass COLORTERM to match TERM. #658540
+ AcceptEnv COLORTERM
EOF
# Then the client config.
@@ -352,6 +355,9 @@ tweak_ssh_configs() {
# Send locale environment variables. #367017
SendEnv ${locale_vars[*]}
+
+ # Send COLORTERM to match TERM. #658540
+ SendEnv COLORTERM
EOF
if use pam ; then
diff --git a/net-misc/openssh/openssh-7.7_p1-r6.ebuild b/net-misc/openssh/openssh-7.7_p1-r6.ebuild
index 3e0ed629bbce..a8c8b20d4c27 100644
--- a/net-misc/openssh/openssh-7.7_p1-r6.ebuild
+++ b/net-misc/openssh/openssh-7.7_p1-r6.ebuild
@@ -345,6 +345,9 @@ tweak_ssh_configs() {
# Allow client to pass locale environment variables. #367017
AcceptEnv ${locale_vars[*]}
+
+ # Allow client to pass COLORTERM to match TERM. #658540
+ AcceptEnv COLORTERM
EOF
# Then the client config.
@@ -352,6 +355,9 @@ tweak_ssh_configs() {
# Send locale environment variables. #367017
SendEnv ${locale_vars[*]}
+
+ # Send COLORTERM to match TERM. #658540
+ SendEnv COLORTERM
EOF
if use pam ; then